PDA

View Full Version : [SOLVED] Custom Screen Resolution Problems



Mach1723
September 15th, 2009, 05:38 PM
I use version 180 of the nvidia drivers and cant get a custom resolution set, xrandr doesnt work and heres my xorg.conf which was located in etc/X11.
I have done some custom naming of the identifiers.

# xorg.conf (X.Org X Window System server configuration file)

# sudo dpkg-reconfigure -phigh xserver-xorg

Section "Monitor"
Identifier "Monitor"

Modeline "1280x960_60.00" 102.10 1280 1360 1496 1712 960 961 964 994 -HSync +Vsync
Option "PreferredMode" "1280x960_60.00"

EndSection

Section "Screen"
Identifier "Screen"
Monitor "Monitor"
Device "nvid"
DefaultDepth 24
SubSection "Display"
Depth 24
Modes "1280x960""1024x768""800x600"
Virtual 1280 960
EndSubSection
EndSection

Section "Module"
Load "glx"
EndSection

Section "Device"
Identifier "nvid"
Driver "nvidia"
Option "NoLogo" "True"
EndSection
I have been trying to fix this problem for the last day searched google and found plenty of posts on these forums but none of them helped me.

Mach1723
September 15th, 2009, 06:49 PM
i have gotten xrandr working to some extent here is the output when trying to create a new mode.

mach@mach-desktop:~$ gtf 1280 960 60

# 1280x960 @ 60.00 Hz (GTF) hsync: 59.64 kHz; pclk: 102.10 MHz
Modeline "1280x960_60.00" 102.10 1280 1360 1496 1712 960 961 964 994 -HSync +Vsync

mach@mach-desktop:~$ xrandr --newmode "1280x960_60.00" 102.10 1280 1360 1496 1712 960 961 964 994 -HSync +Vsync
X Error of failed request: BadName (named color or font does not exist)
Major opcode of failed request: 153 (RANDR)
Minor opcode of failed request: 16 ()
Serial number of failed request: 18
Current serial number in output stream: 18
mach@mach-desktop:~$

wojox
September 15th, 2009, 06:59 PM
Have you tried:


gksudo nvidia-settings

Makes configuring a little easier.

Mach1723
September 15th, 2009, 07:06 PM
Have you tried:


gksudo nvidia-settingsMakes configuring a little easier.
I have tried that but as far as i can tell it doesnt have anyway of adding a custom resolution.

Mach1723
September 15th, 2009, 09:17 PM
any help!?

Mach1723
September 16th, 2009, 03:23 PM
well i have managed to get my screen resolution stuck at 640x480 here is my current xorg.conf plus some terminal outputs

# nvidia-xconfig: X configuration file generated by nvidia-xconfig
# nvidia-xconfig: version 1.0 (buildmeister@builder63) Mon Mar 23 15:33:27 PST 2009


Section "ServerLayout"
Identifier "Layout0"
Screen 0 "Screen0" 0 0
InputDevice "Keyboard0" "CoreKeyboard"
InputDevice "Mouse0" "CorePointer"
EndSection

Section "Files"
EndSection

Section "Module"
Load "dbe"
Load "extmod"
Load "type1"
Load "freetype"
Load "glx"
EndSection

Section "InputDevice"

# generated from default
Identifier "Mouse0"
Driver "mouse"
Option "Protocol" "auto"
Option "Device" "/dev/psaux"
Option "Emulate3Buttons" "no"
Option "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"

# generated from default
Identifier "Keyboard0"
Driver "kbd"
EndSection

Section "Monitor"
Identifier "Monitor0"
VendorName "Unknown"
ModelName "Unknown"
HorizSync 28.0 - 33.0
VertRefresh 43.0 - 72.0
Option "DPMS

Modeline "1280x960_60.00" 102.10 1280 1360 1496 1712 960 961 964 994 -HSync +Vsync


EndSection

Section "Device"
Identifier "Device"
Driver "nvidia"
VendorName "NVIDIA Corporation"
EndSection

Section "Screen"
Identifier "Screen0"
Device "Device0"
Monitor "Monitor0"
DefaultDepth 24
SubSection "Display"
Depth 24
Modes "1280x960_60.00"
EndSubSection
EndSection

mach@mach-desktop:~$ gtf 1280 960 60

# 1280x960 @ 60.00 Hz (GTF) hsync: 59.64 kHz; pclk: 102.10 MHz
Modeline "1280x960_60.00" 102.10 1280 1360 1496 1712 960 961 964 994 -HSync +Vsync

mach@mach-desktop:~$ xrandr --newmode "1280x960_60.00" 102.10 1280 1360 1496 1712 960 961 964 994 -HSync +Vsync
X Error of failed request: BadName (named color or font does not exist)
Major opcode of failed request: 153 (RANDR)
Minor opcode of failed request: 16 ()
Serial number of failed request: 18
Current serial number in output stream: 18

Mach1723
September 16th, 2009, 04:19 PM
what, have i created/encounted the most unique problem ever?, because i really need nvidia drivers working so i can use graphics programs like blender.(i really dont want to reinstall ubtunu for the second time in 4 days.)

Mach1723
September 16th, 2009, 04:54 PM
i got my resolution alittle higher by changing the Vsync and Hsync in the xorg.conf to 60.0 and 30.0

EDIT: Happy!, i changed the Vsycn and Hsync to 60.0 and i got 800x600 and 1280x960 as resolutions very random but it worked!


# nvidia-xconfig: X configuration file generated by nvidia-xconfig
# nvidia-xconfig: version 1.0 (buildmeister@builder63) Mon Mar 23 15:33:27 PST 2009


Section "ServerLayout"
Identifier "Layout0"
Screen 0 "Screen0" 0 0
InputDevice "Keyboard0" "CoreKeyboard"
InputDevice "Mouse0" "CorePointer"
EndSection

Section "Files"
EndSection

Section "Module"
Load "dbe"
Load "extmod"
Load "type1"
Load "freetype"
Load "glx"
EndSection

Section "InputDevice"

# generated from default
Identifier "Mouse0"
Driver "mouse"
Option "Protocol" "auto"
Option "Device" "/dev/psaux"
Option "Emulate3Buttons" "no"
Option "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"

# generated from default
Identifier "Keyboard0"
Driver "kbd"
EndSection

Section "Monitor"
Identifier "Monitor0"
VendorName "Unknown"
ModelName "Unknown"
HorizSync 60.0 - 60.0
VertRefresh 60.0 - 60.0
Option "DPMS

Modeline "1280x960_60.00" 102.10 1280 1360 1496 1712 960 961 964 994 -HSync +Vsync


EndSection

Section "Device"
Identifier "Device"
Driver "nvidia"
VendorName "NVIDIA Corporation"
EndSection

Section "Screen"
Identifier "Screen0"
Device "Device0"
Monitor "Monitor0"
DefaultDepth 24
SubSection "Display"
Depth 24
Modes "1280x960_60.00"
EndSubSection
EndSection