PDA

View Full Version : [ubuntu] gconf-editor volumes visible setting do not work



szarywilq
September 12th, 2009, 10:18 AM
Hi,

Always after installation of Ubuntu, my first two steps are setting fstab to automatically mount ntfs drives at boot, and using gconf-editor to disable volumes visible option. Few days ago I had to re-install system. Everything works, except those volumes. All settings in gconf-editor which are about icons visible on desktop (trash, home, computer icon etc) do not work. Default is - only volumes are visible. And I can't change it, I can't remove them nor add other icons.

Brascocampbell
September 12th, 2009, 03:27 PM
my gconf problem is similar. all i have is my desktop background and nothing else cant do anything with it.
my error code is 3354
where to go?

szarywilq
September 14th, 2009, 03:10 PM
bump. Any ideas?

drs305
September 14th, 2009, 03:13 PM
Is the desktop turned on? If the Desktop acts like there is a glass pane over it, the Desktop is probably turned off. The Desktop setting is the 'master' - the rest won't work if it isn't on.


gconf-editor /apps/nautilus/preferences/show_desktop
or if you just want to run the command that turns it on:
gconftool-2 --type bool --set /apps/nautilus/preferences/show_desktop 'true'


Are you running compiz?

szarywilq
September 15th, 2009, 08:27 AM
1. show_desktop was TRUE

2. Compiz is completely uninstalled. I have ATI card so I always had problems with it. And I do not need visual desktop effects.

EDIT:
When I set show_desktop to FALSE - volumes icons still on desktop.

szarywilq
September 16th, 2009, 10:18 AM
bump

szarywilq
October 4th, 2009, 11:26 AM
Ok, it is working. I can add or remove icons like trash or home from desktop through gconf.

But during some changes I incidentally pressed "use this key as obligatory" (or something like that I have polish version).

So now, tab apps/nautilus/desktop genarally works. But volumes visible is "protected from writing" (or something like that). How can I change it?

drs305
October 4th, 2009, 12:55 PM
Ok, it is working. I can add or remove icons like trash or home from desktop through gconf.

But during some changes I incidentally pressed "use this key as obligatory" (or something like that I have polish version).

So now, tab apps/nautilus/desktop genarally works. But volumes visible is "protected from writing" (or something like that). How can I change it?

If you mean that you have made a change to a gconf key and don't know how to 'reset' it, right click on the value, then select "Unset Key". This will return the entry to the default value.

szarywilq
October 4th, 2009, 02:51 PM
I tried it first. Didn't worked. I do not know why. This is why I asked here. Then I read somewhere else on the net, that this option SHOULD restore it. So I restarted system, and yes, it worked. Key was unlocked.
But still, when it is set to false, icons are still on desktop.

I'm gonna pass, volumes on desktop are not worth it.

Thanks for all advices.