View Full Version : [ubuntu] Please Help, Accidentally Deleted Kernels and Headers, Can't enter GUI or Access Net

September 2nd, 2009, 10:46 PM
Basically I screwed up. I'm a noob, and I recently upgraded to Jaunty 9.04. Video was causing me problem, so I figured it was the fact I had old kernels I was somehow using INSTEAD of the newer version, and so entered synaptic manager and deleted a whole slew of older ones. Unfortunately, now I can't even enter a kernel.....I am stuck in terminal with no GUI, and since I am not proficient in linux or code of any sort, I really don't know what to do.

I've tried sudo apt-get upgrade/update...to no avail, because that requires internet access and I think I accidentally deleted a header to get me online, if you can even do that (and if that even makes sense). I've tried installing essential headers too, to no avail...since I'm not online, it can't download the needed files. Of course, if I had an older boot up disc I could simply use THAT, but I do not...having mindlessly thrown away those old discs only weeks ago. Now I'm stuck typing this on my cell phone, hoping someone has a way for me to remedy my situation with a miraculous code I'm overlooking, as opposed to me going to ebay and purchasing Jaunty 9.04 or some other distro.

Thanks in advance!!