PDA

View Full Version : [ubuntu] Do not start the desktop manager on boot



Plasma2002
September 2nd, 2009, 05:27 PM
Ok, so I have ubuntu installed on a laptop with only 256 mb ram... as you can imaging, it sometimes starts to lag a little here and there.

The other thing is that I only use this machine remotely, aka through ssh.


I want to have ubuntu load so I can remote into it, but I dont need the window manager loaded on the local machine waiting for a login... its just sitting there taking up ram.


How can i make it so the machine only boots up to a command line? I dont want it to even start loading the window manager at all.

(I dont want to have to reinstall anything, like Server edition or something)

denver
September 2nd, 2009, 05:30 PM
Try this:


update-rc.d -f gdm remove

this should remove gnome display manager from startup. You should get a text mode login prompt.

Good luck!

Plasma2002
September 2nd, 2009, 05:32 PM
Would i have to entireley remove it? I mean, if thats the only option, then ill do it....

but i was thinking that maybe if some day i really am in front of the machine, i can enter a command to start the manager if i wanted

i.r.id10t
September 2nd, 2009, 05:46 PM
The command mentioned above removes GDM from starting up in your runlevels. You can still log into the console on the local machine and run startx to start a X session.

Plasma2002
September 2nd, 2009, 05:48 PM
....oh!


well in that case..... thanks! :) its perfect

denver
September 2nd, 2009, 06:32 PM
You can add it back to your startup if you wish:


update-rc.d gdm defaults

to start gdm manually:


sudo /etc/init.d/gdm start

Have fun!