View Full Version : [all variants] Ho to install Pimki?

September 2nd, 2009, 07:26 AM
Hi all, I'm trying to install a notepad software called Pimki (http://pimki.rubyforge.org/); I've managed to get it working except for the mind map feature. The website says that for this, the bin directory must be on the system path; what does that mean?

Any help welcome, thanks.

September 2nd, 2009, 08:00 AM
If you have already installed graphviz, locate the directory where it is installed.

Then open a terminal open your .bashrc file (found in your home directory) in a text editor, and add the following line

export PATH=$PATH:/path/to/graphviz/;

where /path/to/graphviz/ is the actual location of the graphviz software on your machine. (Note if there is a 'bin' directory in the graphviz folder, append that to the above command to make it /path/to/graphviz/bin)

then do

source .bashrc

September 2nd, 2009, 09:01 AM
Thanks for the reply!
Just one questions, the last code is for the terminal (not the .bashrc file) right?

September 2nd, 2009, 09:07 AM
yes... the last code goes in the terminal

September 3rd, 2009, 08:54 PM
I tried installing pimki it on another computer and it doesn't work. I got a warning message saying "you don't have /home/myusername/.gem/ruby/1.9.0/bin in your path, gem executables won't run". Is this the problem? If it isn't what is?

I'm rather puzzled...

September 4th, 2009, 04:45 AM
Try appending that to your path as well

export PATH=$PATH:/path/to/graphviz/:/home/myusername/.gem/ruby/1.9.0/bin;

September 4th, 2009, 08:02 AM
Well I tried what you suggested and it still doesn't work. With pimki 2.0 it just doesn't do anything, and with 1.8 I get: "Failed to execute file "pimki.rb". Failed to execute child process "/home/myusername/pimki-1.8.200/pimki.rb" (No such file or directory)."

September 4th, 2009, 10:39 AM
i dont know what u r doing, but the file "/home/myusername/pimki-1.8.200/pimki.rb" does not seem to exist as is evident from the error.