View Full Version : lha lzh compression

January 25th, 2005, 06:38 PM
I am trying to uncompress a file that is in lzh format (extension) *.lha. File roller tries to open the file then fails as LZH is not installed. So an attemtp to install lzh or lha with:

apt-get update
apt-get install lha
apt-get install lhz

root@PC201:/home/danderso # apt-get install lha
Reading Package Lists... Done
Building Dependency Tree... Done
Package lha is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source
E: Package lha has no installation candidate
root@PC201:/home/danderso #

If it has been replaced, by what? if so, is there a way to configure file roller to use the replacement?

If it has not been replaced, is there a different way to install it (I know I could use
synaptic, but searches in it for lha or lzh also show nothing.

Thanks in advance for the help.

January 25th, 2005, 07:10 PM
You might need a multiverse source in your sources.list.

January 25th, 2005, 07:24 PM
I currently have
CDROM unstable
stable from marillat
java blackdown unstable

how can I add multiverse?

January 25th, 2005, 07:35 PM
and it worked, just so others dont need to search through the lists again:

sudo gedit /etc/apt/sources.list

add the following line:

deb http://archive.ubuntu.com/ubuntu/ warty multiverse

if you dont have it. Save the file, then do
apt-get update
apt-get install lha

and you should be gravy.

October 2nd, 2008, 06:09 AM
This was returned when I did an apt-get update

Failed to fetch http://archive.ubuntu.com/ubuntu/dists/warty/multiverse/binary-i386/Packages.gz 404 Not Found

Anything I can do to get lhz?

October 19th, 2008, 03:02 PM
hogzilla you do realize you posted in a 2 year old thread right? We're using hardy now, almost intrepid