View Full Version : [ubuntu] Error 18 when booting from HDD

August 30th, 2009, 09:28 PM
Greetings to the Ubuntu community. I have recently installed Ubuntu on a VAIO desktop to recover a bad Buffalo drive in ext3 format.

The problem I'm having is when I try to boot from the installation on the HDD, I get an "Error 18" when GRUB is loading. Everything runs perfectly fine if I boot from a LiveCD.

I'm using a Samsung 1TB HDD on a Sony PCV-RX550.

Any help will be greatly appreciated, its my first post on my first system. I'm excited about the Linux switch from Windows and can't wait to tinker with it some more.

Thanks again,

August 30th, 2009, 09:37 PM
You are sure the HDD is working properly?

Did you get any errors during the install?

Have you ran the check disk option on the LiveCD?

August 30th, 2009, 09:42 PM
Haven't tried the checkdisk option, but the drive is new and works just fine if I boot from the LiveCD. It came out of a Buffalo NAS device whose firmware crashed after a power outtage.

Could my BIOS have something to do with it?

August 30th, 2009, 09:47 PM
I doubt BIOS is the culprit. It sounds like grub may need to be reinstalled but first I would recommand testing the disk.

In this thread (http://ubuntuforums.org/showthread.php?t=224351) you will find instructions for reinstalling grub from the LiveCD.

August 30th, 2009, 09:57 PM
Just ran checkdisk with 0 errors. I have reinstalled Ubuntu 3 times so far...isn't that better than just reinstalling GRUB?

August 30th, 2009, 10:21 PM
Sounds like there is a hardware problem then.

While booted into the LiveCD can you post the output of
fdisk -l That is a lower case L.

August 30th, 2009, 10:23 PM
I'm fairly new to this, where do I run this code?

August 30th, 2009, 10:30 PM
Before trying the above code check out this thread (http://ubuntuforums.org/showthread.php?t=11764).

If that thread doesn't fix your system then run the above code by launching the LiveCD and going to Aplications>Accessories>Terminal, then type the code into terminal.

August 30th, 2009, 11:23 PM
Could my BIOS have something to do with it?

I think it could

see my thread on the same subject and a few people who helped fix it.


In particular look at his post


Good luck

August 30th, 2009, 11:39 PM
Very well could be. After searching for grub error 18 on google I found the thread I mentioned about that talked about BIOS.

August 30th, 2009, 11:48 PM
As dangerousdave26 mentioned (and do check his thread), error 18 usually happens when the BIOS cannot access beyond a certain limit. The limit depends on the vintage of your BIOS.

For more info, here's herman's link (http://members.iinet.net/~herman546/p15.html#18).

August 31st, 2009, 02:50 AM
Thanks all of you guys for all of your support. I have reinstalled and made a 5gig partition where I installed the OS. It now boots up but it doesn't seem to see the rest of the 995gigs.

Can I force mount this other partition?