View Full Version : [SOLVED] sata wont boot now ide is plugged in

August 29th, 2009, 08:05 AM
i believe this fault will be easy to fix, but i dont know how to do it

i have a desktop pc with a 160 gig sata drive in it
i have setup 9.04 on it and it will boot from the sata drive and run and do everyhting it needs to just fine

untill i plug in a ide hard drive

now what happens is grub tried to start and gives error 22

i reckon it has something to do with it trying to boot from hd 0,0
it says its booting from that device on start up

i think that hd 0,0 is the ide hdd and thats why it is failing

anyone with any ideas how to fix so the ide and sata drive live in harmoney and it boots from the sata drive?
if i unplug the ide drive and leave the sata, everything is just fine

August 29th, 2009, 08:42 AM
i think that hd 0,0 is the ide hdd and thats why it is failing

You can find an option in most BIOSes to allow SATA HDDs to take precedence over IDE.

The exact option varies from BIOS to BIOS, so I cannot be more specific.

If you feel you have found the correct option, but want confirmation, post a (camera) screenshot of the relevant BIOS screen.

To enter the BIOS (aka CMOS setup), during startup (but before GRUB) you have to press (usually) Del =OR= F10 =OR= F12 (or look for a message on the screen during bootup).

August 29th, 2009, 11:17 AM
i have been hunting and i have found this


im going to get around this by purchasing an ide 2 sata adaptor and fix it (http://www.jaycar.com.au/productView.asp?ID=XC4841&keywords=ide+sata&form=KEYWORD)

August 30th, 2009, 01:51 AM
bought and fitted ide 2 sata adaptor, all is well again

boots nicely off the sata hdd now