View Full Version : [kubuntu] No nvidia-xconfig in kubuntu 9.04

August 28th, 2009, 07:32 PM
Ok guys, i'm new to kubuntu, i've been using ubuntu for about 3 years now. I just put kubuntu 9.04 on a very very old desktop of mine, an old HP, and want to have some fun desktop effects going. I tried ubuntu on this rig about a year ago, had trouble with the graphics card cooperating with me, and just stopped using it till about a week ago when i switched to kubuntu on it. I just tried to turn on the desktop effects, it says it can't do that with my current xconfig. I try to run nvidia-xconfig, and it says that i don't have that command. I went to the hardware drivers screen too, and it only has a driver for my wireless card there (which works fine). I honestly don't know what all you need to get an answer to me, if you tell me what you need and how to find it, i'll have it posted asap.

Thanks as always,


August 28th, 2009, 07:36 PM
Just open your package manager and download the driver. Not sure what it's called in kde. It will install the driver and nvidia-settings.

August 29th, 2009, 04:40 PM
Yeah, but which one should i download? there's quite a few in the package manager. I don't even know what model my card is, I've take the box apart, and looked at the card and it says it's an nvidia, but i don't know which number on it actually refers to "what" it actually is.

August 29th, 2009, 05:16 PM
you can find out what model your card is with this command:

lspci | grep -i nvidia

August 29th, 2009, 05:21 PM
i got this for an output:

01:00.0 VGA compatible controller: nVidia Corporation NV5M64 [RIVA TNT2 Model 64/Model 64 Pro] (rev 15)

which driver should i get from the package manager?

August 29th, 2009, 07:24 PM
I think you want this package. Your card is on the list.

August 30th, 2009, 08:12 PM
Ok, i've downloaded that one, and same as before, when i try to turn on desktop effects it says that i still need to do something to my xorg file.

September 1st, 2009, 12:37 AM
You might need to run this to enable the nvidia driver.

sudo nvidia-xconfig

September 3rd, 2009, 12:28 AM
yeah, I tried that, but

sudo: nvidia-xconfig: command not found

is what I get when I do.

September 3rd, 2009, 02:58 AM
oops sorry, that was right in your first post :redface:

for some reason that config utility is not included in that driver pack.

can you paste the output of:

cat /etc/X11/xorg.conf

September 3rd, 2009, 05:23 PM
# xorg.conf (X.Org X Window System server configuration file)
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
# Edit this file with caution, and see the xorg.conf manual page.
# (Type "man xorg.conf" at the shell prompt.)
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
# Note that some configuration settings that could be done previously
# in this file, now are automatically configured by the server and settings
# here are ignored.
# If you have edited this file but would like it to be automatically updated
# again, run the following command:
# sudo dpkg-reconfigure -phigh xserver-xorg

Section "Device"
Identifier "Configured Video Device"

Section "Monitor"
Identifier "Configured Monitor"

Section "Screen"
Identifier "Default Screen"
Monitor "Configured Monitor"
Device "Configured Video Device"

September 4th, 2009, 03:08 AM
Okay, so the nvidia driver isn't enabled.

Try this:

Back up your xorg.conf.
Run this command in terminal:

sudo cp /etc/X11/xorg.conf /etc/X11/xorg.conf.backup
Edit xorg.conf & reboot
Edit xorg.conf in your favourite editor. Eg:

sudo nano /etc/X11/xorg.conf
And change the Device section to tell X to use the nvidia driver. It should look like this.

Section "Device"
Identifier "Configured Video Device"
Driver "nvidia"
If it doesn't work, restore xorg.conf
If you have a black screen (X doesn't start) then press Ctrl-Alt-F1 to get to a terminal, otherwise just launch a terminal and do:

sudo cp /etc/X11/xorg.conf.backup /etc/X11/xorg.conf
to restore your old xorg.conf.

If that doesn't work, then try here: https://help.ubuntu.com/community/BinaryDriverHowto/Nvidia

That's all I can offer I'm afraid.