PDA

View Full Version : [ubuntu] screen resolution resets on reboot



majoob
August 27th, 2009, 10:49 PM
The screen resolution on my new desktop resets from 1920x1080 (my monitor's native resolution) down to 1280x1024 when I reboot.

So now, after each boot, I have to go to System > Administration >NVIDIA X Server Settings > Server Display Configuration and change it from 1280x1024 back to 1920x1080.

I thought my xorg.conf took care of this (the desired 1920x1080 is specified in my xorg.conf).

NVIDIA GeForce 9400 GT 512MB 128-bit GDDR2 PCI Express 2.0 x16
Acer 23" 5ms HDMI Full 1080P Widescreen LCD Monitor

Any suggestions?

My xorg.conf:

# nvidia-settings: X configuration file generated by nvidia-settings
# nvidia-settings: version 1.0 (buildd@palmer) Sun Feb 1 20:21:04 UTC 2009


Section "ServerLayout"
Identifier "Layout0"
Screen 0 "Screen0" 0 0
InputDevice "Keyboard0" "CoreKeyboard"
InputDevice "Mouse0" "CorePointer"
EndSection

Section "Files"
EndSection

Section "Module"
Load "dbe"
Load "extmod"
Load "type1"
Load "freetype"
Load "glx"
EndSection

Section "ServerFlags"
Option "Xinerama" "0"
EndSection

Section "InputDevice"

# generated from default
Identifier "Mouse0"
Driver "mouse"
Option "Protocol" "auto"
Option "Device" "/dev/psaux"
Option "Emulate3Buttons" "no"
Option "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"

# generated from default
Identifier "Keyboard0"
Driver "kbd"
EndSection

Section "Monitor"

# HorizSync source: edid, VertRefresh source: edid
Identifier "Monitor0"
VendorName "Unknown"
ModelName "Acer X233H"
HorizSync 31.0 - 83.0
VertRefresh 56.0 - 76.0
Option "DPMS"
EndSection

Section "Device"
Identifier "Device0"
Driver "nvidia"
VendorName "NVIDIA Corporation"
BoardName "GeForce 9400 GT"
EndSection

Section "Screen"
Identifier "Screen0"
Device "Device0"
Monitor "Monitor0"
DefaultDepth 24
Option "TwinView" "0"
Option "metamodes" "1920x1080 +0+0; nvidia-auto-select +0+0"
SubSection "Display"
Depth 24
EndSubSection
EndSection

inobe
August 27th, 2009, 10:53 PM
open terminal and do


gksu nvidia-settings

change the resolution and save to xconfig.

close nvidia settings.

done.

majoob
August 27th, 2009, 11:07 PM
inobe, I did that, but after rebooting I'm back to 1280x1024.

inobe
August 27th, 2009, 11:12 PM
when you typed the command' it opened nvidia settings correct ?

when you set the native resolution' you saved and applied the new setting to xconfig ?

majoob
August 27th, 2009, 11:18 PM
Yes and yes.
After I typed "gksu nvidia-settings" it fired up the NVIDIA Xserver Settings dialog.

I checked to make sure the "X Server Display Configuration was set to 1920x1080 then clicked the "Save to X Configuration File" button.

Rebooted and back to 1280x1024.


# nvidia-settings: X configuration file generated by nvidia-settings
# nvidia-settings: version 1.0 (buildd@palmer) Sun Feb 1 20:21:04 UTC 2009


Section "ServerLayout"
Identifier "Layout0"
Screen 0 "Screen0" 0 0
InputDevice "Keyboard0" "CoreKeyboard"
InputDevice "Mouse0" "CorePointer"
EndSection

Section "Files"
EndSection

Section "Module"
Load "dbe"
Load "extmod"
Load "type1"
Load "freetype"
Load "glx"
EndSection

Section "ServerFlags"
Option "Xinerama" "0"
EndSection

Section "InputDevice"

# generated from default
Identifier "Mouse0"
Driver "mouse"
Option "Protocol" "auto"
Option "Device" "/dev/psaux"
Option "Emulate3Buttons" "no"
Option "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"

# generated from default
Identifier "Keyboard0"
Driver "kbd"
EndSection

Section "Monitor"

# HorizSync source: edid, VertRefresh source: edid
Identifier "Monitor0"
VendorName "Unknown"
ModelName "Acer X233H"
HorizSync 31.0 - 83.0
VertRefresh 56.0 - 76.0
Option "DPMS"
EndSection

Section "Device"
Identifier "Device0"
Driver "nvidia"
VendorName "NVIDIA Corporation"
BoardName "GeForce 9400 GT"
EndSection

Section "Screen"
Identifier "Screen0"
Device "Device0"
Monitor "Monitor0"
DefaultDepth 24
Option "TwinView" "0"
Option "metamodes" "1920x1080 +0+0; nvidia-auto-select +0+0"
SubSection "Display"
Depth 24
EndSubSection
EndSection

inobe
August 27th, 2009, 11:22 PM
i am dumbfounded as to why you are experiencing this.

what driver version is activated in " hardware drivers" ?

majoob
August 27th, 2009, 11:31 PM
NVIDIA Accelerated Graphics Driver Version 180 [Recommended].

(Although I see that a newer (http://www.nvidia.com/object/linux_display_ia32_185.18.36.html) driver is available from NVIDIA)

inobe
August 27th, 2009, 11:43 PM
follow my post #5

this will help you obtain the latest and greatest nvidia driver.

http://ubuntuforums.org/showthread.php?p=7851143#post7851143


you don't want to manually install from nvidia's site, it's mildly a pain' also kernel updates will break the driver.

adding the repo will get you the latest driver via updates.

the repo is for ubuntu 9.04 only.

edit: notice how the gksu command works for him.

majoob
August 28th, 2009, 12:07 AM
inobe, what do you mean by #5?

inobe
August 28th, 2009, 12:09 AM
post number 5 in the link:)

majoob
August 28th, 2009, 12:38 AM
Right. #5... way to the right on my widescreen :)
I followed your instructions for the GPG key and added the repository.

No dialogs were fired up but when I checked System > Administration > NVIDIA X Server Settings my driver was still listed as 180.60.

rebooting....

inobe
August 28th, 2009, 12:48 AM
after adding the repo' update manager will start.

allow that to happen before rebooting.

install the updates before rebooting.

if update manager doesn't start' do in terminal


sudo apt-get update

majoob
August 28th, 2009, 12:59 AM
rebooted... dropped back to 1280x1024 again.

System > Administration > NVIDIA X Server Settings still says 180.60.

inobe
August 28th, 2009, 01:10 AM
after adding the repo' update manager will start.

allow that to happen before rebooting.

install the updates before rebooting.

if update manager doesn't start' do in terminal


sudo apt-get update

if the update manager didn't start' nothing was installed.

follow the quote:)

majoob
August 28th, 2009, 04:49 PM
I tried following your instructions but can't seem to get the driver updated. Still shows 180.60

majoob
August 28th, 2009, 04:52 PM
Odd thing is my xorg.conf does correctly specify the desired resolution of 1920x1080:


.
.
.
Section "Monitor"

# HorizSync source: edid, VertRefresh source: edid
Identifier "Monitor0"
VendorName "Unknown"
ModelName "Acer X233H"
HorizSync 31.0 - 83.0
VertRefresh 56.0 - 76.0
Option "DPMS"
EndSection

Section "Device"
Identifier "Device0"
Driver "nvidia"
VendorName "NVIDIA Corporation"
BoardName "GeForce 9400 GT"
EndSection

Section "Screen"
Identifier "Screen0"
Device "Device0"
Monitor "Monitor0"
DefaultDepth 24
Option "TwinView" "0"
Option "metamodes" "1920x1080 +0+0; nvidia-auto-select +0+0"
SubSection "Display"
Depth 24
EndSubSection
EndSection

majoob
August 28th, 2009, 05:03 PM
Here's my Xorg.0.log:

(II) LoadModule: "fb"
(II) Loading /usr/lib/xorg/modules//libfb.so
(II) Module fb: vendor="X.Org Foundation"
compiled for 1.6.0, module version = 1.0.0
ABI class: X.Org ANSI C Emulation, version 0.4
(II) Loading sub module "wfb"
(II) LoadModule: "wfb"
(II) Loading /usr/lib/xorg/modules//libwfb.so
(II) Module wfb: vendor="X.Org Foundation"
compiled for 1.6.0, module version = 1.0.0
ABI class: X.Org ANSI C Emulation, version 0.4
(II) Loading sub module "ramdac"
(II) LoadModule: "ramdac"
(II) Module "ramdac" already built-in
(II) resource ranges after probing:
[0] -1 0 0xffffffff - 0xffffffff (0x1) MX[B]
[1] -1 0 0x000f0000 - 0x000fffff (0x10000) MX[B]
[2] -1 0 0x000c0000 - 0x000effff (0x30000) MX[B]
[3] -1 0 0x00000000 - 0x0009ffff (0xa0000) MX[B]
[4] -1 0 0x0000ffff - 0x0000ffff (0x1) IX[B]
[5] -1 0 0x00000000 - 0x00000000 (0x1) IX[B]
(**) NVIDIA(0): Depth 24, (--) framebuffer bpp 32
(==) NVIDIA(0): RGB weight 888
(==) NVIDIA(0): Default visual is TrueColor
(==) NVIDIA(0): Using gamma correction (1.0, 1.0, 1.0)
(**) NVIDIA(0): Option "TwinView" "0"
(**) NVIDIA(0): Option "MetaModes" "1920x1080 +0+0; nvidia-auto-select +0+0"
(**) NVIDIA(0): Enabling RENDER acceleration
(II) NVIDIA(0): Support for GLX with the Damage and Composite X extensions is
(II) NVIDIA(0): enabled.
(II) NVIDIA(0): NVIDIA GPU GeForce 9400 GT (G96) at PCI:1:0:0 (GPU-0)
(--) NVIDIA(0): Memory: 1048576 kBytes
(--) NVIDIA(0): VideoBIOS: 62.94.72.00.00
(II) NVIDIA(0): Detected PCI Express Link width: 16X
(--) NVIDIA(0): Interlaced video modes are supported on this GPU
(--) NVIDIA(0): Connected display device(s) on GeForce 9400 GT at PCI:1:0:0:
(--) NVIDIA(0): Acer X233H (DFP-0)
(--) NVIDIA(0): Acer X233H (DFP-0): 330.0 MHz maximum pixel clock
(--) NVIDIA(0): Acer X233H (DFP-0): Internal Dual Link TMDS
(II) NVIDIA(0): Assigned Display Device: DFP-0
(II) NVIDIA(0): Validated modes:
(II) NVIDIA(0): "1920x1080+0+0"
(II) NVIDIA(0): "nvidia-auto-select+0+0"
(II) NVIDIA(0): Virtual screen size determined to be 1920 x 1080
(--) NVIDIA(0): DPI set to (95, 94); computed from "UseEdidDpi" X config
(--) NVIDIA(0): option
(==) NVIDIA(0): Enabling 32-bit ARGB GLX visuals.
(--) Depth 24 pixmap format is 32 bpp
(II) do I need RAC? No, I don't.
(II) resource ranges after preInit:
[0] -1 0 0xffffffff - 0xffffffff (0x1) MX[B]
[1] -1 0 0x000f0000 - 0x000fffff (0x10000) MX[B]
[2] -1 0 0x000c0000 - 0x000effff (0x30000) MX[B]
[3] -1 0 0x00000000 - 0x0009ffff (0xa0000) MX[B]
[4] -1 0 0x0000ffff - 0x0000ffff (0x1) IX[B]
[5] -1 0 0x00000000 - 0x00000000 (0x1) IX[B]
(II) NVIDIA(0): Initialized GPU GART.
(II) NVIDIA(0): Setting mode "1920x1080+0+0"
(II) Loading extension NV-GLX
(II) NVIDIA(0): NVIDIA 3D Acceleration Architecture Initialized
(==) NVIDIA(0): Disabling shared memory pixmaps
(II) NVIDIA(0): Using the NVIDIA 2D acceleration architecture
(==) NVIDIA(0): Backing store disabled
(==) NVIDIA(0): Silken mouse enabled
(**) Option "dpms"
(**) NVIDIA(0): DPMS enabled
(II) Loading extension NV-CONTROL
(II) Loading extension XINERAMA
(==) RandR enabled
(II) Initializing built-in extension Generic Event Extension
(II) Initializing built-in extension SHAPE
(II) Initializing built-in extension MIT-SHM
(II) Initializing built-in extension XInputExtension
(II) Initializing built-in extension XTEST
(II) Initializing built-in extension BIG-REQUESTS
(II) Initializing built-in extension SYNC
(II) Initializing built-in extension XKEYBOARD
(II) Initializing built-in extension XC-MISC
(II) Initializing built-in extension SECURITY
(II) Initializing built-in extension XINERAMA
(II) Initializing built-in extension XFIXES
(II) Initializing built-in extension RENDER
(II) Initializing built-in extension RANDR
(II) Initializing built-in extension COMPOSITE
(II) Initializing built-in extension DAMAGE
(II) Initializing extension GLX
(II) config/hal: Adding input device AT Translated Set 2 keyboard
(II) LoadModule: "evdev"
(II) Loading /usr/lib/xorg/modules/input//evdev_drv.so
(II) Module evdev: vendor="X.Org Foundation"
compiled for 1.6.0, module version = 2.1.1
Module class: X.Org XInput Driver
ABI class: X.Org XInput driver, version 4.0
(**) AT Translated Set 2 keyboard: always reports core events
(**) AT Translated Set 2 keyboard: Device: "/dev/input/event3"
(II) AT Translated Set 2 keyboard: Found keys
(II) AT Translated Set 2 keyboard: Configuring as keyboard
(II) XINPUT: Adding extended input device "AT Translated Set 2 keyboard" (type: KEYBOARD)
(**) Option "xkb_rules" "evdev"
(**) AT Translated Set 2 keyboard: xkb_rules: "evdev"
(**) Option "xkb_model" "pc105"
(**) AT Translated Set 2 keyboard: xkb_model: "pc105"
(**) Option "xkb_layout" "us"
(**) AT Translated Set 2 keyboard: xkb_layout: "us"
(II) config/hal: Adding input device Macintosh mouse button emulation
(**) Macintosh mouse button emulation: always reports core events
(**) Macintosh mouse button emulation: Device: "/dev/input/event2"
(II) Macintosh mouse button emulation: Found 3 mouse buttons
(II) Macintosh mouse button emulation: Found x and y relative axes
(II) Macintosh mouse button emulation: Configuring as mouse
(**) Macintosh mouse button emulation: YAxisMapping: buttons 4 and 5
(**) Macintosh mouse button emulation: EmulateWheelButton: 4, EmulateWheelInertia: 10, EmulateWheelTimeout: 200
(II) XINPUT: Adding extended input device "Macintosh mouse button emulation" (type: MOUSE)
(**) Macintosh mouse button emulation: (accel) keeping acceleration scheme 1
(**) Macintosh mouse button emulation: (accel) filter chain progression: 2.00
(**) Macintosh mouse button emulation: (accel) filter stage 0: 20.00 ms
(**) Macintosh mouse button emulation: (accel) set acceleration profile 0
(II) config/hal: Adding input device Logitech Optical USB Mouse
(**) Logitech Optical USB Mouse: always reports core events
(**) Logitech Optical USB Mouse: Device: "/dev/input/event5"
(II) Logitech Optical USB Mouse: Found 3 mouse buttons
(II) Logitech Optical USB Mouse: Found x and y relative axes
(II) Logitech Optical USB Mouse: Configuring as mouse
(**) Logitech Optical USB Mouse: YAxisMapping: buttons 4 and 5
(**) Logitech Optical USB Mouse: EmulateWheelButton: 4, EmulateWheelInertia: 10, EmulateWheelTimeout: 200
(II) XINPUT: Adding extended input device "Logitech Optical USB Mouse" (type: MOUSE)
(**) Logitech Optical USB Mouse: (accel) keeping acceleration scheme 1
(**) Logitech Optical USB Mouse: (accel) filter chain progression: 2.00
(**) Logitech Optical USB Mouse: (accel) filter stage 0: 20.00 ms
(**) Logitech Optical USB Mouse: (accel) set acceleration profile 0
(II) NVIDIA(0): Setting mode "1280x1024"
(II) NVIDIA(0): Setting mode "1920x1080+0+0"

inobe
August 28th, 2009, 10:34 PM
I tried following your instructions but can't seem to get the driver updated. Still shows 180.60


lets assume the repo is setup correctly, in terminal


sudo apt-get update

if the update manager appears' don't do the second command.

then


sudo apt-get upgrade

you should then see in terminal the nvidia updates' you can type y and hit enter to continue.

reboot when done.

as for the xorg.conf' we won't need to mess with that.

majoob
August 29th, 2009, 01:30 AM
Still a no go.
Do I need to disable or uninstall the 180.60 driver first?

sudo apt-get update:

matt@oberle-desktop:~$ sudo apt-get update
Hit http://security.ubuntu.com jaunty-security Release.gpg
Ign http://security.ubuntu.com jaunty-security/main Translation-en_US
Hit http://us.archive.ubuntu.com jaunty Release.gpg
Ign http://us.archive.ubuntu.com jaunty/main Translation-en_US
Hit http://www.avenard.org jaunty Release.gpg
Ign http://www.avenard.org jaunty/release Translation-en_US
Ign http://security.ubuntu.com jaunty-security/restricted Translation-en_US
Ign http://security.ubuntu.com jaunty-security/universe Translation-en_US
Ign http://security.ubuntu.com jaunty-security/multiverse Translation-en_US
Hit http://security.ubuntu.com jaunty-security Release
Ign http://us.archive.ubuntu.com jaunty/restricted Translation-en_US
Ign http://us.archive.ubuntu.com jaunty/universe Translation-en_US
Ign http://us.archive.ubuntu.com jaunty/multiverse Translation-en_US
Hit http://us.archive.ubuntu.com jaunty-updates Release.gpg
Ign http://us.archive.ubuntu.com jaunty-updates/main Translation-en_US
Ign http://us.archive.ubuntu.com jaunty-updates/restricted Translation-en_US
Ign http://us.archive.ubuntu.com jaunty-updates/universe Translation-en_US
Ign http://us.archive.ubuntu.com jaunty-updates/multiverse Translation-en_US
Hit http://us.archive.ubuntu.com jaunty Release
Hit http://www.avenard.org jaunty Release
Hit http://security.ubuntu.com jaunty-security/main Packages
Hit http://us.archive.ubuntu.com jaunty-updates Release
Hit http://security.ubuntu.com jaunty-security/restricted Packages
Hit http://www.avenard.org jaunty/release Packages
Hit http://security.ubuntu.com jaunty-security/main Sources
Hit http://security.ubuntu.com jaunty-security/restricted Sources
Hit http://security.ubuntu.com jaunty-security/universe Packages
Hit http://us.archive.ubuntu.com jaunty/main Packages
Hit http://us.archive.ubuntu.com jaunty/restricted Packages
Hit http://us.archive.ubuntu.com jaunty/main Sources
Hit http://us.archive.ubuntu.com jaunty/restricted Sources
Hit http://us.archive.ubuntu.com jaunty/universe Packages
Hit http://security.ubuntu.com jaunty-security/universe Sources
Hit http://security.ubuntu.com jaunty-security/multiverse Packages
Hit http://security.ubuntu.com jaunty-security/multiverse Sources
Hit http://us.archive.ubuntu.com jaunty/universe Sources
Hit http://us.archive.ubuntu.com jaunty/multiverse Packages
Hit http://us.archive.ubuntu.com jaunty/multiverse Sources
Hit http://us.archive.ubuntu.com jaunty-updates/main Packages
Hit http://us.archive.ubuntu.com jaunty-updates/restricted Packages
Hit http://us.archive.ubuntu.com jaunty-updates/main Sources
Hit http://us.archive.ubuntu.com jaunty-updates/restricted Sources
Hit http://us.archive.ubuntu.com jaunty-updates/universe Packages
Hit http://us.archive.ubuntu.com jaunty-updates/universe Sources
Hit http://us.archive.ubuntu.com jaunty-updates/multiverse Packages
Hit http://us.archive.ubuntu.com jaunty-updates/multiverse Sources
Reading package lists... Done
matt@oberle-desktop:~$

inobe
August 29th, 2009, 01:53 AM
no need to uninstall, we will let package manager do that.

open synaptic, click settings, click repositories, click third party.

uncheck avenard.

reboot and recheck avenard.

then do the update command in terminal.


two things are strange

changes won't stick in nvidia settings with super user privileges

the package manager will not upgrade your nvidia driver

none of which never failed for me :shock:

majoob
August 29th, 2009, 06:40 AM
open synaptic, click settings, click repositories, click third party.

uncheck avenard.

reboot and recheck avenard.

then do the update command in terminal.


Done:

matt@oberle-desktop:~$ sudo apt-get update
[sudo] password for matt:
Hit http://security.ubuntu.com jaunty-security Release.gpg
Ign http://security.ubuntu.com jaunty-security/main Translation-en_US
Hit http://us.archive.ubuntu.com jaunty Release.gpg
Ign http://us.archive.ubuntu.com jaunty/main Translation-en_US
Ign http://security.ubuntu.com jaunty-security/restricted Translation-en_US
Ign http://security.ubuntu.com jaunty-security/universe Translation-en_US
Ign http://security.ubuntu.com jaunty-security/multiverse Translation-en_US
Hit http://security.ubuntu.com jaunty-security Release
Ign http://us.archive.ubuntu.com jaunty/restricted Translation-en_US
Ign http://us.archive.ubuntu.com jaunty/universe Translation-en_US
Ign http://us.archive.ubuntu.com jaunty/multiverse Translation-en_US
Hit http://us.archive.ubuntu.com jaunty-updates Release.gpg
Ign http://us.archive.ubuntu.com jaunty-updates/main Translation-en_US
Ign http://us.archive.ubuntu.com jaunty-updates/restricted Translation-en_US
Ign http://us.archive.ubuntu.com jaunty-updates/universe Translation-en_US
Ign http://us.archive.ubuntu.com jaunty-updates/multiverse Translation-en_US
Hit http://us.archive.ubuntu.com jaunty Release
Hit http://us.archive.ubuntu.com jaunty-updates Release
Hit http://www.avenard.org jaunty Release.gpg
Ign http://www.avenard.org jaunty/release Translation-en_US
Hit http://security.ubuntu.com jaunty-security/main Packages
Hit http://us.archive.ubuntu.com jaunty/main Packages
Hit http://www.avenard.org jaunty Release
Hit http://security.ubuntu.com jaunty-security/restricted Packages
Hit http://security.ubuntu.com jaunty-security/main Sources
Hit http://security.ubuntu.com jaunty-security/restricted Sources
Hit http://security.ubuntu.com jaunty-security/universe Packages
Hit http://us.archive.ubuntu.com jaunty/restricted Packages
Hit http://us.archive.ubuntu.com jaunty/main Sources
Hit http://us.archive.ubuntu.com jaunty/restricted Sources
Hit http://us.archive.ubuntu.com jaunty/universe Packages
Hit http://us.archive.ubuntu.com jaunty/universe Sources
Hit http://security.ubuntu.com jaunty-security/universe Sources
Hit http://security.ubuntu.com jaunty-security/multiverse Packages
Hit http://security.ubuntu.com jaunty-security/multiverse Sources
Hit http://us.archive.ubuntu.com jaunty/multiverse Packages
Hit http://us.archive.ubuntu.com jaunty/multiverse Sources
Hit http://us.archive.ubuntu.com jaunty-updates/main Packages
Hit http://us.archive.ubuntu.com jaunty-updates/restricted Packages
Hit http://us.archive.ubuntu.com jaunty-updates/main Sources
Hit http://us.archive.ubuntu.com jaunty-updates/restricted Sources
Hit http://us.archive.ubuntu.com jaunty-updates/universe Packages
Hit http://us.archive.ubuntu.com jaunty-updates/universe Sources
Hit http://us.archive.ubuntu.com jaunty-updates/multiverse Packages
Hit http://us.archive.ubuntu.com jaunty-updates/multiverse Sources
Hit http://www.avenard.org jaunty/release Packages
Reading package lists... Done
matt@oberle-desktop:~$

unutbu
August 29th, 2009, 01:13 PM
majoob, here is something simple you can try. I don't know if it will work.
If it doesn't, it is easy to revert:

Make a backup of your xorg.conf:


sudo mv /etc/X11/xorg.conf /etc/X11/xorg.conf-20090829

Then edit xorg.conf:


gksu gedit /etc/X11/xorg.conf

Put this in your xorg.conf:


Section "Screen"
Identifier "Default Screen"
DefaultDepth 24
EndSection

Section "Module"
Load "glx"
EndSection

Section "Device"
Identifier "Default Device"
Driver "nvidia"
Option "NoLogo" "True"
EndSection

Save and exit. Reboot, Reboot.

If it doesn't work, then to revert the change, simply run


sudo cp /etc/X11/xorg.conf-20090829 /etc/X11/xorg.conf

majoob
August 29th, 2009, 05:35 PM
That didn't help so I reverted back to my saved xorg.conf

Other than wrestling with this video issue, I haven't invested much in this installation. Do you think reinstalling 9.04 might fix things?

linux_tech
August 29th, 2009, 06:46 PM
sudo nvidia-settings
save the changes for your xorg.conf file

inobe
August 29th, 2009, 07:39 PM
That didn't help so I reverted back to my saved xorg.conf

Other than wrestling with this video issue, I haven't invested much in this installation. Do you think reinstalling 9.04 might fix things?

i think it's repairable


i would activate a driver that is newer in hardware drivers

majoob
August 29th, 2009, 08:22 PM
System > Administration > Hardware Drivers lists two:
NVIDIA accelerated graphics driver (version 180) [Recommended]
NVIDIA accelerated graphics driver (version 173)

The 180 is activated and in use.

inobe
August 29th, 2009, 08:41 PM
back to repositories in synaptic under updates' is "recommended updates" enabled ?

also under auto updates, is it set to daily ?

edit: bare with me' we will figure this out in due time :)

inobe
August 29th, 2009, 08:55 PM
when adding the key and repo' did you copy and paste the entire line into terminal ?


the key


wget http://www.avenard.org/files/ubuntu-repos/ubuntu-repos.key && sudo apt-key add ubuntu-repos.key && rm ubuntu-repos.key

the repo


echo "deb http://www.avenard.org/files/ubuntu-repos jaunty release" | sudo tee /etc/apt/sources.list.d/avenard.list

http://www.avenard.org/media/Ubuntu_Repository/Ubuntu_Repository.html

ejayjock
August 29th, 2009, 11:32 PM
Hello Majoob and Inobe,

As it happens today I ran into this same problem. After some experimenting I believe it is NOT a driver issue. Here is why:

My HTPC setup involves a Sharp 1080p LCD TV and a Nvidia 6600gt on a 32bit Ubuntu 9.04 install. Using nvidia-settings I can set the screen resolution to 1080p and it looks perfect. I then save the configuration to the /etc/X11/xorg.conf file and reboot. The system comes up with 1280x1024. I have tried both the 172 and 180 drivers in the Ubuntu proprietary Hardware settings menu.

After I read this thread, I purged the Nvida drivers using aptitude and installed Driver versions 185.18.36 and 190.18 (obtained from the www.nvidia.com). I all cases the behavior is the same - automatic resizing to 1280x1024 on reboot. The odds of all 4 versions of the driver having the same strange bug did not add up.

So I looked into what was auto starting with the gnome destkop ( System -> Preferences -> Startup Applications ). When I disable both the "gnome settings daemon" and the "gnome settings deamon helper" my desktop comes up in glorious 1080p. However the fonts/graphics are not proper.

Majoob, does this fix the resolution problem for you? Does anyone how to fix the gnome settings daemon?

Cheers,
Eric

inobe
August 30th, 2009, 01:50 AM
i have not had any problems at all with the latest drivers and assuming majoob would all good as well' except for an odd reason apt will not upgrade his nvidia driver.

i want to do it this way because a kernel update will bork a manual install.



i am in the process now at finding out if his package manager is improperly configured or broken' also possibly finding out why super user insn't applying the changes.


now you uncovered something entirely new !

with that information including what was found in this thread' it seems only a slight few are experiencing this and i would like to know why :)

majoob
August 30th, 2009, 03:58 AM
inobe -

back to repositories in synaptic under updates' is "recommended updates" enabled ?

also under auto updates, is it set to daily ?

Yes and yes.

And http://www.avenard.org/files/ubuntu-repos is listed in "Third-Party Software" and is checked.

majoob
August 30th, 2009, 04:10 AM
ejayjock -

So I looked into what was auto starting with the gnome destkop ( System -> Preferences -> Startup Applications ). When I disable both the "gnome settings daemon" and the "gnome settings deamon helper" my desktop comes up in glorious 1080p. However the fonts/graphics are not proper.

I got the same results, including the bad fonts so I re-enabled them.

This might be a clue though, for someone smarter than me.

majoob
August 30th, 2009, 04:14 AM
Also, today my system has started becoming unstable (spontaneous reboots, messages about kernel panic, etc).
One message said something like "the display server has shut down 6 times in the last 90 seconds..."

inobe
August 30th, 2009, 06:06 AM
i believe your system is pretty broken and would make sure you have backed up all important information.

majoob
August 30th, 2009, 06:27 PM
I reinstalled Jaunty but stayed in 1280x1024 and did not activate the 180.60 NVIDIA driver.

Followed your instructions (http://ubuntuforums.org/showthread.php?p=7851143#post7851143) again and got this:


matt@oberle-desktop:~$ wget http://www.avenard.org/files/ubuntu-repos/ubuntu-repos.key && sudo apt-key add ubuntu-repos.key && rm ubuntu-repos.key
--2009-08-30 08:44:14-- http://www.avenard.org/files/ubuntu-repos/ubuntu-repos.key
Resolving www.avenard.org... 88.191.110.21
Connecting to www.avenard.org|88.191.110.21|:80... connected.
HTTP request sent, awaiting response... 200 OK
Length: 1743 (1.7K) [application/pgp-keys]
Saving to: `ubuntu-repos.key'

100%[======================================>] 1,743 --.-K/s in 0.001s

2009-08-30 08:44:14 (2.27 MB/s) - `ubuntu-repos.key' saved [1743/1743]

[sudo] password for matt:
OK
matt@oberle-desktop:~$

then:


matt@oberle-desktop:~$ echo "deb http://www.avenard.org/files/ubuntu-repos jaunty release" | sudo tee /etc/apt/sources.list.d/avenard.list
deb http://www.avenard.org/files/ubuntu-repos jaunty release
matt@oberle-desktop:~$

The update manager started with over 200 updates, but they all looked like they were from canonical... I didn't see anything from avenard.

Restarted, but still only see 180 and 173 in System > Administration > Hardware Drivers.

I'm going to stop here and see if anyone has ideas.

manusha
August 30th, 2009, 07:09 PM
i got the same issue when i change resolution as a non privileged user. I had to assign the user to root group and set its default group to root to resolve the problem. This is OK for me as it was a home pc.

ejayjock
August 30th, 2009, 07:42 PM
Inobe and Majoob,

I'm probably not correct about this, since my knowledge of the repository system is very limited. But when I look at the packages that are found under the release section of the 'http://www.avenard.org/files/ubuntu-repos jaunty' repository I see that the latest driver is the 180.60 driver. Perhaps you meant for Majoob to entering either testing or bleeding repos?

Majoob,

I do not think this is a driver issue, so I would suggest sticking with the 180.60 driver. It appears this is an issue related to the gnome-config-daemon using xrandr (https://bugs.launchpad.net/ubuntu/+source/nvidia-settings/+bug/300287) to set your display in conjunction with the nvidia driver returning strange refresh rates (http://www.nvnews.net/vbulletin/showthread.php?t=94774).

I would suggest one possible work around might be to see if you can work out an xrandr command that fixes you screen resolution and the run it in a bash script at startup

eg:

xrandr --screen default --mode 1680x1050

Definitely a hack work around, but with some tinkering you could probably get it going.

Good luck,
Eric

inobe
August 30th, 2009, 10:40 PM
activate the 180 driver and restart, open synaptic and type nvidia.

what versions are listed' you can click them individually to get further info of their exact version, obviously the boxes that are darkened are what is currently installed.

inobe
August 31st, 2009, 12:24 AM
Inobe and Majoob,



I do not think this is a driver issue, so I would suggest sticking with

Eric

eric, thanks for the information, i did research and found this issues to be resolved, the newest nvidia driver fixes many past issues especially those from the year 08" when the bug was discovered.

it was in fact a driver issue.

majoob
August 31st, 2009, 03:37 AM
I'd still like to upgrade to the latest NVIDIA driver, but....

I enabled version 180 in Hardware Drivers
Restarted, and it booted to the native resolution of 1920x1080
Two things are different from before on the NVIDIA X Server Settings:

On the "Display" tab, Resolution is set to "Auto", where before I was explicitly setting it to 1920x1080.
The driver version is listed as 180.44, where before it was 180.60 (weird)

I restarted a second time to make sure.

inobe
August 31st, 2009, 04:04 AM
well i am certain it should work like it's working now.

congrats on that btw.


what versions are in synaptic ?

tal007
August 31st, 2009, 04:30 AM
Check to see if you have any modification right. If not, even if you change it, the changes may not take effect. Try to do as Root ( Super User ).

majoob
August 31st, 2009, 05:14 AM
My Synaptic, search for "nvidia":


nvidia-glx-96-dev
nvidia-glx-180-dev
nvidia-glx-173-dev
nvidia-glx-71-dev
* nvidia-180-libvdpau................180.44-0ubuntu1
nvidia-180-libvdpau-dev
envyng-core
envyng-qt
* nvidia-settings....................180.25-0ubuntu1
nvidia-173-kernel-source
* nvidia-180-kernel-source...........180.44-0ubuntu1
nvidia-71-kernel-source
nvidia-96-kernel-source
nvidia-cg-toolkit
nvidia-kernael-common
* nvidia-common......................0.2.11
nvclock-qt
nvclock
nvclock-gtk
* nvidia-71-modaliases..............71.86.08-0ubuntu1
* nvidia-173-modaliases.............173.14.16-0ubuntu1
* nvidia-180-modaliases.............180.44-0ubuntu1
* nvidia-96-modaliases..............96.43.10-0ubuntu1
* nvidia-glx-180....................180.44-0ubuntu1
nvtv
nvidia-glx 173
* xserver-xorg-vido-nv..............1:2.1.12-1ubuntu5
sysinfo
xserver-corg-video-nouveau
* smartdimmer.......................0.8b4-1ubuntu2
* jockey-gtk........................0.5-0ubuntu10
jockey-kde
nvidia-glx-71
* jockey-common.....................0.5-0ubuntu10
nvidiea-glx-96
trigger
gimp-normalmap
trigger-data
dmraid
cpufreqd
sensor-applet

inobe
August 31st, 2009, 05:21 AM
well if everything is working' i say leave it as is :)


if it ain't broke' don't fix it.


i am glad you have it working.

as for the repo' if you decide you can test the 185s.

that's entirely up to you.

it seems ubuntu has been upgrading the drivers a lot sooner !

note: nvidia is already offering the 185 driver.. so i don't know why avenard has it in the testing repo lols

edit: you will need to review this page to add testing http://www.avenard.org/media/Ubuntu_Repository/Ubuntu_Repository.html

majoob
August 31st, 2009, 05:37 AM
Thanks for your help and persistence, inobe.

Kristofer Van Orton
August 31st, 2009, 05:41 AM
Well i'm gonna try to help by using personal expirience considering I have a Nvidia graphics card and had the same exact problem when I first installed ubuntu so im gonna explain to you exactly what i did and it worked for me

1. go to System-->Preferences-->Display
2.since you have a Nvidia graphics card it will probably prompt you
"It appears your graphics card does not support the nessacary extensions to use this tool. Do you want to use your graphics driver vendors tool instead?"
I'm sure you already know this, but now if you already have it set using that tool than click no on this box and it will open up your display preferences window anyway.
3. Go to resolution and set it to the desired resolution. Click apply. It'll probably prompt if you wanna keep these settings and freeze the whole OS up, just wait a few minutes (it will NOT unfreeze)
4. After waiting a bit just cold-boot your computer (cold boot means to hold the power button on your computer down until it shuts down, you probably knew that but just incase you didnt:P)
5.start it back up and it should be set to your desired resolution


I know it sounds kind of rediculous but it worked for me!
hope i helped
-KVO

inobe
August 31st, 2009, 05:45 AM
it's not a problem' any time you need assistance from video problems to networking, simply start a top and send me a personal message linking me to the topic.

i will always try to keep it simple' i wouldn't take anyone into command line interface unless it was the last resort, have a great night :)

ndknoy
September 13th, 2009, 03:33 AM
I've been having the same problem. Followed all the directions on this thread and am now running driver version 185. Ran nvidia settings as super user and saved to X Config file. Resolution still resets after every reboot.


# nvidia-settings: X configuration file generated by nvidia-settings
# nvidia-settings: version 1.0 (buildd@palmer) Sun Feb 1 20:21:04 UTC 2009

Section "ServerLayout"
Identifier "Layout0"
Screen 0 "Screen0" 0 0
InputDevice "Keyboard0" "CoreKeyboard"
InputDevice "Mouse0" "CorePointer"
EndSection

Section "Files"
EndSection

Section "Module"
Load "dbe"
Load "extmod"
Load "type1"
Load "freetype"
Load "glx"
EndSection

Section "ServerFlags"
Option "Xinerama" "0"
EndSection

Section "InputDevice"
# generated from default
Identifier "Mouse0"
Driver "mouse"
Option "Protocol" "auto"
Option "Device" "/dev/psaux"
Option "Emulate3Buttons" "no"
Option "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"
# generated from default
Identifier "Keyboard0"
Driver "kbd"
EndSection

Section "Monitor"
# HorizSync source: edid, VertRefresh source: edid
Identifier "Monitor0"
VendorName "Unknown"
ModelName "Sharp LL-T15V1"
HorizSync 22.0 - 62.0
VertRefresh 50.0 - 75.0
Option "DPMS"
EndSection

Section "Device"
Identifier "Device0"
Driver "nvidia"
VendorName "NVIDIA Corporation"
BoardName "GeForce 7600 GS"
EndSection

Section "Screen"
Identifier "Screen0"
Device "Device0"
Monitor "Monitor0"
DefaultDepth 24
Option "TwinView" "0"
Option "metamodes" "1024x768 +0+0; nvidia-auto-select +0+0"
SubSection "Display"
Depth 24
EndSubSection
EndSection