View Full Version : [SOLVED] Did I break Firefox?

August 27th, 2009, 08:11 PM
I am running Jaunty, and I tried to upgrade Firefox according to these instructions:

After I did so, Liferea and Thunderbird won't open links in Firefox. (Did something happen to Gnome?) When I reverted back to the old version of Firefox (I removed the new link to Firefox, I restored all the old link and file names, and removed the new Firefox folder from /usr/lib.) This didn't help, and still, I can't get items to open in Firefox.

Any suggestions?

August 27th, 2009, 09:51 PM
You probably simply need to change the System > Preferences > Preferred Applications settings to Custom, with the command firefox-3.5

August 27th, 2009, 09:53 PM
Probably not, try this:
sudo apt-get remove firefox && sudo apt-get install firefox.

August 27th, 2009, 09:53 PM
I'll give it a shot and let you know the results.

August 27th, 2009, 10:17 PM

I uninstalled and reinstalled Firefox, to be safe. I noticed that my preferred setting was already on "Custom." When I switched it to "Firefox" it worked like before.

Thank you for your help.