PDA

View Full Version : [ubuntu] DVD Help



rkmullins
August 27th, 2009, 02:41 AM
I am completely new to Linux. I just installed Ubuntu on my laptop and all seems ok except for my DVD player. I came play audio CD's just fine, but when I insert a DVD movie it asks me what application to use. The only one listed is "Open Movie Player". I select that and it looks like it is going to play when a message pops up asking to search for a suitable plugin. I select search and it searchs but comers up with a message that "No packages with the requested plugins found" "The requested plugins are: DVD Source"

I have looked in Synaptic Package Manager but nothing is there that spells out "DVD Source"

Can someone assist me? Thanks!

Revolutionary101
August 27th, 2009, 02:45 AM
You should install libdvdcss2 and ubuntu-restricted-extras. Just type this into terminal to get them.


sudo apt-get install libdvdcss2 ubuntu-restricted-extras

rkmullins
August 27th, 2009, 03:08 AM
I tried and here are the results:

sudo apt-get install libdvdcss2 ubuntu-restricted-extras
Reading package lists... Done
Building dependency tree
Reading state information... Done
Package libdvdcss2 is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source
E: Package libdvdcss2 has no installation candidate

rkmullins
August 27th, 2009, 03:49 AM
libdvdcss is installed but I get this for the other you suggested:
E: Couldn't find package ubunto-restricted-extras

acharseth
August 27th, 2009, 08:24 PM
Hi!

This worked for me:
Install libdvdread4 as explained in https://help.ubuntu.com/community/RestrictedFormats/PlayingDVDs
Install ubuntu-restricted-extras (search for it in Synaptic)

Playback is choppy though and I could not find the /dev/hdc described in https://help.ubuntu.com/community/DMA to check if DMA is enabled. I am running Ubuntu 9.04 in a VirtualBox VM so that might be causing the problem too?

Arne

oldos2er
August 27th, 2009, 09:50 PM
You need to enable the Medibuntu repository for libdvdcss2 (http://medibuntu.org).

rkmullins
August 28th, 2009, 03:03 AM
thank you! it now works

Revolutionary101
August 28th, 2009, 07:32 PM
Glad I could help.