View Full Version : [ubuntu] Apparently Unique problm with WizardPen Driver and Intrepid/Jaunty

August 23rd, 2009, 10:19 PM
I just downgraded from Jaunty to Intrepid (too many problems) in order to get my graphics card, and my graphics tablet working again.

I have a Genius MousePen 8x6. I installed Ubuntu, installed the dependencies, and BAM, tablet works again.

Fine. Great. Awesome.

Then, I go and download updates. Fine, everything's still working...

Then, I go and download all of my old packages and enable the backports, and install them...

Now, this is where it gets fuzzy, and at some point the Tablet Stylus just stopped working. I tried checking dmesg, and got the following error:

evdev.c(EVIOCGBIT): Suspicious buffer size 511, limiting output to 64 bytes. See http://userweb.kernel.org/~dtor/eviocgbit-bug.html

I check the link, and find out it's a kernel feature, and a simple fix. Okay, fix a couple lines of code, reinstall, all good, right?

Nope. The stylus still fails to work. Mind you, the mouse still works fine.

I dig through FDI's, configuration files, etc... Not much of anything is coming up. I'm this close to just wiping, reinstalling again, and finding exactly at what point it breaks, cause it looks like some kind of package is breaking support.

Anything and everything that I can think to dump, to give some kind of clue: (mind you, I've been tinkering, and modifying, and still nothing, so keep that in mind if odd things pop up)

lsusb output:

trevor@BlackMage:~$ lsusb
Bus 003 Device 006: ID 0461:0347 Primax Electronics, Ltd Primascan Colorado 2600u/Visioneer 4400 Scanner
Bus 003 Device 005: ID 03f0:1d04 Hewlett-Packard
Bus 003 Device 004: ID 046d:08af Logitech, Inc. QuickCam Easy/Cool
Bus 003 Device 003: ID 0a5c:2101 Broadcom Corp. A-Link BlueUsbA2 Bluetooth
Bus 003 Device 002: ID 058f:9254 Alcor Micro Corp. Hub
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 007 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 006 Device 002: ID 5543:0005 UC-Logic Technology Corp. Genius MousePen 8x6 Tablet
Bus 006 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 005 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 004 Device 003: ID 413c:3012 Dell Computer Corp.
Bus 004 Device 002: ID 046d:c315 Logitech, Inc. Classic New Touch Keyboard
Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

relevant portion of lshal's output:

trevor@BlackMage:~$ lshal
udi = '/org/freedesktop/Hal/devices/usb_device_5543_5_noserial_if0_logicaldev_input'
info.capabilities = {'input', 'input.mouse', 'input.touchpad'} (string list)
info.category = 'input' (string)
info.parent = '/org/freedesktop/Hal/devices/usb_device_5543_5_noserial_if0' (string)
info.product = 'UC-LOGIC Tablet WP8060U' (string)
info.subsystem = 'input' (string)
info.udi = '/org/freedesktop/Hal/devices/usb_device_5543_5_noserial_if0_logicaldev_input' (string)
input.device = '/dev/input/event3' (string)
input.originating_device = '/org/freedesktop/Hal/devices/usb_device_5543_5_noserial_if0' (string)
input.product = 'UC-LOGIC Tablet WP8060U' (string)
input.x11_driver = 'wizardpen' (string)
input.x11_identifier = 'stylus' (string)
input.x11_options.BottomX = '32747' (string)
input.x11_options.BottomY = '32762' (string)
input.x11_options.MaxX = '32747' (string)
input.x11_options.MaxY = '32762' (string)
input.x11_options.SendCoreEvents = 'true' (string)
input.x11_options.TopX = '605' (string)
input.x11_options.TopY = '2492' (string)
linux.device_file = '/dev/input/event3' (string)
linux.hotplug_type = 2 (0x2) (int)
linux.subsystem = 'input' (string)
linux.sysfs_path = '/sys/devices/pci0000:00/0000:00:13.1/usb6/6-3/6-3:1.0/input/input3/event3' (string)

found input devices:

trevor@BlackMage:~$ cat /proc/bus/input/devices | grep -i name
N: Name="Macintosh mouse button emulation"
N: Name="Logitech Logitech USB Keyboard"
N: Name="Dell Dell USB Optical Mouse"
N: Name="UC-LOGIC Tablet WP8060U"
N: Name="Power Button (FF)"
N: Name="Power Button (CM)"
N: Name="PC Speaker"
N: Name="Mouseemu virtual keyboard"
N: Name="Mouseemu virtual mouse"

the current .fdi file I'm using:

trevor@BlackMage:~$ cat /etc/hal/fdi/policy/99-x11-wizardpen.fdi
<?xml version="1.0" encoding="ISO-8859-1" ?>
<deviceinfo version="0.2">
<!-- This MUST match with the name of your tablet -->
<match key="info.product" contains="UC-LOGIC Tablet WP8060U">
<merge key="input.x11_driver" type="string">wizardpen</merge>
<merge key="input.x11_identifier" type="string">stylus</merge>
<merge key="input.x11_options.SendCoreEvents" type="string">true</merge>
<merge key="input.x11_options.TopX" type="string">605</merge>
<merge key="input.x11_options.TopY" type="string">2492</merge>
<merge key="input.x11_options.BottomX" type="string">32747</merge>
<merge key="input.x11_options.BottomY" type="string">32762</merge>
<merge key="input.x11_options.MaxX" type="string">32747</merge>
<merge key="input.x11_options.MaxY" type="string">32762</merge>

dmesg output after I plug in the tablet.

trevor@BlackMage:~$ dmesg
[ 1073.473040] usb 6-2: new low speed USB device using ohci_hcd and address 3
[ 1073.645018] usb 6-2: configuration #1 chosen from 1 choice
[ 1073.660277] input: UC-LOGIC Tablet WP8060U as /devices/pci0000:00/0000:00:13.1/usb6/6-2/6-2:1.0/input/input9
[ 1073.717972] input,hidraw2: USB HID v1.00 Mouse [UC-LOGIC Tablet WP8060U] on usb-0000:00:13.1-2

Also, restarting does not help. (Actually, compiz isn't starting up on restart either). I've switched kernels, recompiled and reinstalled. I've even had troubles getting 'sudo make install' to actually copy the files to /usr/lib/xorg/modules/input.

Let me know if more information, what kind is needed. I'm not a complete linux noob, but this just dumbfounds me, and I'm probably just missing something small... So, feel free to tell me to dump some kind of log to help someone help me.

August 24th, 2009, 01:54 AM
Hi GothPanda,

Doesn't make any sense to me. Why would you get "Suspicious buffer size 511" when your .fdi doesn't have anything like:

<merge key="input.x11_options.zMax" type="string">1023</merge>
instead of:

<merge key="input.x11_options.zMax" type="string">511</merge>
You might want to see if "xinput --list" tells you anything.

I noticed:

linux.sysfs_path = '/sys/devices/pci0000:00/0000:00:13.1/usb6/6-3/6-3:1.0/input/input3/event3' (string)
doesn't match:

[ 1073.660277] input: UC-LOGIC Tablet WP8060U as /devices/pci0000:00/0000:00:13.1/usb6/6-2/6-2:1.0/input/input9
But I suppose that's because you replugged. Although wouldn't just the event number change?

Before you reinstall why not give up on the .fdi first and try xorg.conf? Just comment the .fdi out or remove it and use your old xorg.conf settings.

August 24th, 2009, 02:06 AM
Well, because I'm impatient as all get out, I've gone ahead and reinstalled...

To be completely honest, I've got it down to a 2-3 hour affair. (keep /home on a separate partition, list of packages, etc)

But, installing just the 8.10 fresh install, fglrx, flash, ffmpeg, build-essential, and the various different dependencies has got it working...

I'm only going to install a few new packages at a time, and see exactly what caused it to break.

But, yeah, the reinstall worked, and worked quickly... Hate to go through this again tho...

Thanks for the info. I'll keep a close watch on it this time, and I'll let you know what I find out...

August 24th, 2009, 02:14 AM
I'm installing updates, and I've locked the Kernel Version to 2.6.27-7, so shouldn't get any suprises from that...

August 24th, 2009, 02:31 AM
Hi GothPanda,

OK. Hopefully no surprises this time. And you're on the alert.

August 24th, 2009, 04:43 PM
Well, it did the updates fine, but apparently there's some package that's causing it to break, cause it did it again.

I have to run to work, otherwise I'd put out some more information...

But, right now, a package list:

abiword install
abiword-common install
abiword-help install
abiword-plugin-grammar install
abiword-plugin-mathview install
acidrip install
acl install
aconnectgui install
acpi install
acpi-support install
acpid install
adduser install
agave install
aircrack-ng install
alacarte install
alarm-clock install
albumshaper install
alexandria install
alsa-base install
alsa-oss install
alsa-tools install
alsa-tools-gui install
alsa-utils install
anacron install
apache2 install
apache2-mpm-prefork install
apache2-utils install
apache2.2-common install
app-install-data install
app-install-data-commercial install
apparmor install
apparmor-utils install
apport install
apport-gtk install
apt install
apt-transport-https install
apt-utils install
apt-xapian-index install
aptitude install
aptoncd install
apturl install
asoundconf-gtk install
aspell install
aspell-en install
asterisk install
asterisk-config install
asterisk-sounds-main install
at install
at-spi install
audacity install
autoconf install
automake install
autopano-sift install
autotools-dev install
avahi-autoipd install
avahi-daemon install
avahi-utils install
avant-window-navigator install
avant-window-navigator-data install
awn-applets-c-core install
awn-applets-c-extras install
awn-applets-python-core install
awn-applets-python-extras install
awn-manager install
base-files install
base-passwd install
bash install
bash-completion install
bc install
belocs-locales-bin install
bind9-host install
binfmt-support install
binutils install
binutils-static install
blt install
blubuntu-gdm-theme install
bluetooth install
bluez install
bluez-alsa install
bluez-cups install
bluez-gnome install
bluez-gstreamer install
bluez-utils install
bogofilter install
bogofilter-bdb install
bogofilter-common install
brasero install
brltty install
brltty-x11 install
bsdmainutils install
bsdutils install
build-essential install
busybox-initramfs install
bzip2 install
bzr install
bzrtools install
ca-certificates install
ca-certificates-java install
cabextract install
capplets-data install
casper install
cdparanoia install
cdrdao install
chameleon-cursor-theme install
check install
cheese install
chromium-browser install
chromium-codecs-ffmpeg install
cli-common install
cmatrix install
comerr-dev install
comix install
command-not-found install
command-not-found-data install
community-themes install
compiz install
compiz-core install
compiz-fusion-plugins-extra install
compiz-fusion-plugins-main install
compiz-gnome install
compiz-plugins install
compiz-wrapper install
compizconfig-backend-gconf install
compizconfig-settings-manager install
console-setup install
console-terminus install
consolekit install
contact-lookup-applet install
coreutils install
cpio install
cpp install
cpp-4.3 install
cron install
crystalcursors install
cups install
cups-bsd install
cups-client install
cups-common install
cups-driver-gutenprint install
cupsddk install
cupsddk-drivers install
curl install
curlftpfs install
dash install
dbconfig-common install
dbus install
dbus-x11 install
dc install
dcraw install
debconf install
debconf-i18n install
debhelper install
debianutils install
defoma install
deskbar-applet install
desktop-file-utils install
dhcp3-client install
dhcp3-common install
dialog install
dictionaries-common install
diff install
dirac install
discover install
discover-data install
dkms install
dmidecode install
dmsetup install
dmz-cursor-theme install
dnsmasq-base install
dnsutils install
doc-base install
docbook-xml install
docbook-xsl install
docbook-xsl-doc-html install
dosfstools install
dpkg install
dpkg-dev install
dvd+rw-tools install
dvdauthor install
dvdisaster install
dvdisaster-doc install
dvgrab install
e2fslibs install
e2fsprogs install
ecryptfs-utils install
ed install
eject install
ekiga install
enblend install
eog install
esound-clients install
esound-common install
espeak install
espeak-data install
ethtool install
evince install
evolution install
evolution-common install
evolution-data-server install
evolution-data-server-common install
evolution-exchange install
evolution-plugins install
evolution-webcal install
exaile install
example-content install
exiv2 install
f-spot install
fakeroot install
fast-user-switch-applet install
ffmpeg install
fglrx-amdcccle install
fglrx-kernel-source install
fglrx-modaliases install
file install
file-roller install
findutils install
finger install
firefox install
firefox-3.0 install
firefox-3.0-branding install
firefox-3.0-gnome-support install
firefox-gnome-support install
flashplugin-nonfree install
fontconfig install
fontconfig-config install
foo2zjs install
foomatic-db install
foomatic-db-engine install
foomatic-db-hpijs install
foomatic-filters install
fortune-mod install
fortunes-min install
freeglut3 install
freepats install
friendly-recovery install
ftp install
fuse-utils install
fusion-icon install
g++ install
g++-4.3 install
gamin install
gawk install
gcalctool install
gcc install
gcc-4.3 install
gcc-4.3-base install
gconf-editor install
gconf2 install
gconf2-common install
gdb install
gdebi install
gdebi-core install
gdm install
gdm-guest-session install
gedit install
gedit-common install
genisoimage install
gettext install
gettext-base install
gftp-common install
gfxboot install
ggzcore-bin install
ghostscript install
ghostscript-x install
giblib1 install
gimp install
gimp-data install
gimp-help-common install
gimp-help-en install
gisomount install
git-core install
gksu install
glabels install
glabels-data install
gnome-about install
gnome-accessibility-themes install
gnome-alsamixer install
gnome-app-install install
gnome-applets install
gnome-applets-data install
gnome-art install
gnome-cards-data install
gnome-control-center install
gnome-desktop-data install
gnome-doc-utils install
gnome-games install
gnome-games-data install
gnome-icon-theme install
gnome-keyring install
gnome-mag install
gnome-media install
gnome-media-common install
gnome-menus install
gnome-mime-data install
gnome-mount install
gnome-netstatus-applet install
gnome-nettool install
gnome-orca install
gnome-panel install
gnome-panel-data install
gnome-pilot install
gnome-pilot-conduits install
gnome-power-manager install
gnome-screensaver install
gnome-session install
gnome-settings-daemon install
gnome-spell install
gnome-splashscreen-manager install
gnome-system-monitor install
gnome-system-tools install
gnome-terminal install
gnome-terminal-data install
gnome-themes install
gnome-themes-extras install
gnome-user-guide install
gnome-utils install
gnupg install
gparted install
gpgv install
graphviz install
grep install
groff-base install
grub install
grub-common install
gsfonts install
gsfonts-x11 install
gstreamer0.10-alsa install
gstreamer0.10-ffmpeg install
gstreamer0.10-fluendo-mp3 install
gstreamer0.10-gnomevfs install
gstreamer0.10-plugins-bad install
gstreamer0.10-plugins-bad-multiverse install
gstreamer0.10-plugins-base install
gstreamer0.10-plugins-base-apps install
gstreamer0.10-plugins-good install
gstreamer0.10-plugins-ugly install
gstreamer0.10-plugins-ugly-multiverse install
gstreamer0.10-pulseaudio install
gstreamer0.10-schroedinger install
gstreamer0.10-tools install
gstreamer0.10-x install
gtk-chtheme install
gtk-recordmydesktop install
gtk2-engines install
gtk2-engines-cleanice install
gtk2-engines-murrine install
gtk2-engines-nimbus install
gtk2-engines-pixbuf install
gucharmap install
guile-1.8-libs install
gvfs install
gvfs-backends install
gvfs-bin install
gvfs-fuse install
gweled install
gzip install
hal install
hal-cups-utils install
hal-info install
handbrake-common install
handbrake-gtk install
hdparm install
hicolor-icon-theme install
hostname install
hotkey-setup install
hpijs install
hplip install
hplip-data install
hplip-gui install
html2text install
hugin install
hugin-data install
hugin-tools install
human-icon-theme install
human-theme install
hunspell-en-us install
hwtest install
hwtest-gtk install
ia32-libs install
icedax install
icedtea6-plugin install
ifupdown install
im-switch install
imagemagick install
info install
initramfs-tools install
initscripts install
inkscape install
inputattach install
intltool install
intltool-debian install
iproute install
iptables install
iputils-arping install
iputils-ping install
iputils-tracepath install
irb1.8 install
iso-codes install
isomaster install
jack install
jackd install
jam install
java-common install
jockey-common install
jockey-gtk install
jwm install
kbd install
kde-icons-oxygen install
kdebase-runtime install
kdebase-runtime-bin-kde4 install
kdebase-runtime-data install
kdebase-runtime-data-common install
kdelibs-bin install
kdelibs-data install
kdelibs4c2a install
kdelibs5 install
kdelibs5-data install
kdenlive install
kdenlive-data install
keyutils install
khelpcenter4 install
kino install
klibc-utils install
klogd install
lame install
language-pack-en install
language-pack-en-base install
language-pack-gnome-en install
language-pack-gnome-en-base install
language-selector install
language-selector-common install
language-support-en install
language-support-translations-en install
language-support-writing-en install
laptop-detect install
laptop-mode-tools install
latex-xft-fonts install
launchpad-integration install
less install
lftp install
lib32asound2 install
lib32gcc1 install
lib32ncurses5 install
lib32nss-mdns install
lib32stdc++6 install
lib32v4l-0 install
lib32z1 install
liba52-0.7.4 install
liba52-0.7.4-dev install
libaa1 install
libaccess-bridge-java install
libacl1 install
libaiksaurus-1.2-0c2a install
libaiksaurus-1.2-data install
libaiksaurusgtk-1.2-0c2a install
libamazon-ruby install
libao2 install
libapache2-mod-php5 install
libapm1 install
libapparmor-perl install
libapparmor1 install
libapr1 install
libaprutil1 install
libarchive1 install
libart-2.0-2 install
libart2-ruby1.8 install
libart2.0-cil install
libarts1c2a install
libartsc0 install
libasound2 install
libasound2-dev install
libasound2-plugins install
libaspell15 install
libass1 install
libatk1-ruby1.8 install
libatk1.0-0 install
libatk1.0-data install
libatk1.0-dev install
libatm1 install
libatspi1.0-0 install
libattr1 install
libaudio2 install
libaudiofile0 install
libavahi-client-dev install
libavahi-client3 install
libavahi-common-data install
libavahi-common-dev install
libavahi-common3 install
libavahi-compat-libdnssd1 install
libavahi-core5 install
libavahi-glib1 install
libavahi-gobject0 install
libavahi-qt3-1 install
libavahi-ui0 install
libavc1394-0 install
libavcodec-unstripped-51 install
libavcodec51 deinstall
libavdevice52 install
libavformat52 install
libavutil-unstripped-49 install
libavutil49 deinstall
libawn-extras0 install
libawn0 install
libbabl-0.0-0 install
libbeagle1 install
libbind9-40 install
libblas3gf install
libblkid1 install
libbluetooth3 install
libbonobo2-0 install
libbonobo2-common install
libbonoboui2-0 install
libbonoboui2-common install
libboost-regex1.34.1 install
libboost-thread1.34.1 install
libbrasero-media0 install
libbrlapi0.5 install
libbz2-1.0 install
libbz2-dev install
libc-client2007b install
libc6 install
libc6-dev install
libc6-i386 install
libcaca0 install
libcairo-perl install
libcairo-ruby1.8 install
libcairo2 install
libcairo2-dev install
libcairomm-1.0-1 install
libcamel1.2-14 install
libcanberra-gnome install
libcanberra-gtk-module install
libcanberra-gtk0 install
libcanberra0 install
libcap1 install
libcap2 install
libcdaudio1 install
libcdio-cdda0 install
libcdio-paranoia0 install
libcdio7 install
libcdparanoia0 install
libcelt0 install
libck-connector0 install
libclass-accessor-perl install
libclucene0ldbl install
libcomerr2 install
libcompizconfig0 install
libcompress-raw-zlib-perl install
libcompress-zlib-perl install
libcroco3 install
libcryptui0 install
libcucul0 install
libcups2 install
libcupsimage2 install
libcurl3 install
libcurl3-gnutls install
libcurl4-openssl-dev install
libcwidget3 install
libcwiid1 install
libdaemon0 install
libdatrie0 install
libdb4.6 install
libdb4.7 install
libdbd-mysql-perl install
libdbi-perl install
libdbus-1-3 install
libdbus-1-dev install
libdbus-glib-1-2 install
libdbus-glib-1-dev install
libdc1394-22 install
libdc1394-22-dev install
libdca0 install
libdebconfclient0 install
libdebian-installer4 install
libdecoration0 install
libdeskbar-tracker install
libdevmapper1.02.1 install
libdigest-sha1-perl install
libdirectfb-1.0-0 install
libdirectfb-dev install
libdirectfb-extra install
libdiscover2 install
libdjvulibre21 install
libdmx1 install
libdns43 install
libdrm2 install
libdv4 install
libdvbpsi4 install
libdvdnav4 install
libdvdread3 install
libebackend1.2-0 install
libebml0 install
libebook1.2-9 install
libecal1.2-7 install
libecryptfs0 install
libedata-book1.2-2 install
libedata-cal1.2-6 install
libedataserver1.2-11 install
libedataserverui1.2-8 install
libedit2 install
libeel2-2 install
libeel2-data install
libegroupwise1.2-13 install
libelf1 install
libenca0 install
libenchant1c2a install
libept0 install
liberror-perl install
libesd-alsa0 install
libespeak1 install
libevolution3.0-cil install
libexchange-storage1.2-3 install
libexempi3 install
libexif12 install
libexiv2-4 install
libexpat1 install
libexpat1-dev install
libfaac0 install
libfaad0 install
libffi5 install
libfftw3-3 install
libfile-basedir-perl install
libfile-desktopentry-perl install
libfile-mimeinfo-perl install
libflac++6 install
libflac8 install
libflickrnet2.1.5-cil install
libfltk1.1 install
libfont-afm-perl install
libfontconfig1 install
libfontconfig1-dev install
libfontenc1 install
libfreebob0 install
libfreetype6 install
libfreetype6-dev install
libfreezethaw-perl install
libfribidi0 install
libfs6 install
libfuse2 install
libgadu3 install
libgail-gnome-module install
libgamin0 install
libgc1c2 install
libgcc1 install
libgconf2-4 install
libgconf2-ruby install
libgconf2-ruby1.8 install
libgconf2.0-cil install
libgconfmm-2.6-1c2 install
libgcrypt11 install
libgd2-noxpm deinstall
libgd2-xpm install
libgda3-3 install
libgda3-bin install
libgda3-common install
libgdata-google1.2-1 install
libgdata1.2-1 install
libgdbm3 install
libgdiplus install
libgdk-pixbuf2 install
libgdk-pixbuf2-ruby1.8 install
libgdl-1-0 install
libgdl-1-common install
libgdome2-0 install
libgdome2-cpp-smart0c2a install
libgegl-0.0-0 install
libgettext-ruby1.8 install
libgfortran3 install
libggi-target-x install
libggi2 install
libggz2 install
libggzcore9 install
libggzmod4 install
libgif4 install
libgii1 install
libgii1-target-x install
libgimp2.0 install
libgksu2-0 install
libgl1-mesa-dri install
libgl1-mesa-glx install
libglade2-0 install
libglade2-ruby install
libglade2-ruby1.8 install
libglade2.0-cil install
libglademm-2.4-1c2a install
libgle3 install
libglew1.5 install
libglib-perl install
libglib1.2ldbl install
libglib2-ruby1.8 install
libglib2.0-0 install
libglib2.0-cil install
libglib2.0-data install
libglib2.0-dev install
libglibmm-2.4-1c2a install
libglitz-glx1 install
libglitz1 install
libglu1-mesa install
libglut3 install
libgmime-2.0-2a install
libgmime2.2-cil install
libgmp3c2 install
libgmyth0 install
libgnome-desktop-2-7 install
libgnome-keyring0 install
libgnome-keyring1.0-cil install
libgnome-mag2 install
libgnome-media0 install
libgnome-menu2 install
libgnome-pilot2 install
libgnome-speech7 install
libgnome-vfs2.0-cil install
libgnome-window-settings1 install
libgnome2-0 install
libgnome2-canvas-perl install
libgnome2-common install
libgnome2-perl install
libgnome2-ruby install
libgnome2-ruby1.8 install
libgnome2-vfs-perl install
libgnome2.0-cil install
libgnomecanvas2-0 install
libgnomecanvas2-common install
libgnomecanvas2-ruby1.8 install
libgnomecups1.0-1 install
libgnomekbd-common install
libgnomekbd3 install
libgnomekbdui3 install
libgnomeprint2.2-0 install
libgnomeprint2.2-data install
libgnomeprintui2.2-0 install
libgnomeprintui2.2-common install
libgnomeui-0 install
libgnomeui-common install
libgnomevfs2-0 install
libgnomevfs2-bin install
libgnomevfs2-common install
libgnomevfs2-extra install
libgnutls26 install
libgomp1 install
libgoocanvas-common install
libgoocanvas3 install
libgp11-0 install
libgpg-error0 install
libgpgme11 install
libgphoto2-2 install
libgphoto2-port0 install
libgpm2 install
libgpod-common install
libgpod3 install
libgraphviz4 install
libgs8 install
libgsf-1-114 install
libgsf-1-common install
libgsl0ldbl install
libgsm1 install
libgsm1-dev install
libgstreamer-plugins-base0.10-0 install
libgstreamer-plugins-base0.10-dev install
libgstreamer0.10-0 install
libgstreamer0.10-dev install
libgtk-vnc-1.0-0 install
libgtk1.2 install
libgtk1.2-common install
libgtk2-perl install
libgtk2-ruby1.8 install
libgtk2-spell-perl install
libgtk2.0-0 install
libgtk2.0-bin install
libgtk2.0-cil install
libgtk2.0-common install
libgtk2.0-dev install
libgtkglext1 install
libgtkhtml-editor-common install
libgtkhtml-editor0 install
libgtkhtml2-0 install
libgtkhtml3.14-19 install
libgtkmathview0c2a install
libgtkmm-2.4-1c2a install
libgtksourceview-common install
libgtksourceview1.0-0 install
libgtksourceview2.0-0 install
libgtksourceview2.0-common install
libgtkspell0 install
libgtop2-7 install
libgtop2-common install
libgucharmap7 install
libgutenprint2 install
libgvfscommon0 install
libgweather-common install
libgweather1 install
libhal-dev install
libhal-storage-dev install
libhal-storage1 install
libhal1 install
libhesiod0 install
libhpricot-ruby install
libhpricot-ruby1.8 install
libhtml-format-perl install
libhtml-parser-perl install
libhtml-tagset-perl install
libhtml-template-perl install
libhtml-tree-perl install
libhunspell-1.2-0 install
libhyphen0 install
libical0 install
libice-dev install
libice6 install
libicu38 install
libid3tag0 install
libidl0 install
libidn11 install
libidn11-dev install
libiec61883-0 install
libieee1284-3 install
libijs-0.35 install
libiksemel3 install
libilmbase6 install
libimage-exiftool-perl install
libimage-size-ruby1.8 install
libimlib2 install
libio-compress-base-perl install
libio-compress-zlib-perl install
libio-string-perl install
libiptcdata0 install
libisc44 install
libisccc40 install
libisccfg40 install
libiso9660-5 install
libiw29 install
libjack0 install
libjasper1 install
libjpeg-progs install
libjpeg62 install
libjpeg62-dev install
libkadm55 install
libkeyutils1 install
libklibc install
libkpathsea4 install
libkrb5-dev install
libkrb53 install
liblapack3gf install
liblaunchpad-integration1 install
liblcms1 install
libldap-2.4-2 install
libldap2-dev install
liblink-grammar4 install
liblircclient0 install
liblocale-gettext-perl install
liblockfile1 install
libloudmouth1-0 install
liblpint-bonobo0 install
liblrdf0 install
libltdl7 install
libltdl7-dev install
liblua5.1-0 install
liblua50 install
liblualib50 install
liblwres40 install
liblzo1 install
liblzo2-2 install
libmad0 install
libmagic1 install
libmagick++10 install
libmagick10 install
libmail-sendmail-perl install
libmailtools-perl install
libmatroska0 install
libmbca0 install
libmcrypt4 install
libmeanwhile1 install
libmetacity0 install
libmikmod2 install
libmiracle0.2.5 install
libmjpegtools0c2a install
libmldbm-perl install
libmlt++0.2.5 install
libmlt-data install
libmlt0.2.5 install
libmms0 install
libmng1 install
libmodplug0c2 install
libmono-addins-gui0.2-cil install
libmono-addins0.2-cil install
libmono-cairo1.0-cil install
libmono-cairo2.0-cil install
libmono-corlib1.0-cil install
libmono-corlib2.0-cil install
libmono-data-tds1.0-cil install
libmono-data-tds2.0-cil install
libmono-i18n1.0-cil install
libmono-i18n2.0-cil install
libmono-security1.0-cil install
libmono-security2.0-cil install
libmono-sharpzip0.84-cil install
libmono-sharpzip2.84-cil install
libmono-sqlite2.0-cil install
libmono-system-data1.0-cil install
libmono-system-data2.0-cil install
libmono-system-web1.0-cil install
libmono-system-web2.0-cil install
libmono-system1.0-cil install
libmono-system2.0-cil install
libmono0 install
libmono1.0-cil install
libmono2.0-cil install
libmp3lame0 install
libmpcdec3 install
libmpeg2-4 install
libmpeg4ip-0 install
libmpeg4ip-dev install
libmpfr1ldbl install
libmtp8 install
libmusicbrainz4c2a install
libmysql++-dev install
libmysql++3 install
libmysql-java install
libmysqlclient15-dev install
libmysqlclient15off install
libnautilus-burn4 install
libnautilus-extension1 install
libncurses5 install
libncurses5-dev install
libncursesw5 install
libndesk-dbus-glib1.0-cil install
libndesk-dbus1.0-cil install
libneon27 install
libneon27-gnutls install
libnet-daemon-perl install
libnet-dbus-perl install
libnetpbm10 install
libnewt0.52 install
libnl1 install
libnm-glib0 install
libnm-util0 install
libnotify-bin install
libnotify-dev install
libnotify0.4-cil install
libnotify1 install
libnspr4-0d install
libnss-mdns install
libnss3-1d install
libntfs-3g28 install
libntfs10 install
libofa0 install
libogg-dev install
libogg0 install
liboil0.3 install
liboobs-1-4 install
libopal-2.2 install
libopenal1 install
libopenexr6 install
libopenobex1 install
libopenssl-ruby1.8 install
liborbit2 install
libotr2 install
libots0 install
libpam-ck-connector install
libpam-gnome-keyring install
libpam-modules install
libpam-runtime install
libpam-smbpass install
libpam0g install
libpanel-applet2-0 install
libpango1-ruby1.8 install
libpango1.0-0 install
libpango1.0-common install
libpango1.0-dev install
libpangomm-1.4-1 install
libpano13-0 install
libpano13-bin install
libpaper-utils install
libpaper1 install
libparse-debianchangelog-perl install
libparted1.8-9 install
libpcap0.8 install
libpci3 install
libpciaccess-dev install
libpciaccess0 install
libpcre3 install
libpcrecpp0 install
libpcsclite1 install
libperl5.10 install
libphonon4 install
libpisock9 install
libpisync1 install
libpixman-1-0 install
libpixman-1-dev install
libpkcs11-helper1 install
libplot2c2 install
libplrpc-perl install
libpng12-0 install
libpng12-dev install
libpolkit-dbus2 install
libpolkit-gnome0 install
libpolkit-grant2 install
libpolkit2 install
libpoppler-glib3 install
libpoppler3 install
libpopt-dev install
libpopt0 install
libportaudio0 install
libportaudio2 install
libpostproc51 install
libpq5 install
libpri1.0 install
libpt-1.10.10 install
libpt-1.10.10-plugins-alsa install
libpt-1.10.10-plugins-v4l install
libpt-1.10.10-plugins-v4l2 install
libpth20 install
libpthread-stubs0 install
libpthread-stubs0-dev install
libpulse-browse0 install
libpulse-dev install
libpulse-mainloop-glib0 install
libpulse0 install
libpulsecore5 install
libpurple-bin install
libpurple0 install
libqt3-mt install
libqt4-assistant install
libqt4-core install
libqt4-dbus install
libqt4-designer install
libqt4-gui install
libqt4-help install
libqt4-network install
libqt4-opengl install
libqt4-qt3support install
libqt4-script install
libqt4-sql install
libqt4-sql-mysql install
libqt4-svg install
libqt4-test install
libqt4-webkit install
libqt4-xml install
libqt4-xmlpatterns install
libqtcore4 install
libqtgui4 install
libquicktime1 install
libradiusclient-ng2 install
libraptor1 install
librarian0 install
librasqal0 install
libraw1394-8 install
libraw1394-dev install
librdf0 install
libreadline-ruby1.8 install
libreadline5 install
librecode0 install
librevolution-ruby install
librevolution-ruby1.8 install
librpc-xml-perl install
librsvg2-2 install
librsvg2-common install
libruby1.8 install
libsamplerate0 install
libsane install
libsasl2-2 install
libsasl2-modules install
libschroedinger-1.0-0 install
libscim8c2a install
libsdl-gfx1.2-4 install
libsdl-image1.2 install
libsdl-mixer1.2 install
libsdl-sound1.2 install
libsdl1.2debian install
libsdl1.2debian-alsa install
libselinux1 install
libsensors3 install
libsepol1 install
libsexy2 install
libsgutils1 install
libshout3 install
libsidplay1 install
libsigc++-2.0-0c2a install
libsilc-1.1-2 install
libslang2 install
libslp1 install
libsm-dev install
libsm6 install
libsmbclient install
libsmbios-bin install
libsmbios2 install
libsmpeg0 install
libsndfile1 install
libsnmp-base install
libsnmp15 install
libsoprano4 install
libsoundtouch1c2 install
libsoup2.4-1 install
libsox-fmt-all install
libsox-fmt-alsa install
libsox-fmt-ao install
libsox-fmt-base install
libsox-fmt-ffmpeg install
libsox-fmt-flac install
libsox-fmt-gsm install
libsox-fmt-mp3 install
libsox-fmt-ogg install
libsox-fmt-oss install
libsox-fmt-sndfile install
libsox0 install
libspectre1 install
libspeex-dev install
libspeex1 install
libspeexdsp1 install
libsqlite0 install
libsqlite3-0 install
libss2 install
libssl-dev install
libssl0.9.8 install
libstartup-notification0 install
libstdc++6 install
libstdc++6-4.3-dev install
libstreamanalyzer0 install
libstreams0 install
libstrigiqtdbusclient0 install
libsuitesparse-3.1.0 install
libsvga1 install
libsvn1 install
libswscale0 install
libsys-hostname-long-perl install
libsysfs-dev install
libsysfs2 install
libt1-5 install
libtag1c2a install
libtalloc1 install
libtar install
libtasn1-3 install
libtdb1 install
libterm-readkey-perl install
libtext-charwidth-perl install
libtext-iconv-perl install
libtext-wrapi18n-perl install
libthai-data install
libthai0 install
libtheora-bin install
libtheora-dev install
libtheora0 install
libtidy-0.99-0 install
libtie-ixhash-perl install
libtiff4 install
libtimedate-perl install
libtonezone1 install
libtool install
libtotem-plparser12 install
libtracker-gtk0 install
libtrackerclient0 install
libtre4 install
libts-0.0-0 install
libtspi1 install
libtwolame0 install
libuniconf4.4 install
libunique-1.0-0 install
liburi-perl install
libusb-0.1-4 install
libusplash0 install
libuuid-perl install
libuuid1 install
libv4l-0 install
libvala0 install
libvalerie0.2.5 install
libvcdinfo0 install
libvisual-0.4-0 install
libvisual-0.4-plugins install
libvlc2 install
libvlccore0 install
libvolume-id0 install
libvorbis-dev install
libvorbis0a install
libvorbisenc2 install
libvorbisfile3 install
libvpb0 install
libvte-common install
libvte9 install
libwavpack1 install
libwbclient0 install
libwebkit-1.0-1 install
libwebkit-dev install
libwildmidi0 install
libwmf-bin install
libwmf0.2-7 install
libwnck-common install
libwnck22 install
libwpd8c2a install
libwpg-0.1-1 install
libwps-0.1-1 install
libwrap0 install
libwv-1.2-3 install
libwvstreams4.4-base install
libwvstreams4.4-extras install
libwww-mechanize-ruby install
libwww-mechanize-ruby1.8 install
libwww-perl install
libwxbase2.6-0 install
libwxbase2.8-0 install
libwxgtk2.6-0 install
libwxgtk2.8-0 install
libwxsvg0 install
libx11-6 install
libx11-data install
libx11-dev install
libx11-xcb1 install
libx264-59 install
libx86-1 install
libxapian15 install
libxau-dev install
libxau6 install
libxaw7 install
libxcb-render-util0 install
libxcb-render-util0-dev install
libxcb-render0 install
libxcb-render0-dev install
libxcb-shape0 install
libxcb-shm0 install
libxcb-xlib0 install
libxcb-xlib0-dev install
libxcb-xv0 install
libxcb1 install
libxcb1-dev install
libxcomposite-dev install
libxcomposite1 install
libxcursor-dev install
libxcursor1 install
libxdamage-dev install
libxdamage1 install
libxdmcp-dev install
libxdmcp6 install
libxevie1 install
libxext-dev install
libxext6 install
libxfixes-dev install
libxfixes3 install
libxfont1 install
libxft-dev install
libxft2 install
libxi-dev install
libxi6 install
libxine1 install
libxine1-bin install
libxine1-console install
libxine1-ffmpeg install
libxine1-misc-plugins install
libxine1-x install
libxinerama-dev install
libxinerama1 install
libxkbfile1 install
libxklavier12 install
libxml++2.6-2 install
libxml-namespacesupport-perl install
libxml-parser-perl install
libxml-sax-expat-perl install
libxml-sax-perl install
libxml-simple-perl install
libxml-twig-perl install
libxml-xpath-perl install
libxml2 install
libxml2-dev install
libxml2-utils install
libxmu6 install
libxmuu1 install
libxp6 install
libxplc0.3.13 install
libxpm4 install
libxrandr-dev install
libxrandr2 install
libxrender-dev install
libxrender1 install
libxres1 install
libxslt1.1 install
libxss1 install
libxt-dev install
libxt6 install
libxtrap6 install
libxtst6 install
libxv1 install
libxvidcore4 install
libxvmc1 install
libxxf86dga1 install
libxxf86misc1 install
libxxf86vm1 install
libzephyr3 install
libzip1 install
lilo install
link-grammar-dictionaries-en install
linux-firmware install
linux-generic install
linux-headers-2.6.27-14 install
linux-headers-2.6.27-14-generic install
linux-headers-2.6.27-7 install
linux-headers-2.6.27-7-generic install
linux-headers-generic install
linux-image-2.6.27-14-generic install
linux-image-2.6.27-7-generic install
linux-image-generic install
linux-libc-dev install
linux-restricted-modules-2.6.27-14-generic install
linux-restricted-modules-2.6.27-7-generic install
linux-restricted-modules-common install
linux-restricted-modules-generic install
linux-sound-base install
localechooser-data install
locales install
lockfile-progs install
login install
logrotate install
lp-solve install
lsb-base install
lsb-release install
lsdvd install
lshw install
lsof install
lswm install
ltrace install
lynx install
lzma install
m4 install
make install
makedev install
man-db install
manpages install
mawk install
mbr install
mdetect install
memtest86+ install
mencoder install
menu install
mesa-utils install
metacity install
metacity-common install
midori install
mime-support install
min12xxw install
mjpegtools install
mktemp install
mkvtoolnix install
mlocate install
mlock install
mobile-broadband-provider-info install
module-assistant install
module-init-tools install
mono-common install
mono-gac install
mono-jit install
mono-runtime install
mount install
mouseemu install
mousetweaks install
mplayer install
mplayer-skins install
mscompress install
msttcorefonts install
mtools install
mtr-tiny install
myspell-en-au install
myspell-en-gb install
myspell-en-us deinstall
myspell-en-za install
mysql-client install
mysql-client-5.0 install
mysql-common install
mysql-server install
mysql-server-5.0 install
nano install
nautilus install
nautilus-cd-burner install
nautilus-data install
nautilus-dropbox install
nautilus-sendto install
nautilus-share install
ncurses-base install
ncurses-bin install
net-tools install
netbase install
netcat install
netcat-traditional install
netpbm install
netsurf install
network-manager install
network-manager-gnome install
nimbus-icon-theme install
nmap install
notification-daemon install
nspluginwrapper install
ntfs-3g install
ntfsprogs install
ntp install
ntpdate install
nvidia-173-modaliases install
nvidia-177-modaliases install
nvidia-180-modaliases install
nvidia-71-modaliases install
nvidia-96-modaliases install
nvidia-common install
obex-data-server install
odbcinst1debian1 install
odt2txt install
ogmtools install
onboard install
openjdk-6-jre install
openjdk-6-jre-headless install
openjdk-6-jre-lib install
openoffice.org-base-core install
openoffice.org-calc install
openoffice.org-common install
openoffice.org-core install
openoffice.org-draw install
openoffice.org-emailmerge install
openoffice.org-gnome install
openoffice.org-gtk install
openoffice.org-help-en-gb install
openoffice.org-help-en-us install
openoffice.org-hyphenation install
openoffice.org-hyphenation-en-us install
openoffice.org-impress install
openoffice.org-l10n-common install
openoffice.org-l10n-en-gb install
openoffice.org-l10n-en-za install
openoffice.org-math install
openoffice.org-style-human install
openoffice.org-thesaurus-en-au install
openoffice.org-thesaurus-en-us install
openoffice.org-writer install
openprinting-ppds install
openssh-client install
openssh-server install
openssl install
openssl-blacklist install
os-prober install
padevchooser install
paman install
paprefs install
parted install
passwd install
patch install
pavucontrol install
pavumeter install
pciutils install
pcmciautils install
pcsx-df install
perl install
perl-base install
perl-modules install
perlmagick install
phonon install
phonon-backend-gstreamer install
php5 install
php5-common install
php5-gd install
php5-mcrypt install
php5-mysql install
phpmyadmin install
picasa install
pidgin install
pidgin-data install
pidgin-facebookchat install
pidgin-libnotify install
pidgin-otr install
pkg-config install
pm-utils install
pmount install
pnm2ppa install
po-debconf install
policykit install
policykit-gnome install
poppler-utils install
popularity-contest install
powermanagement-interface install
powermgmt-base install
powernowd install
ppp install
pppconfig install
pppoeconf install
procps install
psfontmgr install
psmisc install
pulseaudio install
pulseaudio-esound-compat install
pulseaudio-module-gconf install
pulseaudio-module-hal install
pulseaudio-module-x11 install
pulseaudio-module-zeroconf install
pulseaudio-utils install
pxljr install
python install
python-all install
python-all-dev install
python-alsaaudio install
python-apport install
python-apt install
python-awn install
python-awn-extras install
python-awnlib install
python-beagle install
python-brlapi install
python-cairo install
python-cddb install
python-central install
python-chardet install
python-compizconfig install
python-crypto install
python-cups install
python-cupshelpers install
python-cwiid install
python-dateutil install
python-dbus install
python-debian install
python-dev install
python-elementtree install
python-eyed3 install
python-feedparser install
python-fstab install
python-gamin install
python-gconf install
python-gdata install
python-gdbm install
python-glade2 install
python-gmenu install
python-gnome2 install
python-gnome2-desktop install
python-gnome2-extras install
python-gnomecanvas install
python-gnupginterface install
python-gobject install
python-gpod install
python-gst0.10 install
python-gtk2 install
python-gtkhtml2 install
python-gtksourceview2 install
python-imaging install
python-launchpad-bugs install
python-launchpad-integration install
python-libxml2 install
python-lxml install
python-minimal install
python-mutagen install
python-newt install
python-notify install
python-numeric install
python-numpy install
python-ogg install
python-paramiko install
python-pexpect install
python-pkg-resources install
python-problem-report install
python-pyatspi install
python-pyogg install
python-pyorbit install
python-pysqlite2 install
python-pyvorbis install
python-qt3 install
python-qt4 install
python-qt4-common install
python-qt4-dbus install
python-rdflib install
python-reportlab install
python-reportlab-accel install
python-sexy install
python-sip4 install
python-software-properties install
python-sqlalchemy install
python-sqlite install
python-support install
python-uniconvertor install
python-uno install
python-usb install
python-utidylib install
python-virtkey install
python-vte install
python-wxgtk2.8 install
python-wxversion install
python-xapian install
python-xdg install
python-xkit install
python-xlib install
python2.4 install
python2.4-dev install
python2.4-minimal install
python2.5 install
python2.5-dev install
python2.5-minimal install
qjackctl install
qt4-qtconfig install
radeontool install
raptor-utils install
rarian-compat install
rdate install
rdesktop install
readahead install
readline-common install
recordmydesktop install
redland-utils install
reiserfsprogs install
resolvconf install
rhino install
rhythmbox install
rss-glx install
rsync install
ruby install
ruby1.8 install
samba install
samba-common install
sane-utils install
scim install
scim-bridge-agent install
scim-bridge-client-gtk install
scim-gtk2-immodule install
scim-modules-socket install
screen install
screen-resolution-extra install
screensaver-default-images install
scrot install
seahorse install
seahorse-plugins install
sed install
sg3-utils install
sgml-base install
sgml-data install
shared-mime-info install
smartdimmer install
smbclient install
software-properties-gtk install
soprano-daemon install
soundconverter install
sox install
splix install
sqlite install
sqlite3 install
squashfs-tools install
ssh-askpass-gnome install
sshfs install
ssl-cert install
startup-tasks install
strace install
streamripper install
subversion install
sudo install
sun-java6-bin install
sun-java6-fonts install
sun-java6-jre install
swh-plugins install
synaptic install
sysklogd install
syslinux install
system-config-printer-common install
system-config-printer-gnome install
system-services install
system-tools-backends install
sysv-rc install
sysvinit-utils install
tangerine-icon-theme install
tar install
tasksel install
tasksel-data install
tasque install
tcl8.4 install
tcl8.5 install
tcpd install
tcpdump install
telnet install
thunderbird-locale-en-gb install
time install
tk8.4 install
tk8.5 install
tomboy install
toshset install
totem install
totem-common install
totem-gstreamer install
totem-mozilla install
totem-plugins install
tracker install
tracker-search-tool install
tracker-utils install
transmission-common install
transmission-gtk install
tsclient install
ttf-arabeyes install
ttf-arphic-uming install
ttf-bengali-fonts install
ttf-bitstream-vera install
ttf-dejavu install
ttf-dejavu-core install
ttf-dejavu-extra install
ttf-dustin install
ttf-freefont install
ttf-indic-fonts-core install
ttf-kannada-fonts install
ttf-kochi-gothic install
ttf-kochi-mincho install
ttf-lao install
ttf-liberation install
ttf-opensymbol install
ttf-oriya-fonts install
ttf-sazanami-gothic install
ttf-sazanami-mincho install
ttf-telugu-fonts install
ttf-thai-tlwg install
ttf-unfonts-core install
ttf-wqy-zenhei install
tzdata install
tzdata-java install
ubiquity install
ubiquity-casper install
ubiquity-frontend-gtk install
ubiquity-ubuntu-artwork install
ubufox install
ubuntu-artwork install
ubuntu-desktop install
ubuntu-docs install
ubuntu-gdm-themes install
ubuntu-keyring install
ubuntu-minimal install
ubuntu-restricted-extras install
ubuntu-sounds install
ubuntu-standard install
ubuntu-system-service install
ubuntu-wallpapers install
ucf install
udev install
ufw install
unattended-upgrades install
unixodbc install
unrar install
untex install
unzip install
update-inetd install
update-manager install
update-manager-core install
update-motd install
update-notifier install
update-notifier-common install
upstart install
upstart-compat-sysv install
upstart-logd install
ure install
usb-creator install
usbutils install
user-setup install
usplash install
usplash-theme-ubuntu install
util-linux install
uuid-runtime install
vala-awn install
valac install
vbetool install
vim-common install
vim-tiny install
vinagre install
vino install
virtualbox-ose install
virtualbox-ose-source install
vlc install
vlc-data install
vlc-nox install
vorbis-tools install
vpb-driver-source install
vpnc install
w3m install
wamerican install
wbritish install
wget install
whiptail install
whois install
winbind install
wine install
wine-gecko install
wireless-tools install
wmgui install
wminput install
wodim install
wpasupplicant install
wv install
wvdial install
x-ttcidfont-conf install
x11-apps install
x11-common install
x11-session-utils install
x11-utils install
x11-xfs-utils install
x11-xkb-utils install
x11-xserver-utils install
x11proto-composite-dev install
x11proto-core-dev install
x11proto-damage-dev install
x11proto-dri2-dev install
x11proto-fixes-dev install
x11proto-fonts-dev install
x11proto-input-dev install
x11proto-kb-dev install
x11proto-randr-dev install
x11proto-render-dev install
x11proto-video-dev install
x11proto-xext-dev install
x11proto-xinerama-dev install
xauth install
xautomation install
xbase-clients install
xbitmaps install
xbmc install
xbmc-common install
xbmc-eventclients-common install
xbmc-eventclients-wiiremote install
xbmc-skin-pm3 install
xbmc-skin-pm3-hd install
xbmc-web-pm3 install
xchat install
xchat-common install
xcursor-themes install
xdg-user-dirs install
xdg-user-dirs-gtk install
xdg-utils install
xdm install
xfonts-100dpi install
xfonts-75dpi install
xfonts-base install
xfonts-encodings install
xfonts-scalable install
xfonts-utils install
xine-ui install
xinit install
xinput install
xkb-data install
xml-core install
xmlto install
xorg install
xorg-driver-fglrx install
xournal install
xpad install
xresprobe install
xsane install
xsane-common install
xscreensaver install
xscreensaver-data install
xscreensaver-data-extra install
xscreensaver-gl install
xscreensaver-gl-extra install
xserver-common install
xserver-xorg install
xserver-xorg-core install
xserver-xorg-dev install
xserver-xorg-input-all install
xserver-xorg-input-evdev install
xserver-xorg-input-kbd install
xserver-xorg-input-mouse install
xserver-xorg-input-synaptics install
xserver-xorg-input-vmmouse install
xserver-xorg-input-wacom install
xserver-xorg-video-all install
xserver-xorg-video-apm install
xserver-xorg-video-ark install
xserver-xorg-video-ati install
xserver-xorg-video-chips install
xserver-xorg-video-cirrus install
xserver-xorg-video-fbdev install
xserver-xorg-video-i128 install
xserver-xorg-video-intel install
xserver-xorg-video-mach64 install
xserver-xorg-video-mga install
xserver-xorg-video-neomagic install
xserver-xorg-video-nv install
xserver-xorg-video-openchrome install
xserver-xorg-video-r128 install
xserver-xorg-video-radeon install
xserver-xorg-video-rendition install
xserver-xorg-video-s3 install
xserver-xorg-video-s3virge install
xserver-xorg-video-savage install
xserver-xorg-video-siliconmotion install
xserver-xorg-video-sis install
xserver-xorg-video-sisusb install
xserver-xorg-video-tdfx install
xserver-xorg-video-trident install
xserver-xorg-video-tseng install
xserver-xorg-video-v4l install
xserver-xorg-video-vesa install
xserver-xorg-video-vmware install
xserver-xorg-video-voodoo install
xsltproc install
xterm install
xtrans-dev install
xulrunner-1.9 install
xulrunner-1.9-gnome-support install
xutils install
xutils-dev install
yabause-gtk install
yasm install
yelp install
zenity install
zim install
zip install
zlib1g install
zlib1g-dev install
zlibc install