PDA

View Full Version : 9.04 UNR Acer Aspire One ZG5 Wireless switch and LED



bawkbawkboo1
August 23rd, 2009, 01:44 AM
Minor question about 9.04 UBR. Not sure where I should put this thread, maybe "Networking & Wireless"? I'm putting it here because it is about very specific hardware

On my Acer Aspire One [8.9-inch 1.6GHz Atom, 8GB SSD, 1GB RAM wireless device model Atheros AR5BXB63] the wireless LED worked based on traffic under 8.10 after I had done the following:

put these lines at the end of .etc/sysctl.conf:

dev.wifi0.ledpin=3
dev.wifi0.softled=1

it does not work out of the box on 9.04 UNR and I don't know if the above works anymore. Note that I was useing madwifi drivers before. I have not done any modifications on 9.04. Also the switch doesn't work anymore. Anyone have either feature working? How?

rederic4
August 25th, 2009, 06:56 PM
I am going to post my question under this same topic and hope for some love. I also have an ACER Aspire One ZG5 with a fresh 9.04 UNR install. Wireless was working great. With the netbook running I hit the wireless switch. Wireless continued to work (it did not disconnect). That's fine, when I restarted wireless was off, I could not connect or "see" my wireless network (and yes my wireless network is still up and running) hit switch again, wireless did not come on, restarted computer, wireless did not come on. Any ideas how to fix this or "force" the wireless to restart?

nalberto
August 26th, 2009, 11:46 AM
exact same problem here

ianmillington
August 26th, 2009, 01:30 PM
installing jaunty-backports-modules from within your package manager should sort that out I think.

Omnicr0n
September 9th, 2009, 06:55 PM
Ok, I had the same problem. I was about to format my netbook (that or kill myself ;) when I tried pressing the wifi switch again. And after a couple of minutes...

Yes, it worked. How stupid am I? So make sure that it is not deactivated by the switch, because as we donīt have a working LED we donīt know if itīs on or off.

Good luck, and if thatīs not the anser then check this posts:
http://ubuntuforums.org/showthread.php?t=1150524
and the one which gave me the "enlightenment":
http://www.pubbs.net/ubuntu/200904/56563/

ddrichardson
September 9th, 2009, 06:59 PM
Just for added hilarity, this changes again in the most recent Linux kernel - threw me completely using Arch Linux, it worked setting the LED pins, update and it didn't. Update again and the kernel (non-madwifi) drivers support the LED out of the box.

LuciusMare
September 19th, 2009, 08:12 AM
So i will ask here,i didnt get to connect to my wifi with Ubuntu netbook remix (9.04),and more things didnt work,so i switched to "regular" 9.04.There,my wifi worked well,i hit the switch...nothing happened.Restart,and as said,couldnt connect,scan,nothing.So i hit it again,put on the floor and waited,and it worked.I am using it pretty much out of the box,so no madwifi,but the led doesnt work either.