PDA

View Full Version : [ubuntu] Spotify in WINE means no sound in other programs, and vice versa



ojohnsen79
August 22nd, 2009, 08:24 PM
I've tried searching for any answers on this, but I've come up short so far.

My problem is that whenever I listen to Spotify in WINE, any other program in Ubuntu is dead silent. Doesn't matter if it's Youtube in Firefor, or MP3 files in VLC. And just the same the other way around. If I have Youtube in Firefox active when I try to start up Spotify, I get an error message saying that Spotify has problems with my sound card.

A friend of mine is able to run both Spotify and other programs at the same time without any problems, so I know that it's possible. Unfortunately, he doesn't know what causes my system to fail.

Can anyone help me?

ojohnsen79
August 23rd, 2009, 12:01 PM
Nobody knows anything about this?

UltraAnders
August 29th, 2009, 11:33 AM
I'm getting the same problem ... but I've no idea how to fix it. Which Wine sound drivers are you and your friend using? I'm using OSS.

howefield
August 29th, 2009, 11:47 AM
Which version of wine are you using ?

I am using 1.28 and spotify works perfectly and plays nice with the other sound apps.

If you are using the wine from Ubuntus` repository, have you followed the instructions here ?

http://www.spotify.com/en/help/faq/wine/

UltraAnders
August 29th, 2009, 01:06 PM
I'm using 1.1.28 from the "http://wine.budgetdedicated.com/apt jaunty main" repo.

Farwalker
August 29th, 2009, 02:25 PM
I'm running into the same problem (It's not exclusive to Spotify)- in my case, World of Warcraft (again, under Wine 1.1.28, though from the Hardy repos) either gets an exclusive lock on the sound when started, or plays no sound if another application (or applications) has control of sound.

I'm running 64-bit Kubuntu Hardy, don't know about the OP.

I've tried Wine with Alsa, with OSS, and with aoss... in every case, it doesn't want to play nice with other sound-using processes.

Stumped.

UltraAnders
August 29th, 2009, 04:40 PM
32-bit Jaunty here. Been using the sound test facility in winecfg, which fails if there is another app using sound. Have also tried all the different audio drivers in both "full" and "emulated" hardware acceleration.

dj-toonz
August 29th, 2009, 07:17 PM
I've had the same problem, but going into the wine config & changing the audio from pulse audio to alsa fixed it for me

howefield
August 29th, 2009, 07:25 PM
I've had the same problem, but going into the wine config & changing the audio from pulse audio to alsa fixed it for me

Just to confirm what dj-toonz has written, mine was already at alsa, might be why I had no issues.

UltraAnders
August 30th, 2009, 11:35 AM
Cheers all, working with Alsa drivers (Emulation) after a reset.

aldursys
August 30th, 2009, 07:13 PM
Fixed properly in the upcoming Karmic release if you use my Wine1.2 package.

http://www.3spoken.co.uk/2009/08/making-wine-sound-work-with-pulseaudio.html