View Full Version : [ubuntu] mounting kodak digital camera m1033

August 22nd, 2009, 02:41 AM
Can anyone tell me how to mount a kodak m1033 easyshare digital camera so I can d/l pictures from internal memory? For the answer i have searched wide and far, but it has left me wishing on a star.

August 22nd, 2009, 03:17 AM
See if

sudo lsusb | less

outputs your camera somewhere while it's plugged in. If it does, tell us the output.

August 22nd, 2009, 05:32 AM
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 004 Device 002: ID 04d9:1135 Holtek Semiconductor, Inc.
Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub

thats the info ive been given :)

August 23rd, 2009, 12:59 AM
bump :)

September 9th, 2009, 08:12 PM
Same issues, here is my output:
Bus 001 Device 013: ID 040a:0598 Kodak Co. Digital Camera
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 002 Device 003: ID 045e:00dd Microsoft Corp.
Bus 002 Device 002: ID 045e:0084 Microsoft Corp. Basic Optical Mouse
Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub

Any ideas?

I tried to install the software with Crossover and with WINE, neither worked.

September 9th, 2009, 08:17 PM
Wine isn't supposed to accept drivers.

September 9th, 2009, 10:46 PM
Will this (http://ubuntuforums.org/showthread.php?t=340271) work?

If so, what info based on the above will work?

September 11th, 2009, 04:22 AM

I dont own a Kodak and dont know if there are any kodak specific nuances. Below are my generic observations and suggestions..

I own a Canon and have used it with multiple versions of Ubuntu over the years. Recently, Hardy and Jaunty, without any problems.

From your lsusb output, it looks like the OS is seeing the device.. either it is not taking the right action or the action fails.

You can set the initial action taken when you connect the camera at "System->Preferences->Removable drives and Media ". This is for GNOME. There should be equivalent in KDE and others.

Also, in general, you can try doing a "tail -f /var/log/syslog" in a terminal window before connecting the camera to watch the log messages. Alternatively you can check the file after the fact as well. Posting those messages will help others to troubleshoot as well.

Hope this helps..

January 4th, 2010, 06:44 PM

I'm also having issues getting my Kodak M1033 to work in Ubuntu 9.10 on an IBM Thinkpad T41.

"tail -f /var/log/syslog" gives me this:

kernel: [37747.196160] usb 1-4: new high speed USB device using ehci_hcd and address 7
kernel: [37747.330095] usb 1-4: configuration #1 chosen from 1 choice

But then it opens two Camera icons, 2 windows saying "Kodak EasyShare M1033 Camera" asking me what to do, and an error message window that says

Unable to mount Kodak EasyShare M1033 Digital Camera. Error Initializing Camera: -60: could not lock the device

"lsusb |less" gives me this:

Bus 001 Device 008: ID 040a:0598 Kodak Co. Digital Camera

Any ideas?

January 8th, 2010, 01:48 PM
Check out “gphoto2”. The link:


although your camera is not listed there, gphoto does recognize any “Kodak EasyShare” camera.

If you have “gtkam” (ubuntu) or “digikam” (kubuntu), you have an application with a graphical user interface, both are based on “gphoto2”.

All 3 programs are in the repositories.

My “Kodak M340” is not listed in the “gphoto2” list of supported cameras, but I switched the camera ON and in PHOTO SHOOTING MODE, connected it afterwards to the computer and it was recognized immediately by “digikam”.

My system is Kubuntu 9.10

Good luck