View Full Version : [ubuntu] Failed to initialize GLX extension

August 21st, 2009, 12:41 AM
This is sort of a continuation of this thread:

But to give as much info as possible here's what I'm running on:
Toshiba Qosmio X300
Duo Core 2.66
Nvidia 9800 GTX
2 x 320 GB HDD (windows 7 on one and ubuntu on the other)
32 bit Ubuntu 8.10

Running the 177 Nvidia driver I get the errors:

/var/log/Xorg.0.log:1651:(EE) Failed to initialize GLX extension (Compatible NVIDIA X driver not found)
/var/log/Xorg.failsafe.log:1651:(EE) Failed to initialize GLX extension (Compatible NVIDIA X driver not found)
and here is my xorg.conf file

# xorg.conf (X.Org X Window System server configuration file)
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
# Edit this file with caution, and see the xorg.conf manual page.
# (Type "man xorg.conf" at the shell prompt.)
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
# Note that some configuration settings that could be done previously
# in this file, now are automatically configured by the server and settings
# here are ignored.
# If you have edited this file but would like it to be automatically updated
# again, run the following command:
# sudo dpkg-reconfigure -phigh xserver-xorg

Section "Monitor"
Identifier "Configured Monitor"

Section "Screen"
Identifier "Default Screen"
Monitor "Configured Monitor"
Device "Configured Video Device"
DefaultDepth 24

Section "Module"
Load "glx"
Disable "dri2"

Section "Device"
Identifier "Configured Video Device"
Driver "nvidia"
Also back when i was running 9.04 I had a thread on this forum:

And the latest poster has suggested that i edit my kernel boot parameters. How does one go about this and is it wise?

Anway any help you can give I would be eternally grateful for.

August 21st, 2009, 06:37 AM
Bump, I know someone out there has an answer

August 21st, 2009, 08:18 AM
Update: I found a guide to modify the boot parameters here:

Unfortunately editing the boot parameters still doesn't fix the problem :(

August 21st, 2009, 10:28 AM
oops,double post..

August 21st, 2009, 10:39 AM
me again;had to spend some time at real life...
Another idea:
Your machine has 4 MB RAM,right?
Is there any BIOS option concerning RAM sharing with the GPU?
"TurboCache" e.g.,try to disable it..
Asking cause you use 32bit...the guy who's machine ran "brilliantly"
in this toshiba thread:


used 8.10 64bit

Your 32 bit should only recognize 3.5 MB of the RAM (Think so,check in systemmonitor)
If it is shared in the BIOS,there could be a problem...
If not,why not testing the 8.10 64 bit....

August 21st, 2009, 05:16 PM
Alright so now downloaded and reinstalled 8.10 as the 64 bit version:

Using this kernal: 2.6.27-9-generic
and using the 177 graphics driver

I'm still getting the same errors:

/var/log/Xorg.0.log:1651:(EE) Failed to initialize GLX extension (Compatible NVIDIA X driver not found)
/var/log/Xorg.failsafe.log:1651:(EE) Failed to initialize GLX extension (Compatible NVIDIA X driver not found)

I've noticed that if I try to use the lastest kernel of 8.10 ( 2.6.27-14-generic ) the sound doesn't work, so yeah I decided to use the one im using now based on the recomendation in the toshiba x300 thread.

August 21st, 2009, 08:31 PM
..kernel option "selinux=0" during nvidia-driver installation helped
someone..lost link...but you know how to edit ;-)


back to the facts:
since backstepping to 8.10
it doesn't complain anymore about:
Failed to initialize the NVIDIA graphics device PCI:1:0:0.

So please post all the log files again,maybe there is a hint ..

lsmod | grep nvidia
modprobe nvidia ??

Is there any BIOS option concerning RAM sharing with the GPU?

August 22nd, 2009, 03:57 AM
Uploaded both nvidia bug report and xorg.0.log in archive

lsmod | grep nvidia
nvidia 7815240 0
i2c_core 36128 1 nvidia

modprobe nvidia
no ouput

I'm not entirely sure what the bios is let alone how to find the option to get it to stop sharing ram with the GPU..........

Trying the kernel command now

and sorry this took so long, I needed some sleep @_@

August 22nd, 2009, 04:08 AM
Kernel parameter didn't work.

August 22nd, 2009, 06:31 AM
here is the output of sudo modprobe -l if it helps anyone.


August 22nd, 2009, 09:06 AM
apt-cache policy xserver-xgl ?

should give no output....


NVRM: loading NVIDIA UNIX x86_64 Kernel Module 177.82 Tue Nov 4 16:50:05 PST 2008
NVRM: failed to register with the ACPI subsystem!

disable acpi in bios...does it boot?If so,try reinstalling driver..

"sharing ram with the GPU" you know if it does?

has your xorg.conf changed somehow?Please post again..

August 22nd, 2009, 09:20 AM
OK a rather odd developement has occured.

I installed the 180 driver, rebooted and got the error (EE) No devices deteced when i started up but when I looked in the xorg conf file it gave the usual error that glx extension hadn't been initialised. So I went back deactivated it and reinstalled the 177 driver. I rebooted the driver and by some freaky miracle its now working.

I'm gonna assume this is a fluke, but what should I do now? :S

August 22nd, 2009, 09:36 AM
glxinfo | grep direct

direct rendering = yes ??????

If so,reboot after disabling boot parameters you edited,especially the

Still working?

install nvidia-settings if have not done yet,open it with root

gksudo nvidia-settings

Change desired resolution,apply,save to X configuration file (important,otherwise settings lost after reboot)
(ignore parser warning)
reboot (just to see....)

Install that fancy stuff...compiz,emerald
Enable medibuntu,get all the codecs,,,gstreamer plugins..

August 22nd, 2009, 09:59 AM
direct rendering = yes

rebooted (also the boot parameters I only did so they were temporary and not permanent)

nvidia-settings already installed, saved configuration and rebooted
still working

But what is compiz, emerald and medibuntu?????????

compiz seems to be installed and emerald says its for compiz-fusion?
edit: medibuntu doesn't show up in synaptic.

edit 2: the kernel im using now isn't the latest one. Should I uninstall the latest one so it doesn't show up in GRUB installer just to make sure i dont screw up?

August 22nd, 2009, 11:57 AM

restricted codecs,not allowed to be delivered with ubuntu......googleearth,libdvdcss,w32 (w64) codecs..



OpenGL-Desktop-manager,fancy....the desktopcube and much more


If you like the cube,wobbly windows and that stuff I can give you few links for more plugins...


If a kernel is running well,and if there is no known security issue,no need to use a newer one.Uninstall the newer on,I am not shure about the nvidia kernel headers installed correctly for this one.If you later update your system,it will appear again,then you can reinstall it to test.(sound?!)..
Should not mess anything up,and if so,you can use your older kernel..

When all this is done,you might want to backup.....remastersys is a great tool,which makes a Live/Installation CD of your system.

August 22nd, 2009, 12:33 PM
Yeah i really should back it up.

Zippy you've been freaking awesome over the past 2-3 days! I'm eternally grateful for the help and patience you've provided me and if there was anyway I could pay you back, I'd gladly do so :)

ok so

August 22nd, 2009, 12:43 PM
"...anyway I could pay you back" :

If you keep using ubuntu for any reason ;-),know how things work,
come back to forum,have a look at new posts, to help anybody who needs it.that's the deal with
free software,ubuntu...

Ask mod to set threads as solved.
...although I do not know why it's working now,or,why it did not before...

August 22nd, 2009, 12:53 PM

August 22nd, 2009, 01:03 PM

August 22nd, 2009, 04:15 PM
Bad news:

Was playing with compiz, it froze the system, nothing responding, did hardreboot and now the driver's not working again. So much for magic :D

August 22nd, 2009, 04:31 PM
... have some USBdevice (TVtuner,e.g.) plugged in?

August 22nd, 2009, 04:34 PM
I have a usb mouse?

August 22nd, 2009, 04:39 PM
....no bios option concerning videoram sharing..???????????
know I asked before,but...

...crash log?

Will be not online next hours.
Try to reinstall!

August 22nd, 2009, 05:27 PM
There's no bios concerning video sharing :/ in fact toshiba gives you very little options concerning the bios.

/var/log/Xorg.0.log:1651:(EE) Failed to initialize GLX extension (Compatible NVIDIA X driver not found)
/var/log/Xorg.failsafe.log:1651:(EE) Failed to initialize GLX extension (Compatible NVIDIA X driver not found)

August 22nd, 2009, 11:44 PM

Ok the graphics driver is now working again......goddamnit this is odd.....although 3 reasons to why it may have worked:

Put the BusID in the xorg.conf file
in the linux restricted module i disabled nv nividia_new
or I just have to keep reinstalling the graphics driver till it works.

edit2: Now the drivers not working again. What happened now:
I reinstalled compiz, compiz hanged, did hard reboot
went to firefox, firefox hanged and did hard reboot
now im back to where I started..........huh..................

August 23rd, 2009, 02:03 AM
Ok i looked into the BIOS and the only things I see which might be off any help are:

Legacy USB support
Pointing devices
Intel Dynamic Acceleration Mode
Internal CIR
Intel Virtualisation Technology
Execute Disable Bit Capability

August 23rd, 2009, 05:37 AM

Ok so apparently the 177 driver doesn't actually support 9800M GTX (supports GT and GTS but not GTX) and and so i tried the 180 driver and it gives me

(EE) No devices detected :/

Apparently this is an issue commonly involved with cards in SLI but problem is I've only got one card.

August 23rd, 2009, 12:16 PM
Launchpad bug report.


August 23rd, 2009, 12:23 PM


or is it your bug-report?


Ok,hi John!
Try to disable:
Intel Dynamic Acceleration Mode
Execute Disable Bit Capability

There is a beta driver out since august 21. :


* Fixed a bug that caused kernel panics when starting X on some mobile GPUs.
* Fixed an interaction problem between VDPAU and PowerMizer when using VDPAU solely as a display mechanism, and not to decode video streams. The GPU performance level should now be raised, if required, in this scenario.
* Fixed VDPAU to avoid "display preemption" in some cases where a VdpOutputSurface is deleted while it is still active (either queued or visible) in a VdpPresentationQueue. In particular, this can occur in MPlayer when using the "-fs" option, and could completely prevent VDPAU from operating successfully, depending on the exact timing conditions.

August 23rd, 2009, 12:46 PM

Intel Dynamic Acceleration Mode
Execute Disable Bit Capability

Didn't do anything. Uninstalled 180 driver

installed the new driver, it comes up with errors

the command:
sudo grep -n "^(EE)" /var/log/Xorg*log
shows this:

/var/log/Xorg.0.log:1652:(EE) Failed to initialize GLX extension (Compatible NVIDIA X driver not found)
/var/log/Xorg.failsafe.log:1652:(EE) Failed to initialize GLX extension (Compatible NVIDIA X driver not found)
Never ending story indeed :P

August 23rd, 2009, 01:03 PM
Please go to folder /etc/init.d :

is there a script "nvidia-glx" or "nvidia-glx-legacy"?

if so,rename it to test install driver again...

August 23rd, 2009, 01:12 PM
There's no script there by either of those names

August 24th, 2009, 12:53 AM
Bumping with xorg.conf and Xorg.0.log files attached

August 24th, 2009, 07:57 PM
Referencing this page, which seems to suggest that this may be a bug with your computer's SBIOS: http://www.nvnews.net/vbulletin/showthread.php?t=104393

Aug 22 02:08:31 john-laptop kernel: [ 146.510871] NVRM: loading NVIDIA UNIX x86_64 Kernel Module 177.82 Tue Nov 4 16:50:05 PST 2008
Aug 22 02:08:31 john-laptop kernel: [ 146.524392] NVRM: request_mem_region failed for 16M @ 0xce000000. This can
Aug 22 02:08:31 john-laptop kernel: [ 146.524394] NVRM: occur when a driver such as rivatv is loaded and claims
Aug 22 02:08:31 john-laptop kernel: [ 146.524395] NVRM: ownership of the device's registers.

01:00.0 VGA compatible controller: nVidia Corporation Device 0617 (rev a2)
Subsystem: Toshiba America Info Systems Device ff01
Flags: bus master, fast devsel, latency 0, IRQ 16
Memory at ce000000 (32-bit, non-prefetchable) [size=16M]
Memory at d0000000 (64-bit, prefetchable) [size=256M]
Memory at cc000000 (64-bit, non-prefetchable) [size=32M]

[ 0.000000] BIOS-provided physical RAM map:
[ 0.000000] BIOS-e820: 0000000000000000 - 000000000009f400 (usable)
[ 0.000000] BIOS-e820: 000000000009f400 - 00000000000a0000 (reserved)
[ 0.000000] BIOS-e820: 00000000000d8000 - 0000000000100000 (reserved)
[ 0.000000] BIOS-e820: 0000000000100000 - 00000000bdaa1000 (usable)
[ 0.000000] BIOS-e820: 00000000bdaa1000 - 00000000bdaa7000 (reserved)
[ 0.000000] BIOS-e820: 00000000bdaa7000 - 00000000bdbbc000 (usable)
[ 0.000000] BIOS-e820: 00000000bdbbc000 - 00000000bdc0f000 (reserved)
[ 0.000000] BIOS-e820: 00000000bdc0f000 - 00000000bdd08000 (usable)
[ 0.000000] BIOS-e820: 00000000bdd08000 - 00000000bdf0f000 (reserved)
[ 0.000000] BIOS-e820: 00000000bdf0f000 - 00000000bdf18000 (usable)
[ 0.000000] BIOS-e820: 00000000bdf18000 - 00000000bdf1f000 (reserved)
[ 0.000000] BIOS-e820: 00000000bdf1f000 - 00000000bdf64000 (usable)
[ 0.000000] BIOS-e820: 00000000bdf64000 - 00000000bdf9f000 (ACPI NVS)
[ 0.000000] BIOS-e820: 00000000bdf9f000 - 00000000bdfe5000 (usable)
[ 0.000000] BIOS-e820: 00000000bdfe5000 - 00000000bdfff000 (ACPI data)
[ 0.000000] BIOS-e820: 00000000bdfff000 - 00000000be000000 (usable)
[ 0.000000] BIOS-e820: 0000000100000000 - 0000000140000000 (usable)

All the above are quotes from the nvidia-bug-report that you gave.

The crucial difference is the last quote, the memory where the nvidia card is allocated is not referenced in the dmesg as being used or reserved.
This seems like a good sign.

In the first instance, I suggest that you try a newer NViDIA driver.
In the second instance, I suggest that you reboot and select the option to run a Memtest.
In the third instace, I suggest editing /boot/grub/menu.lst and in your kernel line, add "pci=nommconf" to the end of it, so it looks like so:

title Ubuntu 9.04, kernel 2.6.28-15-generic
uuid 7590fe0c-3e70-4316-b04e-70ae4e8b3365
kernel /boot/vmlinuz-2.6.28-15-generic root=UUID=7590fe0c-3e70-4316-b04e-70ae4e8b3365 ro quiet splash pci=nommconf
initrd /boot/initrd.img-2.6.28-15-generic

In the fourth instance. I go against recommending it, but you could also check to see if there is an update for your Laptop's BIOS from the manufacturer's website.

Other than that, at this current point in time, there seems to be no workaround. Although some people have reported that lowering your RAM to 2GB or less resolves the issue.

I'll have an eye on any solutions and will update you when I become aware of them.


August 24th, 2009, 10:42 PM
Actually, I wonder if this has anything to do with a (possibly) buggy DSDT.

If you attach your DSDT I may have a look into it.

You can aquire it as instructed here: http://ubuntuforums.org/showthread.php?t=1036051

August 25th, 2009, 06:29 AM
I don't have any special parameters and I can install the Nvidia drivers just fine. This is with the nvidia drivers on nvidia's website, not the restricted drivers available in Ubuntu directly. I'm running Ubuntu 9.04 with whatever the latest kernel in its standard update is.

I bring up a console with crtl-alt-F1, log in as "root", stop gdm (/etc/init.d/gdm stop), install the nvidia drivers, start gdm again, exit the console, and restart the computer. You have to make sure that the restricted drivers available directly in Ubuntu are uninstalled before you do this, however.

September 1st, 2009, 12:17 AM
Hey, I had this same problem, I have a 9800m GS.

Here's exactly what I did, I'm not the best at Ubuntu so if I did unnecessary stuff... meh.

-Go to "nvidia drivers" in the address bar (Firefox).
-I chose Product Series "GeForce 9m Series (NoteBooks)"
-click search, and download.
-then I kinda got lost as to what to do next and went to Synaptic Package Manager
-Search for "nvidia"
-I forget which I chose, but you want to change the nvidia-180 version drivers.
-let it install.
-Not sure if this is related, but then I had to do a bunch of other regular updates.(new install of ubuntu)
-go to System->Appearance->Visual Effects
-click on "extra" (going to install some stuff and then tell you to try again after restarting the computer)
-restart and click "extra" again. Should work.