View Full Version : [ubuntu] 'Printer may not be connected' - but works fine via Virtualbox guests

August 20th, 2009, 07:08 PM
I am running Jaunty (Ubuntu 9.04 Kernel version 2.6.28-15)

I have a Canon Pixma ip4500 printer that appears to accept print jobs but then stops before any mechanical response from the printer. A status message 'Printer may not be connected' appears in the print manager, and Printer state is shown as 'Processing - unable to open device xxx : Permission denied'.

I attach a png showing the messages and can send a (long) output from the Printing Troubleshooter if this would help.

A few observations:
- It used to work fine under Hardy.
- I recently tried Turboprint but had difficulties with it too and uninstalled it. Installing Turboprint may have been the part of the problem and upgrading to Jaunty may have been a factor too.
- I have tried re-installing the Canon drivers downloaded from the manufacturer's website
- I am running Windows XP and Linux Mint guests under Virtualbox, and the printer works fine in both cases (i.e. via the Jaunty host that's got the problem).

Anyone got any ideas?

August 20th, 2009, 07:12 PM
Sorry - I put this on the wrong forum - will switch it to Hardware and Laptops