View Full Version : [kubuntu] Anomalous behaviour of USB sticks

August 20th, 2009, 05:17 PM
Hi everyone,

I am puzzled, I experienced the same problems with more than 1 USB stick (a sony and a kingston)...is that a bug?
The pattern is the following:

The USB became read-only in Ubuntu (9.04) after I used them on a windows computer (XP and Vista). After I used them I could open the files in Ubuntu but neither copy them nor transfer any more files into them.

In windows they worked normally

I tried to format them with Gparted but it was not possible, it gives a generic error

I formatted them in a windows computer and restored the original parameters (FAT32) and it worked fine, I could even transfer some files from windows into Linux

Today I tried to transfer them again, after copying the file in windows I insert the stick into my laptop and it said that the files I copied were corrupted and impossible to copy. Then the stick became read-only again and to make it work in Ubuntu I will need to format them again...

Anyone who solved a similar problem or can help?
Thank you in advance