View Full Version : [ubuntu] can't boot after update-samba?

August 20th, 2009, 07:00 AM
installed update yesterday, remember samba was part of list. Today when I try to boot up, no go, in any kernel version, recovery mode basically gets past choice window (resume normal boot to open root terminal) and starts down list at resume then stalls at "installing samba daemons" (no [0] or [failed] at the end, tho alt-ctl-del shutdown first thing to go is gnome display manager (tho isn't showing after samba) then "stopping samba daemons" then on down to reboot. Am running off live CD right now. Don;t know much about working under the hood with linux, though had to study samba and write a conf file to make my LAN work. and did ask to retain my old conf when new samba installed. have worked a little in terminal, but only very basics.tho been using linux a couple years but have relatively new install of ibex (tried upgrade and network/nautilus/LAN didn't work couldn't get it to work(despite great forum posts by someone) so after a few days in the forums and trying did a clean reinstall of ibex, tho nautilus still won't work right.. have to use typed location to get through samba to LAN now,but at least it will under ibex, wouldn't even do that in jaunty). can reinstall again but have to reinstall all the software and firefox plugs etc again if there is some simple thing I can do.. maybe reinstall the older version of samba somehow? (have a copy of my smb.conf file saved outside linux as backup) if that is the problem, there were other things in the update (don't recall what they were), but it does seem to stall at the samba point. just guessing, this stuff is not my specialty.

any instructions would help, otherwise I'll go ahead an reinstall tomorrow, need to get through my LAN, that always works, do it a lot it seems.. never keep data in linux anymore, it all on the non os hardrive, so reistall only effects installed softwares and firefox/plugins, etc, can'tt remember if I install samba afterwards, and if so, where do I go to get the old version that worked. must have last time or have a copy here somewhere, was all working yesterday and got it reset up after failed jaunty upgrade couple months back

sorry, babbling, been working on this too long, too late, must sleep!


am giving up and reinstalling but in case it helps
the dpkg option in that recovery mode menu box wanted to install
ash blt python2.4 python2.4-minimal tc18.4 tc18.5 tk8.4 tk8.5
but just sat on 0% (working...) and couldn't get it
tried to use the terminal line and apt-get install for the same stuff, but it again couldn't access the internet, tho I can access through the live cd, guess the terminal can't at that point
funny, a lot of dos commands from when I worked on computers before hard drives and guis, lod dos first and go, and some still work at terminal line.. will search for terminal commands as was able to navigate to find the foxfire files I'd want to save.. bookmarks.. using cd and dir, but copy command doesn't must be different.. never learned unix, maybe I'll have time someday. so, solution, reinstall, don't update. good enough, got to get it to work. so I can access the studio... which still runs win98 (with the guts ripped out, much more stable that way), and yes, both my cars are over 20 years old, cpus are hmm p3(linux) and a athlon k7(win98) gets it done
thanks, had plenty of helpful stuff here in the forums other times