PDA

View Full Version : [ubuntu] Why won't some flash movies play back in Firefox?



stefcep
August 19th, 2009, 01:59 AM
I tried to play video from newspaper site eg http://media.theage.com.au/flintoff-faces-his-final-test-686402.html?from=videobox

Any idea why they won't play back at all? Ubuntu 9.04, Firefox 3.13 and Shiretoko.

wojox
August 19th, 2009, 02:03 AM
Well it was about Michael Jacksons mom...wait I don't want to ruin it.
Take a look at lovinglinux Firefox Optimization thread.
http://ubuntuforums.org/showthread.php?t=1193567
It helped me out.

HappyFeet
August 19th, 2009, 03:19 AM
Works for me. What flash are you using? I use the adobe flash and have the mozilla-mplayer plugin.

anechoic
August 19th, 2009, 04:15 AM
if you are using Gnash they report a change in Flash content as breaking the latest version...
for example YouTube works but Vimeo doesn't
file a bug at Launchpad

oboedad55
August 19th, 2009, 04:53 AM
if you are using Gnash they report a change in Flash content as breaking the latest version...
for example YouTube works but Vimeo doesn't
file a bug at Launchpad

It says Flintoff faces his final Test.

stefcep
August 19th, 2009, 06:04 AM
thank you.

I ended up doing this :

sudo apt-get remove swfdec-mozilla
sudo apt-get remove mozilla-plugin-gnash
sudo apt-get remove adobe-flashplugin
sudo apt-get remove flashplugin-nonfree
sudo apt-get install flashplugin-nonfree

I also installed mozilla-mplayer plug-in from synaptic, mplayer itself and the w32codecs (not sure if needed, but I put it in anyway)

gnash was never installed in my system.

Previously when playing flash video eg from youtube i could right click and see the video downloading, select it and save it. I've lost this now. oh well can't have everything, i suppose.

bzhao
August 19th, 2009, 07:06 AM
thank you.

I ended up doing this :

sudo apt-get remove swfdec-mozilla
sudo apt-get remove mozilla-plugin-gnash
sudo apt-get remove adobe-flashplugin
sudo apt-get remove flashplugin-nonfree
sudo apt-get install flashplugin-nonfree

I also installed mozilla-mplayer plug-in from synaptic, mplayer itself and the w32codecs (not sure if needed, but I put it in anyway)

gnash was never installed in my system.

Previously when playing flash video eg from youtube i could right click and see the video downloading, select it and save it. I've lost this now. oh well can't have everything, i suppose.


The above post has fix the same problem I have been having.
Thanks indeed!

anechoic
August 21st, 2009, 06:29 PM
//sudo apt-get remove mozilla-plugin-gnash

it seems gnash was installed on your system

also, I tried your fix and wasn't able to play Vimeo content or anything from Comedy Central

:(

stefcep
August 27th, 2009, 12:09 AM
//sudo apt-get remove mozilla-plugin-gnash

it seems gnash was installed on your system

No it wasn't, I issued that command in case it was, and the package installer said gnash wasn't installed.


also, I tried your fix and wasn't able to play Vimeo content or anything from Comedy Central

:(
vimeo works for me.

comedy central works, but I had to access the clips from the drop down menus and with South PArk clips, the advertisements would play but not the actual South PArk clip unless I clicked o replay the clip, but all other clips including futurama played OK.

can also stream live tv from p2p4ue.

Works for me but your mileage may vary.

stefcep
August 27th, 2009, 12:10 AM
The above post has fix the same problem I have been having.
Thanks indeed!

CAn you check that vimeo and comedy central work for you?