PDA

View Full Version : [ubuntu] Ati driver help?



shiggydiggy
August 18th, 2009, 06:31 PM
Hi,
I've got two systems:
Desktop: Opteron 144; 1.8@2.34GHz, 2GB ram, Radeon HD4350
Laptop: Sempron 2GHz, 512MB ram, some slow ATI built-in GFX card

When i put I put "normal" or "extra" visual effects on, my desktop system lags! For example if i minimise firefox and the go to restore it, it will pause for a second or two before it restores it. on the slower laptop everything is super fast.... what gives?

Thanks guys :)

utnubuuser
August 18th, 2009, 06:39 PM
Hello -- Probably just a driver configuration issue. I've an ATi card in my laptop, and when installing the card is recognized and the driver installed, but I still have to change the settings in xorg.conf. What I've done in the past is to google the name/model of the card together with the words ubuntu and xorg.conf, then copied the settings from someone elses configuration file. (This is dependent on which version of Ubuntu you're using too).
Here's the ATi Wiki:http://wiki.cchtml.com/index.php/Main_Page(This is only for newer cards, you'll have to check if your card is supported through the fglrx site)

Post the exact make and model of your laptop, and ask for someone's xorg.conf file.

You can check if rendering is on with the command:
glxinfo | grep directanswer should be YES.

To get the model of your ATi card,
lspciin a terminal, ( maybe sudo lspci).

My laptop is a Thinkpad with an ATi M6 Ysomething or other card. This uses the older "xserver-xorg-video-ati" driver.

Here's a copy of the /etc/X11/xorg.conf file:
##########################################
## xorg.conf (xorg X Window System server configuration file)
#
# This file was generated by failsafeDexconf, using
# values from the debconf database and some overrides to use vesa mode.
#
# You should use dexconf or another such tool for creating a "real" xorg.conf
# For example:
# sudo dpkg-reconfigure -phigh xserver-xorg

Section "Module"
Load "i2c"
Load "bitmap"
Load "ddc"
Load "dri"
Load "extmod"
Load "freetype"
Load "glx"
Load "int10"
Load "vbe"
EndSection

Section "InputDevice"
Identifier "Generic Keyboard"
Driver "kbd"
Option "CoreKeyboard"
Option "XkbRules" "xorg"
Option "XkbModel" "pc105"
Option "XkbLayout" "us"
EndSection

Section "InputDevice"
Identifier "Configured Mouse"
Driver "mouse"
Option "CorePointer"
Option "Device" "/dev/input/mice"
Option "Protocol" "ImPS/2"
Option "ZAxisMapping" "4 5"
Option "Emulate3Buttons" "true"
EndSection


Section "InputDevice"
Identifier "Synaptics Touchpad"
Driver "synaptics"
Option "SendCoreEvents" "true"
Option "Device" "/dev/psaux"
Option "Protocol" "auto-dev"
Option "HorizScrollDelta" "0"
EndSection

Section "Device"
Identifier "ATI"
Driver "radeon"
Option "AccelMethod" "XAA"
Option "AGPMode" "4"
Option "AGPFastWrite" "yes"
Option "EnablePageFlip" "on"
Option "RenderAccel" "on"
Option "DynamicClocks" "on"
Option "BIOSHotkeys" "on"
EndSection


Section "Monitor"
Identifier "Generic Monitor"
Option "DPMS"
EndSection

Section "Screen"
Identifier "Default Screen"
Device "ATI Technologies Inc Radeon Mobility M6 LY"
Monitor "Generic Monitor"
DefaultDepth 16
SubSection "Display"
Depth 8
Modes "1024x768"
EndSubSection
SubSection "Display"
Depth 16
Modes "1024x768"
EndSubSection
SubSection "Display"
Depth 24
Modes "1024x768"
EndSubSection
EndSection

Section "ServerLayout"
Identifier "Default Layout"
screen 0 "Default Screen" 0 0
Inputdevice "Generic Keyboard"
Inputdevice "Configured Mouse"
Inputdevice "Synaptics Touchpad"
option "AIGLX" "true"
EndSection

Section "DRI"
Mode 0666
EndSection

Section "Extensions"
Option "Composite" "Enable"
EndSection
#######################################


PS. be sure to make a backup copy of your original xorg.conf file before making any changes.
In terminal: sudo cp /etc/X11/xorg.conf xorg.conf.bk
that way, if anything goes wrong you can restore it with sudo cp /et/X11/xorg.conf.bk xorg.conf

markbuntu
August 18th, 2009, 08:41 PM
The most likely cause of slow graphics is a misinstalled or wrong driver in use. What driver are you using for that card. Is it a HD3450?

I would suggest removing whatever driver you are using and getting the latest driver from ati and installing it.

I have a HD3450 and have not had any problems with it. If it is a newer agp card you will need the latest driver.

RedSingularity
August 19th, 2009, 03:05 AM
You can find drivers in System>Admin>Hardware Drivers.

shiggydiggy
August 20th, 2009, 02:54 AM
well, that's what i did, i went System>Admin>Hardware Drivers and i installed the driver that ubuntu got for me. I tried a clean install, but that didn't help either...

Temüjin
August 20th, 2009, 02:59 AM
fglrx is relatively slow 2d-wise. It uses old XAA, while the open-source drivers use EXA.

shiggydiggy
August 20th, 2009, 03:12 AM
fglrx is relatively slow 2d-wise. It uses old XAA, while the open-source drivers use EXA.
how do i fix that?

markbuntu
August 20th, 2009, 09:24 PM
I am pretty sure you need a newer driver for the x3450 which is not the same as the hd3450.