PDA

View Full Version : [ubuntu] Desktop filed need to be marked as "trusted" in 9.04



LunaLuan
August 18th, 2009, 07:23 AM
Hello!

I installed a java application in Ubuntu9.04, and it created a desktop file in the desktop

but the desktop file seems so strange that the icon and the name are both not corret

when i click it and thy to open it, i got the prompt:

"Untrusted application launcher...."

and i hava to click button to mark it as "trusted", and then the desktop file will become normal with correct icon and name

who can tell me why, is this a new feature for 9.04, cause it doesn't perform like this in other ubuntu os like 8.10,8.04......

and is there any way to avoid it?

Thanks!!!

Nightcrawler23
May 8th, 2010, 10:30 AM
I've got the same problem... after installing a win32 application under wine, the .desktop autogenerated file in my desktop is not marked as trusted by default, and when I try to open it I'm not prompted to mark it as trusted (as I used to be).

Isn't there any way to mark it manually? I've not seen the option in the properties window.

3rdalbum
May 8th, 2010, 11:18 AM
The "you have to mark it as trusted" is a response to a post written last year about how a .desktop file can be downloaded from online to the desktop and double-clicked without needing execute permission:

http://www.geekzone.co.nz/foobar/6229

So you'll need to get used to this behaviour. If Gnome doesn't create the launcher, you'll need to tell Gnome to mark it as trusted when you double-click on it for the first time.

kerry_s
May 8th, 2010, 12:07 PM
right click-> properties-> permissions, check "allow executing..."

naaman
May 17th, 2010, 04:35 AM
Cheers kerry_s, this worked for me..