PDA

View Full Version : [ubuntu] 9.04 nvidia drivers 180.44



daes_coconut
August 17th, 2009, 09:44 PM
Hi there

I installed ubuntu 9.04 a few days ago as I thought it'd be a more efficient method of completing my comp sci homework rather than basically logging into my university's servers through putty and working there.

Anyway I've installed 9.04 on the second hard drive of my Toshiba Qosmio X300 laptop, with a NVIDIA 9800M GTX graphics card. It was running fine at first but then when I restarted it went into low graphics mode and I've been fighting with Ubuntu ever since.

The driver that ubuntu suggests from system->administrator->hardware devices is the 180.44 driver and it doesn't seem to like anything else I tell it to install. Anyway here's the log from my xconfig.


/var/log/Xorg.2.log:143:(EE) NVIDIA(0): Failed to initialize the NVIDIA graphics device PCI:1:0:0.
/var/log/Xorg.2.log:144:(EE) NVIDIA(0): Please see the COMMON PROBLEMS section in the README for
/var/log/Xorg.2.log:145:(EE) NVIDIA(0): additional information.
/var/log/Xorg.2.log:146:(EE) NVIDIA(0): Failed to initialize the NVIDIA graphics device!
/var/log/Xorg.2.log:150:(EE) Screen(s) found, but none have a usable configuration.
/var/log/Xorg.3.log:143:(EE) NVIDIA(0): Failed to initialize the NVIDIA graphics device PCI:1:0:0.
/var/log/Xorg.3.log:144:(EE) NVIDIA(0): Please see the COMMON PROBLEMS section in the README for
/var/log/Xorg.3.log:145:(EE) NVIDIA(0): additional information.
/var/log/Xorg.3.log:146:(EE) NVIDIA(0): Failed to initialize the NVIDIA graphics device!
/var/log/Xorg.3.log:150:(EE) Screen(s) found, but none have a usable configuration.
/var/log/Xorg.4.log:1631:(EE) Failed to initialize GLX extension (Compatible NVIDIA X driver not found)
/var/log/Xorg.failsafe.log:1631:(EE) Failed to initialize GLX extension (Compatible NVIDIA X driver not found)
Anybody able to help this tired befuddle ubuntu newb? I would be eternally grateful as I've been searching for answer all night/early morning.

Technoviking
August 17th, 2009, 10:07 PM
You may need new drivers for a NVidia 9800 card.

You may want to add this ppa, which has 185.18 drivers:
https://edge.launchpad.net/~ubuntu-x-swat/+archive/x-updates

Please note, the drivers in this ppa are not officially supported.


Also, read https://help.ubuntu.com/community/BinaryDriverHowto/Nvidia

T-V

daes_coconut
August 18th, 2009, 12:51 AM
Wow quick reply! Thankyou!

I went and added the ppa but unfortunately it still doesn't fix things and results in what seems a longer error file in xconfig :/


/var/log/Xorg.0.log:140:(EE) NVIDIA(0): Failed to initialize the NVIDIA graphics device PCI:1:0:0.
/var/log/Xorg.0.log:141:(EE) NVIDIA(0): Please check your system's kernel log for additional error
/var/log/Xorg.0.log:142:(EE) NVIDIA(0): messages and refer to Chapter 8: Common Problems in the
/var/log/Xorg.0.log:143:(EE) NVIDIA(0): README for additional information.
/var/log/Xorg.0.log:144:(EE) NVIDIA(0): Failed to initialize the NVIDIA graphics device!
/var/log/Xorg.0.log:148:(EE) Screen(s) found, but none have a usable configuration.
/var/log/Xorg.1.log:1631:(EE) Failed to initialize GLX extension (Compatible NVIDIA X driver not found)
/var/log/Xorg.2.log:1631:(EE) Failed to initialize GLX extension (Compatible NVIDIA X driver not found)
/var/log/Xorg.3.log:143:(EE) NVIDIA(0): Failed to initialize the NVIDIA graphics device PCI:1:0:0.
/var/log/Xorg.3.log:144:(EE) NVIDIA(0): Please see the COMMON PROBLEMS section in the README for
/var/log/Xorg.3.log:145:(EE) NVIDIA(0): additional information.
/var/log/Xorg.3.log:146:(EE) NVIDIA(0): Failed to initialize the NVIDIA graphics device!
/var/log/Xorg.3.log:150:(EE) Screen(s) found, but none have a usable configuration.
/var/log/Xorg.4.log:1631:(EE) Failed to initialize GLX extension (Compatible NVIDIA X driver not found)
/var/log/Xorg.failsafe.log:1631:(EE) Failed to initialize GLX extension (Compatible NVIDIA X driver not found)


I also read the how to guide and basically tried everything I could. I also tried adding the PCI Address to the xorg.conf file but that only produced:

(EE) No devices detected

Which is the very thing it's supposed to resolve.


Erm any idea on where I should go from here? and thanks for your reply :)

wojox
August 18th, 2009, 12:59 AM
Have a look at this thread it's what I used to upgrade. Worked like a charm.
http://ubuntuforums.org/showthread.php?t=1125400

daes_coconut
August 18th, 2009, 02:16 AM
hey wojox I actually went through that thread last night and tried it but to no avail(this was before I installed the PPA's that techno suggested I install)

I went through that thread again and did eveything it suggested and when i rebooted I didn't get any funny error messages, Hurrah! Although I think I then ****** it up when i went to system->administration->hardware drivers and saw that there wasn't anything to active. So I went to synaptic and downloaded the 180(to 185) driver. I then rebooted and came up with error messages, which I unfortunately didn't save. so I went to the troubleshooting section of wojox's suggested thread and did these commands

sudo aptitude purge $(dpkg -l | grep nvidia | awk '{print $2}')
and then went about reinstalling the driver again. Now I'm back with the same error messages as before.

daes_coconut
August 19th, 2009, 11:42 AM
"9.04" Ok so I completely reinstalled Ubuntu 9.04.

installed the ppa's that techno suggested. rebooted. Everything was groovy and fine. I tried installing the program Second Life but the moment my character logged in, it froze the screen and locked up my mouse and keyboard and I wasn't able to do anything but do a hard reboot. And now I get errors again and made to go into low graphics mode again. Bloody oath :/

Edit: sorry forgot errors.


(EE) NVIDIA(0): Failed to initialize the NVIDIA graphics device PCI:1:0:0.
(EE) NVIDIA(0): Please check your system's kernel log for additional error
(EE) NVIDIA(0): messages and refer to Chapter 8: Common Problems in the
(EE) NVIDIA(0): README for additional information.
(EE) NVIDIA(0): Failed to initialize the NVIDIA graphics device!
(EE) Screen(s) found, but none have a usable configuration.

daes_coconut
August 19th, 2009, 01:17 PM
bumping

junglefun
September 2nd, 2009, 05:48 PM
"9.04" Ok so I completely reinstalled Ubuntu 9.04.

installed the ppa's that techno suggested. rebooted. Everything was groovy and fine. I tried installing the program Second Life but the moment my character logged in, it froze the screen and locked up my mouse and keyboard and I wasn't able to do anything but do a hard reboot. And now I get errors again and made to go into low graphics mode again. Bloody oath :/

Edit: sorry forgot errors.


(EE) NVIDIA(0): Failed to initialize the NVIDIA graphics device PCI:1:0:0.
(EE) NVIDIA(0): Please check your system's kernel log for additional error
(EE) NVIDIA(0): messages and refer to Chapter 8: Common Problems in the
(EE) NVIDIA(0): README for additional information.
(EE) NVIDIA(0): Failed to initialize the NVIDIA graphics device!
(EE) Screen(s) found, but none have a usable configuration.




I have exactly the same error with Jaunty. I'm using Geforce 7350 LE