PDA

View Full Version : [xubuntu] Resolution resets to 1024x768 after restart/re-login



derekboy
August 17th, 2009, 05:21 PM
Everytime I restart my computer or re-login, my resolution changes from 1280x1024 to 1024x768. It's not a huge problem, but it's more of an annoyance of hanging to change it back every time I login. Does anyone know how to fix this?

realzippy
August 17th, 2009, 05:23 PM
Use nvidia?

tomasrey88
August 17th, 2009, 06:19 PM
If you did not install the monitor with your OS, you might have to reinstall your OS. There's a better way, but I don't know it. There should be a way to save your monitor settings... but I don't know it. Installing your monitor with the OS initially should make it the permanent default monitor. You might also want to check your bios settings, too. Go over them with a fine-tooth comb. This is especially true if you have a frankenstein computer as the bios may be set-up for default operation with multiple monitors, or if it is a laptop CPU/board, a certain size lcd may be default, etc. I've found that lots of ubuntu owners have frankenstein computers.

BTW, I invite you to take a look at my question:
http://ubuntuforums.org/showthread.php?t=1242310

Enjoy,
:guitar:

derekboy
August 17th, 2009, 11:56 PM
My graphics card is an Intel 82845G according to Windows XP's Device Manager. I read somewhere that Intel drivers are pre-installed to *ubuntu, so I didn't look around for drivers.

I installed the OS through Wubi, and today I'm going to move the Image to a separate partition following the Wubi instructions. I did this because I didn't have a CD to burn the ISO to.

When I installed the OS, I was using the monitor I am right now (in fact, I installed it not even 3 days ago). But when I go to Settings -> Display, it says my monitor is "monitor 1" or something similar (I'm on Windows right now).

realzippy
August 18th, 2009, 08:58 AM
Have a look at this thread:

http://ubuntuforums.org/showthread.php?t=97570

if the setting of shared video memory in the BIOS does not help:

http://ubuntuforums.org/showthread.php?t=83973

Please test the "BIOS" setting first.
If the second link is too much for you,post your xorg.conf.

derekboy
August 18th, 2009, 06:04 PM
I changed my "Video Buffer Size" from 1MB to 8MB, and after restart I noticed "Theres a Xubuntu loading screen? o.O".

But unfortunatly, it didn't fix my original problem. But I noticed that before I changed my settings, 1024x768 lets me change the refresh rate to 60, 65, and 80, while 1280x1024 only let me select 80. After changing settings, 1280x1024 will only let me select 60 for the refresh rate.

I'm going to try the second link now.

EDIT: After clicking the second link, I realized that I already tried to follow that guide, but after closing the GUI I can't see what I'm typing as the resolution is all wrong. If I press ENTER a bunch of times I can see what I previously entered, but I still can't see what I'm typing.

/etc/X11/xorg.conf:

<I won't post the comments>
Section "Device"
Identifier "Configured Video Device"
Option "UseFBDev" "true"
EndSection

Section "Monitor"
Identifier "Configured Monitor"
EndSection

Section "Screen"
Identifier "Default Screen"
Monitor "Configured Monitor"
Device "Configured Video Device"
EndSection

realzippy
August 18th, 2009, 08:28 PM
Please post your whole xorg.conf..

derekboy
August 20th, 2009, 04:17 PM
That was the whole xorg.conf except for the comments at the top, but here you go:


# xorg.conf (X.Org X Window System server configuration file)
#
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
#
# Edit this file with caution, and see the xorg.conf manual page.
# (Type "man xorg.conf" at the shell prompt.)
#
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
#
# Note that some configuration settings that could be done previously
# in this file, now are automatically configured by the server and settings
# here are ignored.
#
# If you have edited this file but would like it to be automatically updated
# again, run the following command:
# sudo dpkg-reconfigure -phigh xserver-xorg

Section "Device"
Identifier "Configured Video Device"
EndSection

Section "Monitor"
Identifier "Configured Monitor"
EndSection

Section "Screen"
Identifier "Default Screen"
Monitor "Configured Monitor"
Device "Configured Video Device"
EndSection

I don't see why the comments make a difference, especially if they're mutual on all installations....

Aguamiga
August 26th, 2009, 08:45 PM
Try adding this to your section Screen, just above EndSection:

SubSection "Display"
Modes "1280x1024"
EndSubSection

bagy
October 4th, 2009, 02:48 PM
See http://ubuntuforums.org/showthread.php?t=1274023