View Full Version : [ubuntu] NVidea/X loses configuration after reboot.

August 16th, 2009, 11:44 PM
This has been bugging me for a while, so I decided to make a post about it.

I am currently happily running Ubuntu Hardy 8.04 on my computer (sadly, anything newer seems to fail). Every time I turn off the computer for whatever reason (update, normal shutdown/reboot, hard shutdown), I get the error message about low graphics mode. I've tried going into recovery mode and reconfiguring X, but that doesn't seem to work. Neither does dpkg.

The only thing that fixes the error is if I drop into tty1, kill the gdm and reinstall the NVidea Driver. I have no idea what is causing this, but it seems to have been occurring ever since I installed the NVidea driver the first time.

Is there a line of code in the sh script that NVidea has made that can be run at startup? Or maybe some kind of script? I really have no idea what to do.

Thank you!

August 17th, 2009, 02:53 AM
can u post ur xorg.conf file (/etc/X11/xorg.conf)

have u always had this problem with 8.04 or has it just started recently (after an update or a change of graphics driver)?

can u post which nvidia driver you are using (go to system>admin>hardware drivers)

Can u get to ur desktop whilst running in safe graphics mode?

August 17th, 2009, 03:13 PM
# nvidia-xconfig: X configuration file generated by nvidia-xconfig
# nvidia-xconfig: version 1.0 (buildmeister@builder63) Tue Jul 28 16:20:20 PDT 2009

Section "ServerLayout"
Identifier "Layout0"
Screen 0 "Screen0"
InputDevice "Keyboard0" "CoreKeyboard"
InputDevice "Mouse0" "CorePointer"

Section "Files"

Section "Module"
Load "dbe"
Load "extmod"
Load "type1"
Load "freetype"
Load "glx"

Section "InputDevice"
# generated from default
Identifier "Mouse0"
Driver "mouse"
Option "Protocol" "auto"
Option "Device" "/dev/psaux"
Option "Emulate3Buttons" "no"
Option "ZAxisMapping" "4 5"

Section "InputDevice"
# generated from default
Identifier "Keyboard0"
Driver "kbd"

Section "Monitor"
Identifier "Monitor0"
VendorName "Unknown"
ModelName "Unknown"
HorizSync 28.0 - 33.0
VertRefresh 43.0 - 72.0
Option "DPMS"

Section "Device"
Identifier "Device0"
Driver "nvidia"
VendorName "NVIDIA Corporation"

Section "Screen"
Identifier "Screen0"
Device "Device0"
Monitor "Monitor0"
DefaultDepth 24
SubSection "Display"
Depth 24

2. To be honest... I don't remember. It definitely didn't happen before the NVidea driver though.

3. 185.18.31

4. Yes I can, but it is 800x600 with none of my settings.

August 20th, 2009, 03:26 PM
3 Day bump.

I'm really sorry, but this is annoying me to no end.

August 20th, 2009, 03:57 PM
are you saying that the driver is installed and you can configure to your likings....then when you reboot, all settings are lost?

if so, then what you need to do is configure the nvidia-settings as root to make them "stick".

open a terminal (applications > accessories > terminal) and type or copy/paste the following:

gksudo nvidia-settings

type your password when prompted, make all your settings, press "apply", then "save to x configuration file".

that should do it.

August 22nd, 2009, 04:38 AM
That isn't the issue.

The issue is that the driver appears to be completely uninstall when I reboot. :/ Not sure how that happens, but I keep seeing the dreaded low-res mode. I have a large monitor. I want to be able to use it.

August 22nd, 2009, 04:53 AM
Have you tried what fooman said?

August 24th, 2009, 01:21 AM
I did what he said, but no dice.

I did however, solve the problem. It appears that I'm missing a Driver section in my xorg.conf. If anyone knows what to add to xorg.conf, I should be good to go.