View Full Version : [xubuntu] Installing Xubuntu in a HP pavilion dv2 laptop

August 15th, 2009, 08:40 AM
Ok so here's the thing. I got myself a pavilion dv2 laptop, but I disliked Vista's performance (resource hog). So, I decided to go for something as efficient as possible, to boot in the least amount of time and be blazing fast. I first tried Puppy linux... but our relationship didn't work. First, installation is stupidly complicated in terms of making it official, since I wanted to save it to my HDD but I couldn't manage to get it to load grub, nor I found the saved session or whatever bla bla. Anyway, I also discovered Puppy is x86_64 (if I'm not mistaken,) since it only identified 3 of my 4 gigs of ram. Then I decided to go for Xubuntu, since I've tried Ubuntu and I know Ubuntu has many pluses like more support, repositories to dl many programs, and more than anything, it has AMD64 support and it has a pretty straightforward installation. The only damned problem is... the installation does not launch in the first place! I dloaded the AMD64 version of 9.04 of xubuntu, burned it and installed it in my main box (monster quad core desktop, which I am using to type this). I burned the disk at 16X btw. SO, I get the very same CD and plugged it in the external disk reader. I load using the disk reader, and see some blabber, then the Xubuntu logo and the little moving/loading bar appear. Finally, I select "install xubuntu". I see the logo and bar again, then some blabber again and the thing finally ends up getting stuck at a bunch of errors. I have no remedy but to hard shut down the machine. I did check the disk for errors previously, no errors found - disk integrity fine. Oh well sorry for long story, but I've tried everything. Dloading the alternate disk doesn't sound so good either... took quite a decent time to download the live cd. As I said, it worked flawlessly in my desktop box.

Extra info, I saw some BIOS stuff with error somewhere in that blabber I told ya IIRC...


# 1.6GHz AMD Athlon Neo Processor MV-40
# 4GB PC2-6400 DDR2 SDRAM 666MHz (1 Dimm)
# Windows Vista Home Premium 64-bit with Service Pack 1 (stock)
# 12.1" WXGA High-Definition HP LED BrightView Widescreen Display (1280x800)
# 320GB 5400RPM SATA Hard Drive
# ATI Mobility Radeon HD 3410 Graphics (512MB)
# 802.11a/b/g/n wireless and Bluetooth
# 5-in-1 card reader
# External Lightscribe SuperMulti 8x DVD+/-R/RW with Double Layer Support
# 6-Cell Li-ion battery
# Dimensions: 11.50 in (L) x 9.45 in (D) x 0.93 in (min H) / 1.29 in (max. H)
# Weight: 3.95 lbs (with 6-cell battery)

Thanks in advance ppl

August 27th, 2009, 02:35 PM
Check out my proposed solution here:


September 22nd, 2009, 08:51 PM
I see, thanks for the reply and sorry for slow answer. I tried making a 9.04 live cd and installing, but that returned the same damn error. I thought it was xubuntu, now I see it is the 'live' characterisic, so I yet again made a ubuntu CD, though this time an alternate CD. Worked like a charm. I've had TONS of other problems with live CD's, so I won't be getting the live versions... ever again. Nor I will get HP laptops/netbooks ever again. :mad:

I find doing the bootable USB a little difficult, so I didn't use the solution in your link.

Oh and don't worry, I didn't strain the Ubuntu servers. I always use bittorrent whenever possible, this case not being the exception.