PDA

View Full Version : [ubuntu] window color automatically changed



kickwin
August 12th, 2009, 09:51 PM
I do know what happened but when I started my computer today, I was surprised to find that the window top bar (which has close, minimize etc.) changed colour.

http://ubuntuforums.org/attachment.php?attachmentid=124632&stc=1&d=1250110202

I do not know how I can change it back to the original default colour (brown). I changed the theme but it did nothing to change this. I am totally surprised and I would appreciate any help.

TheNosh
August 12th, 2009, 10:32 PM
in the top menu: system--> preferences--> appearance

then you can select one of the default theme options, or to simply change the colours you can click the "customize" button and then go to the "colors" tab

kickwin
August 12th, 2009, 10:38 PM
I tried that but there is no option to change the color of the active window title bar. I could change the color of other things such as window area, text box etc.

theozzlives
August 12th, 2009, 10:41 PM
I tried that but there is no option to change the color of the active window title bar. I could change the color of other things such as window area, text box etc.

I believe it's called hilighted item or object or something to that effect.

TheNosh
August 12th, 2009, 11:10 PM
it's "selected items". i just checked.

kickwin
August 12th, 2009, 11:31 PM
It still doesn't change it.

TheNosh
August 13th, 2009, 12:49 AM
It still doesn't change it.

i can't really tell by the picture you gave, but are you using emerald theme manager?

CatKiller
August 13th, 2009, 01:02 AM
That looks like the default Emerald theme to me.

kickwin
August 13th, 2009, 02:51 AM
Oh..yes...I have emerald installed. I thought it was needed for having Compiz work properly. Is this correct?

Emerald has been on my system for a while but this change of color happened only today.

So I reckon I have to change this option within emerald.

TheNosh
August 13th, 2009, 03:02 AM
you actually don't need emerald for compiz to function properly, many of us just prefer it. i'm not sure how to make it not run with compiz though if you'd like that i'm sure someone here can help you. if you would just like to change the colour of your emeral theme you can do so by going to

system --> prefferences --> emerald theme manager

and then just click edit themes to be given options for colors and such

CatKiller
August 13th, 2009, 11:59 AM
So I reckon I have to change this option within emerald.

You don't have to, although you can. There are some themes that are just like the default Metacity theme, but with Emerald flourishes. As well as some other nice ones, too, of course.

You could configure Compiz to use Metacity to decorate the windows with Metacity rather than Emerald instead, although I can't remember exactly how at the moment. I know you can do it through CompizConfig Settings Manager, but there may well be a more general way.

wizard10000
August 13th, 2009, 12:30 PM
I do know what happened but when I started my computer today, I was surprised to find that the window top bar (which has close, minimize etc.) changed colour.

http://ubuntuforums.org/attachment.php?attachmentid=124632&stc=1&d=1250110202

I do not know how I can change it back to the original default colour (brown). I changed the theme but it did nothing to change this. I am totally surprised and I would appreciate any help.

Your screenshot is of the default emerald theme. If you want metacity back all you have to do is either uninstall emerald or open a terminal window and type


metacity --replace &

Hope this helps -

TheNosh
August 13th, 2009, 01:18 PM
Your screenshot is of the default emerald theme. If you want metacity back all you have to do is either uninstall emerald or open a terminal window and type


metacity --replace &

Hope this helps -

that stops compiz though

wizard10000
August 13th, 2009, 01:50 PM
that stops compiz though

It does? Sorry, I'm at work on a Windows machine :)

TheNosh
August 13th, 2009, 02:00 PM
It does? Sorry, I'm at work on a Windows machine :)

no need for appologies, i had to test it myself before i realized that. (which is sad on my part because it's the command i always use to stop compiz before playing games.)

TheNosh
August 14th, 2009, 09:11 AM
AH! found it! (the name of the default window decorator) it's gtk-window-decorator (duh!)

the command you need is
gtk-window-decorator --replace and then all should go back to normal

metacity --replace wouldn't work because metacity is a window manager which is what compiz is as well so they conflict. however gtk-window-decorator (which metacity uses) can be used with other window managers with no conflict as it is a window decorator.

kickwin
August 14th, 2009, 06:30 PM
I uninstalled emerald and it appears to have solved the problem. Compiz works fine as well. Is there something wrong with what I did?

kickwin
August 14th, 2009, 06:57 PM
I uninstalled emerald and it appears to have solved the problem. Compiz works fine as well. Is there something wrong with what I did?

I realized the use of Emerald which is to change themes.

TheNosh
August 17th, 2009, 12:54 AM
I uninstalled emerald and it appears to have solved the problem. Compiz works fine as well. Is there something wrong with what I did?

nope, theres nothing wrong with what you did. getting rid of emerald made it default back to gtk-window-decorator.