PDA

View Full Version : [ubuntu] What the f*** is wrong with ubuntu wireless networking



andlinux
August 12th, 2009, 08:26 PM
Sorry for the title but this pisses me of.

I've had a few modem/router/ap combo, you know them, all in one.
And some worked partially, some didn't and I mean the wireless part.

I have a laptop that's installed with Ubuntu 9.04 and this laptop has a built in wlan Intel 4965 card. Recently I bought a new modem, it's a Linksys WAG54G2, when I had installed that I started my laptop and entered the wireless wpa2 pass-phrase and voila it worked I was connected with the modem. The only problem was that the interface wlan0 lost the connection sometimes, but I was excited because this was the first time that I could use wpa2.

until yesterday, I started the laptop and the keychain asked me to give a password for networkmanager. so I did that but networkmanager wasn't able to connect to my Acces Point.

So I closed the laptop and tried it today again, it did just the same thing, it asked for the password but didn't connect and a few days ago it worked like a charm. So I walked to my AP in the basement and networkmanager still tried to connect, I was in the basement almost by the AP and there it was, networkmanager connected.

I had this problem also with my previous modem, I had to be very close to the AP so that it could connect and the wireless signal is very good in any room in the house. In my bedroom it's 77%.

So can please somebody give me an answer or knows how to get rid of this annoying problem ?

I have problems with the wireless part when I bought this laptop, it's brand new and from the first day I installed ubuntu on it.

Logs included.