View Full Version : [SOLVED] iwl4965/1 acting up

August 12th, 2009, 07:04 PM
Hi everyone,

I have an intermittent problem where iwl4965/1 causes my system to "stutter".

Every once and a while my system gets into this pattern where iwl4965/1 will jump up to near the top of the "top" list -- only taking about 15% cpu cycles. But it causes the system to stutter, in that if I'm typing the computer will think I'm holding a key down when I'm not. The whole interface seems to slow down but background applications keep running fine. When the problem happens it seems to occur about once every minute or two (for a second). But then there's weeks where the problem goes away entirely.

I've tried disabling wireless on nm-applet but that does nothing -- is iwl4965 supposed to keep running in this situation?

This is happening on a Thinkpad T61p with Ubuntu 8.04. Moreover, I'm connected to the internet via an ethernet cable so I suspect this stutter is happening when the wireless driver periodically polls the local wireless connections (there's 10 or 11).

Is this a known issue?

August 13th, 2009, 06:57 PM
Any ideas? This morning iwl4965/1 is behaving itself, but I'm running the exact same tasks as yesterday.

August 13th, 2009, 10:53 PM
The poor behavior of iwl4965/1 seems to be linked to flashplayer somehow. If iwl4965/1 isn't acting up, flashplayer isn't running. But as soon as I start using flashplayer, iwl4965/1 starts causing trouble.

Sometimes firefox's window will dim when iwl4965/1 starts acting strangely.