PDA

View Full Version : [ubuntu] Force Ubuntu to use eth1 instead of eth0



grapnell
August 12th, 2009, 04:14 PM
I have a broadcom built-in card on my motherboard, and the b44 driver continually disconnects. as far as I know, this is a known problem. I have installed a second card, an intel card, in which ubuntu recognizes perfectly, and dhcp assigns an IP address to it with no problem, however, it seems that ubuntu still tries to use the eth0 card instead of the new eth1 as its default. How do I tell ubuntu to forget about eth0 and use eth1?

Thanks for any help.

grapnell
August 12th, 2009, 07:40 PM
bump? anyone?

superprash2003
August 12th, 2009, 07:48 PM
try this http://www.cyberciti.biz/faq/linux-setup-default-gateway-with-route-command/

kerry_s
August 12th, 2009, 09:52 PM
you need to edit /etc/udev/rules.d/70-persistent-net.rules

you should find your devices listed in the order they were detected, on the end will be NAME="eth0" just change it to NAME="eth1" & the other to NAME="eth0", reboot and it should be all good.

Iowan
August 12th, 2009, 09:54 PM
There might be a way to effectively disable eth0 by defining it in /etc/network/interfaces as "manual", and leave eth1 under NM control. I haven't tried it, so ...

A BIOS disable might also be effective.

slakkie
August 12th, 2009, 10:04 PM
You can change the metric of the interface so it will prefer the intel over the broadcom. Lower metrics take precedence over higher ones.