View Full Version : [ubuntu] Ubuntu taking too long to connect to servers

August 12th, 2009, 03:23 AM
I have a slow internet connection here (about 0.3 Mb/s), but it seems to be slower in Ubuntu.

I have a dual boot system, Windows XP and Jaunty.

When I'm in Ubuntu and try to download something, Ubuntu takes very long to actually start the download, either a webpage on Firefox, a package in Synaptic, an update...
In Firefox, when I go to Youtube, after the page is loaded, it takes some 20 seconds for the video player to appear and actually start loading the video.
While in Windows, after the page is loaded, the video starts loading almost immediately.

When I search something in Google, it says "Looking for www.google.com" for about 30 seconds before start loading the results.

It also happens in Windows XP inside Virtualbox.

It's not only annoying, but sometimes Firefox even gives up trying to connect and says that the page couldn't be found.

Is there any way I can fix this?

August 12th, 2009, 04:19 AM
Look into disabling IPv6 if not needed and also please post your /etc/resolv.conf

August 12th, 2009, 03:55 PM
How can I disable IPv6? It seems to be built into Jaunty's Kernel.


# Generated by NetworkManager

I've looked for it but nobody seems to have a fix for it in Jaunty. In other versions, including Karmic, it seems to be as easy as blacklisting IPv6.

August 13th, 2009, 05:36 PM

If there is no way to disable IPv6, just tell me, so I'll just wait for Karmic.

August 13th, 2009, 05:39 PM
Go here http://www.ubuntugeek.com/how-to-disable-ipv6-in-ubuntu.html

August 13th, 2009, 06:31 PM
Maybe IPv6 is not my problem, I've disabled it in Firefox (using about:config) but I still have problems.

Go here http://www.ubuntugeek.com/how-to-disable-ipv6-in-ubuntu.html

It doesn't seem to work in Jaunty.

August 15th, 2009, 12:34 AM
What kind of connection? LAN / WiFi?

August 15th, 2009, 01:17 AM
This computer is connected to a router and the router connects to the internet and to other computer, all wired.

This problem started a few weeks ago, when my ISP was bought by another one.

August 17th, 2009, 10:10 AM
Sounds like a DNS issue to me. To test that theory you can try using one of the openDNS servers to see if that's any better than your ISPs DNS.

The IP addresses are as follows.

Add one or both of them to the top of your /etc/resolv.conf file and see if that does the trick.


Failing that run a ping on google to check your latency and post the results.

ping -c 10 google.com

If you're certain this is a Linux ONLY issue then we'll look into the networking side of things but to me this looks like a ISP DNS / latency issue.

August 18th, 2009, 05:43 PM
I'll try it now...

This problem is not Linux-only, but in Windows it happens much less.

August 18th, 2009, 05:49 PM
It worked!!!

Thanks, man, finally I can use the internet well again!

EDIT: It's working, but when I suspend the computer and come back, the /etc/resolv.conf file is reset back to what it was, making my connection slow again. What can I do?
Maybe some script at start up to edit the /etc/resolv.conf file?

EDIT2: Fixed, I used the post #7 in this thread: http://ubuntuforums.org/showthread.php?t=306308