PDA

View Full Version : [ubuntu] Using SSH to SFTP



x_jose_x
August 11th, 2009, 09:59 PM
Hello,

I am trying to FTP into my Ubuntu Jeos 8.04 system.

I have SSH installed and running. Using putty I can log in just fine.

I attempted to use WinSCP to SFTP into the system. This returns an Access Denied message.

I have since installed vsftpd. I did edit the vsftpd config to allow local users to log in. This did not help.

Upon further reading, if my understanding is correct, I actually did not need to install a seperate ftp server since I have ssh. Is this correct?

If I can use putty to ssh into the system, what I can do to get sftp to work? Additionally should I uninstall vsftpd?

Thank you,
Jose

sephedo
August 11th, 2009, 10:09 PM
what user are you using to access the files via ssh?

you accessing it local? internet?

all i can think is to make sure that the user has rights to /

and since putty is working im assuming the port is open

x_jose_x
August 11th, 2009, 10:27 PM
For ssh over putty I use a standard user (non-root). This works fine.

I am attempting to use the same user for sftp in WinSCP. I get an access denied message.

I am using this locally.

It is unlikely this user has rights to /

x_jose_x
August 11th, 2009, 10:30 PM
This appears to be an issue with WinSCP. I just tried to log in with psftp and it works fine.

Edit - The issue with WinSCP was that Allow SCP Fallback option was checked. Unchecking this option worked.