View Full Version : [ubuntu] 9.04 won't boot to desktop environment

August 9th, 2009, 10:38 PM
I have been using Ubuntu happily on my laptop for some time. I've had 9.04 on it since it came out, but recently it has had some sort of problem booting to the desktop environment.

I get various kinit messages after the load bar finishes and before it usually gives you the graphical login/password screen. Basically a long series of error messages decide there is "kinit: No resume images, doing normal boot..." only the boot is not normal. It asks me to log in in the command environment and when I try to do things like dpkg-rconfigure xserver-xorg it is "unable to resolve host," "can't stat /var/run/sudo: Not a directory" and many other strange errors.

Some help would be much appreciated. Also, the suspend feature has not worked on this laptop ever and as such it has been disabled so I'm not sure why it is trying to resume from a previous state. I believe this began happening after a crash. Upon restart, these messages began.

August 9th, 2009, 10:44 PM
Tried xfix? Read how to use it here: http://kshoster.net/?q=tutorials/ubuntu/xfix