View Full Version : [ubuntu] Wireless stopped working after graphics card update?

August 9th, 2009, 12:11 PM
I installed Ubuntu 9.04 (32-bit) on my Acer Aspire 5520. I had problems with resolution and wireless, so I first installed ath5k drivers and worked perfectly. Then I installed NVIDIA graphics card drivers, also works... but the wireless stopped working after that. Now I can't get it to work anymore. I even tried recompiling and installing ath5k, didn't do anything. Could somebody help?

Oh, and I don't have access to a wired network, so I have to install everything from my USB stick.

August 9th, 2009, 04:07 PM
Ok so are you sure that the update was only for graphics? So what happened to me is that there was a sort of kernel update. After this update i had no wireless. What i had to do is reinstall the drivers and all to get it working. To see if this applies to you:

On boot up hit:


after hitting escape it will bring you to a menu. In this menu there will be a list of options like

Kernel 2.x.x.x generic
Recovery mode
Kernel 2.x.x.x generic

Try booting up off of the second latest version. So if the first one is e.g generic and the second is (one version lower) then go down to the second option and hit enter.

Do you know what card you have and what driver you are using. I know you are using ath5k but where did you get the driver.


August 9th, 2009, 10:15 PM
I managed to solve the problem. I installed madwifi drivers and now it works perfectly. Thanks for the help anyway. :)

This can be closed.