View Full Version : [ubuntu] Conky does not start on boot

August 7th, 2009, 02:26 PM
I just have installed conky and added this bash script to start it when booting

sleep 10 && conky;
It works well when I logout, but it does not work when booting. Any idea on how to solve this?


August 7th, 2009, 06:31 PM
There are two things I'd try.
1) If conky is starting up but then closing, increase the sleep time. For example, try this.

sleep 15 && conky ;
2) I'm not sure how much of a difference this makes, but my conky startup script has a space between "conky" and ";". So, try simply adding a space, like the code I put above.

August 7th, 2009, 06:47 PM
Go to system >> preferences >> sessions. And add conky :) It`s much easyer that way

August 19th, 2009, 02:15 PM
My conky now starts on boot, using the bash script I posted, with a sleeping time of 15 second :). Now I have another problem :(. When booting, conky loads before the 15s, thus not loading properly. The, I have to re-load the X and the conky loads when required. Any idea on how to solve this?


August 20th, 2009, 08:25 AM
It sounds like either conky is running from sessions instead of the shell script running from sessions, or the sleep isn't long enough. I run mine with a 20 second sleep. So try this instead: (the script I assume is hidden in your home directory)

Make the .sh executable by

sudo chmod a+x .file_name.sh

Then in sessions, remove conky and instead, add the shell script by typing ~/.file_name.sh in the command box.

August 20th, 2009, 08:21 PM
Depending on your Ubuntu version and filesystem used (ext3/4) the time needed to actually boot will vary. So whenever you log in the login scripts are executed but the time needed to actually render the desktop will be much greater than 15sec. Try increasing this delay to more number.. maybe 30ish or even 50sec. That way you don't have to worry about reloading X.

Edit : I put all my scripts inside ~/Scripts folder. It looks better organization to me and easy to find the scripts next time you need to edit them.

August 27th, 2009, 05:44 PM
Sorry for the delay. I've been on holiday and forgot the PC completely. Now it works great.