View Full Version : [ubuntu] Randomly losing mouse and keyboard input

August 7th, 2009, 12:51 PM
I recently started having a problem that I haven't seen before. I'm using Ubuntu 8.10 with nvidia drivers.

Every now and then, Ubuntu stops responding to mouse clicks or keyboard input. I can still move the mouse cursor, but that's all. It happened frequently this morning while I was using xfig. SSHing from another computer and killing xfig solved the problem. But later, it has happened even when I'm not using xfig. Killing and restarting compiz has solved the problem in these cases. So I tried stopping compiz and using metacity instead. That worked well until I used xfig, at which point the same thing happened again and I had to SSH and kill xfig.

I don't know where to start troubleshooting. Any ideas?

August 7th, 2009, 03:16 PM
Have you tried looking at /etc/X11/xorg.conf and see if you can modify what your keyboard and mouse input is ?

August 7th, 2009, 04:41 PM
There are two InputDevices: one "Keyboard0" and one "Mouse0". Strangely, I see there is no input device for my touchpad, but it still works. (I use a laptop with external mouse and keyboard. When the problem happens, I can't click using the touchpad either.)

My xorg.conf is here, in case you see something strange with it:

# nvidia-settings: X configuration file generated by nvidia-settings
# nvidia-settings: version 1.0 (buildd@crested) Mon Nov 3 08:46:04 UTC 2008

Section "ServerLayout"
Identifier "Layout0"
Screen 0 "Screen0" 0 0
InputDevice "Keyboard0" "CoreKeyboard"
InputDevice "Mouse0" "CorePointer"

Section "Files"

Section "Module"
Load "dbe"
Load "extmod"
Load "type1"
Load "freetype"
Load "glx"

Section "ServerFlags"
Option "Xinerama" "0"

Section "InputDevice"

# generated from default
Identifier "Mouse0"
Driver "mouse"
Option "Protocol" "auto"
Option "Device" "/dev/psaux"
Option "Emulate3Buttons" "no"
Option "ZAxisMapping" "4 5"

Section "InputDevice"

# generated from default
Identifier "Keyboard0"
Driver "kbd"

Section "Monitor"

# HorizSync source: edid, VertRefresh source: edid
Identifier "Monitor0"
VendorName "Unknown"
ModelName "Samsung SyncMaster"
HorizSync 30.0 - 81.0
VertRefresh 56.0 - 75.0
Option "DPMS"

Section "Device"
Identifier "Device0"
Driver "nvidia"
VendorName "NVIDIA Corporation"
BoardName "GeForce 9600M GT"
# # Set PowerMizer to dynamic:
# # PerfLevelSrc=0x2222 - fixed PowerMizer mode for battery and AC
# # PerfLevelSrc=0x2233 - fixed mode for battery and adaptive for AC
# # PerfLevelSrc=0x3333 - adaptive strategy for battery and AC
# Option "RegistryDwords" "PerfLevelSrc=0x3333"
# Force Powermizer to a certain level at all times:
# level 01 = highest
# level 02 = med
# level 03 = lowest
# Option "RegistryDwords" "PowerMizerLevel=0x3"

# Max save on battery, adaptive on AC:
Option "RegistryDwords" "PowerMizerEnable=0x1; PerfLevelSrc=0x2233; PowerMizerDefault=0x3"

# Enable on demand V-Blank (which will reduce by 60 your kernel wakeups)
Option "OnDemandVBlankInterrupts" "true"


Section "Screen"

# Removed Option "TwinView" "0"
# Removed Option "metamodes" "DFP: nvidia-auto-select +0+0"
Identifier "Screen0"
Device "Device0"
Monitor "Monitor0"
DefaultDepth 24
Option "TwinView" "1"
Option "TwinViewXineramaInfoOrder" "DFP-0"
Option "metamodes" "CRT: nvidia-auto-select +1280+0, DFP: nvidia-auto-select +0+0"
SubSection "Display"
Depth 24

August 17th, 2009, 11:52 PM
After downgrading the nvidia driver to version 177.80, this hasn't happened again for a few days. Let's hope it stays that way ;)