View Full Version : [ubuntu] grub 2 doesnt let me boot ubuntu

August 5th, 2009, 11:54 AM
when i boot my laptop it has the grub 1 menu and at the top it says that i am using debain (not ubuntu like i am) and when i try to load grub 2 or "debian" (witch is ubuntu)it says error 11: unrecognised device string
im using windows on the same laptop so at least i can boot into that is there anything i can do to get ubuntu back

August 6th, 2009, 01:27 PM
i managed to fix it by booting from a live cd and using chroot to get into my normal ubuntu root and then coppied the backup of grub menu.lst to the real file

August 6th, 2009, 01:57 PM
ha...by u fixing your own error i learned something!!! thanks!!!

August 7th, 2009, 10:42 AM
thats good to hear but it wasent my error it was an error in grub2s installer

October 16th, 2009, 10:53 AM
thats good to hear but it wasent my error it was an error in grub2s installer

Looks like you didn't know what you were doing.
If you installed grub 2 as an upgrade of the grub that comes with ubuntu, yes you will receive an error.

You should research before you do something, as I did, and Grub 2 worked perfectly for me.
All I had to do was install it, and when it came up with this error:
press the a key to continue.

You should then come to this:
select chainload and press e.

Select root and then press e

Now re-name the string of root:

too uuid and press enter:

Select the uuid entry and press b to boot:

Now grub should boot safely without any errors, straight to this screen:

Do not blame a program for being bad when it is purely your fault. Set it up correctly for it to work, but don't blame it for not working if it has worked for tons of others.