View Full Version : [ubuntu] update manager failed while partial upgrade

August 5th, 2009, 07:28 AM
Hi ,

I upgrade from 8.04 to 8.10 through 8.10 alternate iso image.
than 8.10 to 9.04 though 9.04 alternate iso image.
now after this i run update manager to download latest updates.
Update manager suggested me for partial upgrade.
It downloads the packages, than suddenly disappeared.
I tried to run it again it does the same.
than i tried to run update-manager through terminal and i saw some failure messages.
Here is the log from terminal.

sumit@sumit-laptop:~$ sudo update-manager
ERROR:root:not handled expection:
Traceback (most recent call last):

File "/usr/bin/update-manager", line 100, in <module>

File "/usr/lib/python2.6/dist-packages/DistUpgrade/DistUpgradeController.py", line 1595, in doPartialUpgrade
if not self.doDistUpgrade():

File "/usr/lib/python2.6/dist-packages/DistUpgrade/DistUpgradeController.py", line 972, in doDistUpgrade

File "/usr/lib/python2.6/dist-packages/DistUpgrade/DistUpgradeQuirks.py", line 77, in run
for plugin in self.plugin_manager.get_plugins(condition):

File "/usr/lib/python2.6/dist-packages/computerjanitor/plugin.py", line 167, in get_plugins
filenames = self.get_plugin_files()

File "/usr/lib/python2.6/dist-packages/computerjanitor/plugin.py", line 120, in get_plugin_files
basenames = [x for x in os.listdir(dirname)

OSError: [Errno 2] No such file or directory: './plugins'

ERROR:root:failed to import apport python module, can't report bug: No module named python_hook

Hope to get some help.
thanks in advance.


August 5th, 2009, 07:43 AM
Try running in terminal
sudo aptitude safe-upgrade

If that doesn't help, boot in rovery mode and select "Repair Broken Packages"

If it doesn't work, let us know.

August 7th, 2009, 08:12 AM
Hey thanks a lot , sudo aptitude safe-upgrade it worked for me.