PDA

View Full Version : [ubuntu] woops i think i messed up



masonkersnick
August 3rd, 2009, 10:52 PM
[solved]ok i am trying to upgrade my ubuntu and i downloaded the whole new file to my computer do i have to put it on a disk to get it to upgrade???

MTGap
August 3rd, 2009, 10:56 PM
No you don't necessarily have to do that unless you want a clean install.

To upgrade your current distro without a disk open up a terminal and type:


sudo apt-get dist-upgrade

masonkersnick
August 3rd, 2009, 10:58 PM
i tried that and all it says is Reading package lists... Done
Building dependency tree
Reading state information... Done
Calculating upgrade... Done
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.

-=hazard=-
August 3rd, 2009, 10:59 PM
Or go to: System -> Administration -> Update Manager

wojox
August 3rd, 2009, 11:01 PM
Are you trying to upgrade packages on your computer or upgrade from 8.10 to 9.04?

masonkersnick
August 3rd, 2009, 11:02 PM
is there anyway i can still get the 7.10 upgrade im trying to go from 7.04 to 8.04 and i think that could be the problem i know this is ill advised to skip but im not really worried about losing info this computer

wojox
August 3rd, 2009, 11:03 PM
Do what hazzard suggested. You have to go in order.

masonkersnick
August 3rd, 2009, 11:05 PM
i tried both ways and neither worked the 7.10 wont download because it is eol or something

ugm6hr
August 3rd, 2009, 11:09 PM
I would suggest you start again with a fresh install.

Upgrading is not possible without going through every version in between, which will require several GB of downloads, most of which is unnecessary.

If you have downloaded a new version, just burn to CD, or copy to USB flash to install fresh.

EOL means End Of Life - all the rpositories have been moved, and I think upgrading has been disabled.

-=hazard=-
August 3rd, 2009, 11:12 PM
i tried both ways and neither worked the 7.10 wont download because it is eol or something

Check this first maybe your version is obsolete (https://help.ubuntu.com/community/UpgradeNotes#7.10)

masonkersnick
August 3rd, 2009, 11:19 PM
i think i am kinda screwed i just now noticed i cant even get my disk drive open so i guess its two steps back then one foward

masonkersnick
August 3rd, 2009, 11:24 PM
nvm i got it under control :D