PDA

View Full Version : [ubuntu] can't play DVD on Jaunty on dell e1405



shneader
August 2nd, 2009, 07:25 PM
I have a Del E1405 running Jaunty. I just started using Linux a few weeks ago. I wanted to try some of the DVD ripping software (i.e., AcidRip). It can't seem to read the DVD that I have in my drive. Then, I simply tried playing the DVD with VLC or Mplayer, and it doesn't work. When I use VLC and go "Media > Open Disc > have DVD checked, and click "play", VLC just shuts down. When I try MPlayer, Media > Play #n, it says "An error occurred: Your GStreamer installation is missing a plug-in." I tried this with 2 different DVD's, and I get the same result

1. If someone can suggest the plugin I should get from Synaptic, that would be great.
2. Is there any kind of "driver" or something that I need for my E1405 so that it can read these disks? I wouldn't think so, because these DVD's work when I boot in windows. But, who knows.

Thanks.

ubudog
August 2nd, 2009, 07:33 PM
Check this out:https://help.ubuntu.com/community/RestrictedFormats:)

ubudog
August 2nd, 2009, 07:33 PM
It worked for me:)

Dark Aspect
August 2nd, 2009, 07:35 PM
You need libdvdcss2 (http://packages.medibuntu.org/jaunty/libdvdcss2.html) to play DVDs on Linux, also it wouldn't hurt to install Ubuntu restricted codecs.


sudo apt-get install ubuntu-restricted-extras

After that you should be able to play DVDs via VLC and mplayer.

Dark Aspect
August 2nd, 2009, 07:41 PM
Check this out:https://help.ubuntu.com/community/RestrictedFormats:)

That link is broken,

http://img217.imageshack.us/img217/7268/screenshotssb.th.png (http://img217.imageshack.us/img217/7268/screenshotssb.png)

ubudog
August 2nd, 2009, 07:44 PM
That link is broken,

http://img217.imageshack.us/img217/7268/screenshotssb.th.png (http://img217.imageshack.us/img217/7268/screenshotssb.png)

Yes it is. Sorry about that.:)

Dark Aspect
August 2nd, 2009, 07:49 PM
Yes it is. Sorry about that.:)

I believe the semi colon caused the issue, there appears to be a page about RestrictedFormats here (https://help.ubuntu.com/community/RestrictedFormats). None the less its almost easier to write sudo apt-get install ubuntu-restricted-extras.

ubudog
August 2nd, 2009, 07:59 PM
True

shneader
August 3rd, 2009, 05:58 AM
Thanks. I read the Restricted Formats page. I also had to do this:
sudo /usr/share/doc/libdvdread4/install-css.sh

Also, since I had never played a DVD via Ubuntu before, I installed regionset. Interestingly, it was already set to region 1, which is what I wanted.

Lastly, although not specified, I did not restart my computer after installation, and none of these changes worked. I tried restarting my computer, and then it worked.

Thanks.

ubudog
August 3rd, 2009, 02:44 PM
Thanks. I read the Restricted Formats page. I also had to do this:
sudo /usr/share/doc/libdvdread4/install-css.sh

Also, since I had never played a DVD via Ubuntu before, I installed regionset. Interestingly, it was already set to region 1, which is what I wanted.

Lastly, although not specified, I did not restart my computer after installation, and none of these changes worked. I tried restarting my computer, and then it worked.

Thanks.

Any time:)

Chasalin
August 3rd, 2009, 08:28 PM
Wow that was hard to find... I spent weeks searching for a way to play any dvd on my laptop. Today I found an old post about 7.04 telling me about `/usr/share/doc/libdvdread3/install-css.sh`, I updated it to libdvdread4, et voila...
Only with that information I was able to find this thread...

Why is there no easy-to-find option to enable this?
Yes I know it can be abused... so can anything... I abuse my mind every day ;)