View Full Version : [ubuntu] I am a noob and need help with my xorg.conf file

August 2nd, 2009, 04:19 PM
My system is an Asus EEEPC 4G SURF I have the latest Ubuntu installed. I have been able to get everything but my video working to my frustration. After 20 something tries to config my xorg.conf file I have given up and hope that some nice people here can tell me what I need to do to make the file work correctly.

Here is what I have installed.
Resolution1360x768 pixels OpenGL RendererMesa DRI Intel(R) 915GM GEM 20090326 2009Q1 RC2 x86/MMX/SSE2
KernelLinux 2.6.28-14-generic (i686)

Loaded Modules
i915Intel Graphics drmDRM shared core routinesintel_agp
agpgartAGP GART driver

ACPI Video Driver

OpenGL VendorTungsten Graphics, Inc RendererMesa DRI Intel(R) 915GM GEM 20090326 2009Q1 RC2 x86/MMX/SSE2 Version1.4 Mesa 7.4 Direct RenderingYes
If someone out there would be kind enough to give me an xorg.conf file for this setup with 8 megs of video ram. I would be very greatful. Also if there is anything I am missing that is causing this setup not to work please let me know what I need.

August 2nd, 2009, 05:34 PM
I'm certainly no expert on this area, but did you try to use the xfix option from recovery mode? Hit the escape key when GRUB starts loading and select the recovery mode option. Then wait for it to give you a menu and use the arrow keys to go all the way down to the xfix option. After that runs, you should be able to exit the menu (when it comes up again) and resume booting. Your problem sounds related to screen resolution. Go to system > preferences > Display and see if you can change it.

I also found this really good guide for editing xorg.conf file.
It's for BSD, but it should also work Ubuntu.


You can also try here:

August 2nd, 2009, 05:53 PM
I have tried that already. right now I am stuck with an xorg.conf file that just has the generic everything in it. I am not sure what to add to it and where but every time I try my own configs x wants to start in low res mode. Right now I have my resolution working correctly but my FPS on glx gears are very low (200-300fps) usually. I use the gimp a lot for working on my website graphics. Gimp is reallly slow though. I managed to get cpufreq working and have clocked my cpu all the way up to 900mhz but I still am not getting even close to the power I should have. I really need a working xorg.conf file because I am completely lost with that one.

August 3rd, 2009, 04:19 AM
Here is my config file. Maybe someone can point out what is not working in it.

# xorg.conf (X.Org X Window System server configuration file)
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
# Edit this file with caution, and see the xorg.conf manual page.
# (Type "man xorg.conf" at the shell prompt.)
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
# Note that some configuration settings that could be done previously
# in this file, now are automatically configured by the server and settings
# here are ignored.
# If you have edited this file but would like it to be automatically updated
# again, run the following command:
# sudo dpkg-reconfigure -phigh xserver-xorg

Section "Device"
Identifier "Intel Corporation Mobile 915GM/GMS/910GML Express Graphics Controller"
Driver "intel"
BusID "PCI:0:2:0"
Option "XAANoOffScreenPixmaps" "true"
Option "AccelMethod" "XAA"

Section "Monitor"
Identifier "Configured Monitor"

Section "Screen"
Identifier "Default Screen"
Monitor "Configured Monitor"
Device "Intel Corporation Mobile 915GM/GMS/910GML Express Graphics Controller"

DefaultDepth 24
SubSection "Display"
Viewport 0 0
Depth 24
Modes "1360x768"

Section "DRI"
Mode 0666

Section "Extensions"
Option "Composite" "Enable"

August 3rd, 2009, 04:44 AM
I am sorry to say that there are quite a few issues with intel graphics and a stock install of 9.04. Take a look at

I have 852/855 intel chipset on my laptop and a stock install of 9.04 made watching video like looking at a slideshow. After following the howto in the link (I found that what psyke83 calls the "bleeding edge" using the xorg-edgers ppa worked best for my system) performance is quite useable. Hopefully by 9.10 it will be fixed without too many other things breaking!