PDA

View Full Version : [ubuntu] Nvidia GTX7800 SLI freezes when starting Games



misse-
July 31st, 2009, 04:13 PM
Hi All.

I've managed to get both my NVidia card active in SLI and the system successfully logs me in to my desktop. Compiz effects are activated and works fine. Glxgears works and nvidia-settings informs me that both cards are active in SLI.

However, when I launch warcraft 3 or Heroes of Newerth, the system totally freezes. The only way to solve this is by reboot.

These games works fine without sli enabled. I've searched the forums and google but have come out short with a solution to this, so therefore I hope someone's got a tip.

xorg.conf

# xorg.conf (X.Org X Window System server configuration file)
#
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
#
# Edit this file with caution, and see the xorg.conf manual page.
# (Type "man xorg.conf" at the shell prompt.)
#
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
#
# Note that some configuration settings that could be done previously
# in this file, now are automatically configured by the server and settings
# here are ignored.
#
# If you have edited this file but would like it to be automatically updated
# again, run the following command:
# sudo dpkg-reconfigure -phigh xserver-xorg

Section "Monitor"
Identifier "Configured Monitor"
EndSection

Section "Screen"
Identifier "Default Screen"
Monitor "Configured Monitor"
Device "Configured Video Device"
DefaultDepth 24
Option "SLI" "Auto"
EndSection

Section "Module"
Load "glx"
EndSection

Section "Device"
Identifier "Configured Video Device"
Driver "nvidia"
Option "NoLogo" "True"
BusId "01:00:00"
Option "AddARGBGLXVisuals" "true"
EndSection

Section "Device"
Identifier "Configured Video Device"
Driver "nvidia"
Option "NoLogo" "True"
BusId "04:00:00"
Option "AddARGBGLXVisuals" "true"
EndSection


Very grateful for help.