View Full Version : [ubuntu] LaCie USB firewire External Hard Drive not detected

July 29th, 2009, 10:35 AM
I have a LaCie USB 500GB External Hard Drive that doesn't need a power supply to run it is supposed to just plug in and be detected. When I connect it to my USB port it isn't detected at all. I have tried other ports it still doesn't work. The ports work with other devices and the External Hard Drive's blue light comes on confirming it has power i think. It doesn't work on a Windows OS either. It has 2 firewire ports on the side and one other port for something. Suggestions for it to be detected?

March 27th, 2010, 02:24 AM
Did you ever resolve this issue? I am running into the exact same problem (running karmic).

August 7th, 2010, 06:05 AM
Same problem. ::bump::

August 11th, 2010, 01:10 AM
I'm having the same problem.

I'm running my Windows XP, at the moment. It's working there.
Type: Local Disc
File System: FAT32
Device Status: The device is working properly.

I'm new at Ubuntu 9.10. I tried an other USB port, not the answer. Help us out, please. Thank you.

August 19th, 2010, 04:31 PM
Sometimes an Extra-length or weak USB cable is the reason. It may affect in two ways (any or both):

Voltage dropping to less than sufficient (4.6V).
USB signal getting too weak to be detected properly.

I've practically experienced it on my 5.5" PATA HDD casing (couldn't be detected, or detected then disappeared on accessing when using more than 1.5m cable).

However, it is only one of many possible reasons.

September 12th, 2010, 05:00 PM
Thank you varunendra, that did the trick for me! :D Just replaced the cable and instantly my external LaCie was recognized. Cheers!