View Full Version : [ubuntu] 9.04: Grub throws floating point exception with "find" command

July 25th, 2009, 05:28 AM
I installed 9.04, formatted ext4, from the alternate install disk, and let it install grub to the mbr of the first disk - "hd0," in grubspeak. I booted to Jaunty, copied Jaunty's /boot/grub/ contents to my grub partition, and ran grub as root, saying simply,
sudo grubI got the usual response, and then at the grub prompt, typed the universally recommended command,
find /boot/grub/stage1Grub responded, without even the courtesy of a new line,
grub> find /boot/grub/stage1Floating point exception

I tried the same thing in Hardy, and got the expected results - a list, in grubspeak, of the disks and partitions where I could find /boot/grub/stage1, and they were correct. I tried using Hardy's Grub to set the whole thing up, but it looks like the Grub from 8.04 can't see into the ext4 partition.

I aptituded and updated Jaunty, and tried again, and rebooted and tried again, but no joy. The LiveCD gave me the same result

The web and the forums are strangely silent on this issue: just a couple of guys saying the same thing I am - that they bumped into this error, and couldn't find out anything about it.

I also noted that Jaunty's grub installation was far from correct. It would boot to Jaunty, but it didn't get the disk right for any of my other OS's. It set up menu.lst to point to hd0 for partitions that grub finds on hd2; after I made those changes to the menu.lst entries for my other OS's, I could boot, for example, into Hardy again.

But I'm not worrying about that right now. For today, I just want to get past the floating point exception.

Has this only happened to me and a couple of other guys, or does everybody else already know the fix?

August 1st, 2009, 06:28 PM
Never mind. After the last update, this problem disappeared.

August 29th, 2009, 06:18 AM
Well, I was wrong about that. My grub problem wasn't fixed, it was intermittent.

Before I loaded Jaunty, the first partition on one of my PATA drives had become garbled, apparently due to a loose cable connection. I had left it as it was, in hopes of retrieving some of the data, someday. When I gave up on that, I replaced the data cable, reformatted the bad partition, and Grub stopped giving me floating point exceptions when I ran the "find" command.