PDA

View Full Version : [other] Annoying (Serious) Keyboard Shift key problem



congogr
July 22nd, 2009, 03:44 PM
I have the EEE 900, and I am facing a very serious and annoying problem since I installed EEEbuntu Base 3.0 (based on 9.04) both on Power Saver and Super Performance states (so quite likely not an over/underclocking issue). Although I have tried the EEEbuntu Forum as well, I feel this could be an error with Ubuntu 9.04 (Jaunty), no matter what the flavor. Correct me if wrong...

PBEM (problem)...
Neither the right nor the left Shift keys work with most letters.

For example, if I need to use capital letters (or symbols) the Shift+Key combination doesn't work.
SPECIICA (I just tried to type the word specifically using the left Shift key), SPECIFICALL (and now with the right Shift key...).

I overcome this problem by using Caps ock (Lock), but this is not the same with symbols, like the semicolon for example, which I have no way of typing, unless I Copy-Paste it from somewhere else.

(This is not a keyboard shortcut issue, from the Ubuntu settings), as the only thing I added was the Ctrl+Alt+T combination for opening a new Terminal window.

I will now type all letters in the English alphabet, in case it is important to know WHICH do not work...
Left-Shift... ABCEGHIJKMPQSTUWXZ
Right-Shift... ABCEFGHIJKLMPSTVWXZ
...almost the same, although with the right shift I can type an extra F, L, V but cannot type Q and U as I could with the left one...
Help anyone??? From my point of view, it is not a keyboard fault (I checked the flat-plastic cable below the keyboard anyway), although the one below might have to do with the keyboard capabilities on the EEEpc 900. ;-)


(Another thing I also find annoying, is that when I type fast... and my word ends in -on-, what I usually have on the screen is -no-. I type -combination- fast, it works on all my computers, however the EEE 900 shows the word as -combinatino- although I am absolutely certain that I type the sequence correctly, hence it does not appear with any other combinatino ;) of letters... Anyone facing this?)

congogr
July 23rd, 2009, 11:24 AM
Noone has heard of it or can propose a solution?
:o

stephw8
July 30th, 2009, 12:39 PM
I am having a similar issue as well. This started a couple of weeks back and none of the other fixes have solved it.

With me it is both shift keys but, oddly enough, slightly different behavior. The left shift key fails to work with the keys t,y,g,h,{,}," for the right shift key it is g,h," keys.

The other odd thing is I can force it by holding the shift key down, holding down the key I need to capitalize, or the symbol I need, and then releasing the shift key.

I have tried resetting Compiz as suggested in other topics, but that is not the problem. I have also confirmed that there are no shortcut conflicts.

I have been running Ubuntu on this laptop, an HP ze4600, for a few years now. Currently running Jaunty. Everything has been working fine until something was updated back around the first week in July.

frankhdz
July 31st, 2009, 06:13 AM
I am having the same issue with the g and u keys the shift key does not work on these two letters.

I am using Hardy.

testimies
August 29th, 2009, 07:54 AM
Any news on this item? I also have this really annoying problem. Is this a hardware problem? I use password in bios and even it didn't recognize some shift+alphabet combos.. Maybe bios update would help? Or has mine eee 901 just broken keyboard??

Here are mine alphabets with left shift: QWETUIASGJKZXCBM
And with right shift: WETIPASFGHJKLZXCVBM

TM

engles
September 15th, 2009, 01:56 AM
I am having the same keyboard shift problem with my 701 Surf, as a result of a leaky roof and some water getting on the keyboard, and would like to know if it is a hardware or software problem before I try a reformat (Windows.) My first thought was software but as seeing that mine has the same keys disabled as others report it may be that the keyboard was shorted out.

Writer_of_Ryle
September 19th, 2009, 06:29 PM
same problem but it don't work with any keys i got to use caps lock to do cap letters:confused:

engles
October 6th, 2009, 11:13 PM
I cleaned the keyboard as per another forum without success. The left shift key:
QWERTYUIOP
ASD___J__
_____N_
The right shift key: (will not "_", "@", "$", "(", or "^")
*WERTY*IOP
ASDF**J*L*
***V*N*
As with Writer_of_Ryle, the workaround is to use CapsLock, which is almost always with the bottom rows of keys because certain letters work/don't work with either shift key. Hopefully someone will figure it out.

testimies
October 15th, 2009, 01:49 AM
I think that eee's keyboard is not good. I spilled something like half a tee spoon of water into keyboard and that broke it. yes, I suspect that our keyboards are broken, not a software issue.

One solution would be to use some other key for example windows key as a shift. Anyone knows how to do it?

Tm

jnelson11
December 3rd, 2009, 03:43 PM
Ive got an interesting problem that may or may not be related to this issue here.

i have a lenovo t60 laptop that i use with a docking station and an external usb keyboard.

I just installed 9.10 and use both keyboards. One hand on one keyboard and the other hand on the other keyboard. The issue is when i use the shift key from one keyboard and type a letter on the other. it will not apply the shift to the first keypress, but it does apply it to every other subsequent press

lets say for instance i type the letter 'i' and use the left keyboard shift key.

the results are iIIIIIIIIIII the first one is always lower case/? again even symbols like the question mark first one is the slash then the question mark.

anyone had this issue/?

rty88sr
June 1st, 2010, 05:20 AM
I had this problem, left-shift would not work in combination with either the T or Y keys. I turned out that an application key (Email) was stuck from the last time is used it. Once I jiggled this key full functionality was restored. So, I suggest you check and see if any keys are stuck.

testimies
June 24th, 2010, 06:34 PM
My keyboard was physically broken. Luckily I had couple of months of warranty left and they changed keyboard. Now it works. So, not a sw problem in my case.