View Full Version : [ubuntu] Nvidia Drivers Driving me Batty!!!

July 21st, 2009, 01:25 PM
Ok, yesterday I installed Jaunty on my laptop. Everything works fine except for the fact that the Nvidia driver doesn't want to save. Whenever I reboot I have to re-adjust my resolution. No matter what I do I cannot get the xorg.conf file to maintain my settings. I have tried everything from this thread: http://ubuntuforums.org/archive/index.php/t-1101445.html
and just got done installing EnvyNG but the drivers still won't save. I am pulling my hair out here. The error message I get when I try to save the settings to x is this:
Failed to parse existing X file '/etc/X11/xorg.conf'!

If anyone knew of any other way to save my settings, I would be much obliged :)

July 21st, 2009, 01:30 PM
Post up your xorg.conf file, sounds like you've got a typo in it somewhere.

July 21st, 2009, 01:33 PM
From recovery mode console, run this command and reboot:


July 21st, 2009, 01:34 PM
Open terminal:

gksudo /usr/bin/nvidia-settings

That will let you save your new settings as root.

July 21st, 2009, 01:53 PM
From recovery mode console, run this command and reboot:


Well, that helped at little. My xorg.conf file was really sparse before I did the above. Now my xorg.conf file looks like this:

# nvidia-settings: X configuration file generated by nvidia-settings
# nvidia-settings: version 1.0 (buildd@crested) Sun Feb 1 20:25:37 UTC 2009

Section "ServerLayout"
Identifier "Layout0"
Screen 0 "Screen0" 0 0
InputDevice "Keyboard0" "CoreKeyboard"
InputDevice "Mouse0" "CorePointer"

Section "Files"

Section "Module"
Load "dbe"
Load "extmod"
Load "type1"
Load "freetype"
Load "glx"

Section "ServerFlags"
Option "Xinerama" "0"

Section "InputDevice"
# generated from default
Identifier "Mouse0"
Driver "mouse"
Option "Protocol" "auto"
Option "Device" "/dev/psaux"
Option "Emulate3Buttons" "no"
Option "ZAxisMapping" "4 5"

Section "InputDevice"
# generated from default
Identifier "Keyboard0"
Driver "kbd"

Section "Monitor"
# HorizSync source: edid, VertRefresh source: edid
Identifier "Monitor0"
VendorName "Unknown"
ModelName "Seiko"
HorizSync 30.0 - 75.0
VertRefresh 60.0
Option "DPMS"

Section "Device"
Identifier "Device0"
Driver "nvidia"
VendorName "NVIDIA Corporation"
BoardName "GeForce 7150M / nForce 630M"

Section "Screen"
Identifier "Screen0"
Device "Device0"
Monitor "Monitor0"
DefaultDepth 24
Option "TwinView" "0"
Option "metamodes" "1280x800 +0+0"
SubSection "Display"
Depth 24

it only had the screen and device sections before and those were incomplete. However, I still cannot get the display to stay at 1280x800. Whenever I rebooted after using the recovery console the screen still defaulted back to 800x600. I am at a real loss here.

July 21st, 2009, 03:06 PM
I have the exact same card and have been having the same problem with the resolution not staying. The only way I have found that seems to work is to go to System>Preferences>Startup Applications and create a new instance.

Call it Resolution or whatever you will be able to easily remember what it is........(just in case you need to change it later)

Then type the following where it says command:

xrandr -s 1440x900

with the 1440x900 replaced to whatever you would like for your resolution to be when it starts up. (make sure it is something your card and monitor are capable of, obviously)

The only problem with this approach is that you can actually watch your screen change resolution a couple of times during initial log in, however like I said, this seems to be the only way I can find to get it to work for the moment.

July 21st, 2009, 04:10 PM
The "metamodes" thing that the Nvidia drivers puts into your xorg.conf, doesn't seem to do anything. When I bought a new monitor and graphics card, I had to manually switch my monitor to the correct resolution via the Nvidia program EVERY SINGLE TIME I BOOTED.

So, under Section "Display", I added the correct video mode. So here's that part of my xorg.conf:

SubSection "Display"
Modes "1920x1080"

Now it always works at the right resolution. It looks like that's what you'll need to do too.

July 21st, 2009, 04:16 PM
Open terminal:

gksudo /usr/bin/nvidia-settings

That will let you save your new settings as root.

Tried this?

Have heard of this working for people in the past :)

July 21st, 2009, 04:26 PM
I do not know about the OP but as I stated I have the same card and changing the xorg.conf and also starting nvidia-settings as root did not seem to work for me. It is almost like something is forcing the video card to revert to whatever it deems "native" resolution to be at start up.

@OP - Whatever works for you make sure you let us know, as I am sure there are others out there looking to figure this out as well......

July 21st, 2009, 07:25 PM
When I downloaded 8:10 i couldnt get the resolution right so i went to 9.04 and i could now see the desktop at startup but it was very fuzzy and grainy and when I tried to change the resolution, the whole screen turned blue. I got tired of dealing with it so I just went back to 8.04 and all is fine now. I can say that 9.04 works fine on my laptop which is newer than my desktop. My laptop is a year old and my desktop is 5 yrs old. Dont know if that has anything to do with it.

July 21st, 2009, 08:53 PM
Ok, I have tried all of the above ideas but to no avail. I am really losing my mind here. I switched from Slackware so I wouldn't have to endlessly tweak every little setting but it seems like I can't win in that even. The only thing I have not tried is devildoc5's suggestion. I am about to say screw it and just try that. This is just soo frustrating. I wish that my computer could just work :(

Chemical Imbalance
July 21st, 2009, 08:59 PM
This happened to me a couple days ago.

First go into System, Preferences, Display. Ignore the warning about the vendor's graphic tool or whatever then choose the correct resolution.

Now go into the Nvidia X Server Settings and make sure the resolution is set correctly there too. Then log out and in again.

It was a conflict between the two that was a problem for me. Just make sure they both have the same resolution set.

July 21st, 2009, 09:19 PM
Awesome! Thanks a lot. I tried it and it worked like a charm. Only my resolution in the display wasn't any different then my resolution the nvidia settings (they were both set to 1280x800). I went to system > display and when prompted I selected no when asked if I wanted to use the nvidia X server, I then clicked on the resolutions and changed from 1280x800 to a random res and then back to 1280x800 and clicked ok. Then I went to the nvidia X server and did the same thing (without using the "save to x button") and clicked ok and then restarted the computer. It boots up into the right resolution now! Thanks again and I hope that this will help others as well :)

July 21st, 2009, 09:29 PM
btw how do I thank people and how do I mark this thread as solved?

Chemical Imbalance
July 22nd, 2009, 12:49 AM
btw how do I thank people and how do I mark this thread as solved?

You cant thank anymore. They removed it due to database corruption and server strain.

No problem. It took me a while to figure it out :) .

July 22nd, 2009, 01:10 AM
to mark it as solved you should be able to click the down arrow next to thread tools at the top of the page and mark solved......

July 22nd, 2009, 07:34 AM
Nope, I only have "Show Printable Version", "Email this thread", "Subscribe" and "add poll". There is not a selection for solved.

Chemical Imbalance
July 23rd, 2009, 01:27 AM
Nope, I only have "Show Printable Version", "Email this thread", "Subscribe" and "add poll". There is not a selection for solved.

Solved is also gone, like Thanks.

You can add a solved tag to it though.