View Full Version : [ubuntu] Problems updating a kernel

July 21st, 2009, 01:17 AM
Hey all,

So i've recently decided to configure my own kernel, but have been doing little more than giving myself numerous headaches and making me wonder why i ever bothered.
However, having nothing better to do with my time leads me to keep trying :-P

After having no luck with building (i copied my /boot/config-2.6.28-13-generic over to /usr/src/linux- and tried
sudo make all && sudo make modules_install && sudo make install; cd /boot/; sudo mkinitramfs -o initrd.img-; sudo update-grub; , but that still didnt work), i tried much of the same thing with, and have gotten the same error at bootup:

Kernel Panic - Not Syncing: VFS: unable to mount root fs on unknown-block(0,0)

I trawled through /boot/grub/menu.lst just to make sure it was mounting the correct filesystem, etc. etc. and by the looks of things it was all good - which really only leaves the possible explanation of removing my hard-drive drivers from the kernel, but i just straight copy-pasted an existing config file, so that should be no issue.
I dont believe it's anything to do with hardware; im able to boot into 2.6.28-13-generic with no problems (and i havent bothered booting into *-11-generic, but ill also assume that that works).

Does anyone have any ideas on what's going wrong?

July 21st, 2009, 02:22 PM

July 22nd, 2009, 08:44 AM
gah, cant someone help?! i hate bumping my own threads!