View Full Version : [ubuntu] Monitor: Unknown cannot change resolution

July 21st, 2009, 12:42 AM
First post, w00t. Now that's out of the way, I am a life long Windows administrator looking to learn about linux based os's. I've tried installing linux in the past (two years ago), but had so much trouble and no resources providing clear information, so I gave up out of frustration.

I've decided to give it another go and I'm still having problems. I don't have a dedicated box to run this on, so have the latest version of Ubuntu (9 something) installed on a virtual pc 2007 sp1. I know some of you will just say, "Install Sun's VirtualBox." But I am not looking for another virtualization solution. I'm the type of person that if there's a problem, I want to fix it, not throw out the baby with the bath water.

With that being said, my physical pc is running XP Pro SP3. My issue is I cannot for the life of me figure out how to change the resolution in Ubuntu. I have spent 3 straight days (not an exaggeration) on trying to figure this out. I have tried System-Preferences-Display, but it states that the monitor is unknown, the refresh rate is 0Hz, and the highest resolution is 896x600. I have tried editing my xorg file, updating the system, running the command "sudo apt-get install xorg-driver-fglrx", and other things that I cannot recall.

My physical pc is using a cheap ATI Radeon X300. When I run the command "lspci -nn | grep VGA" in Ubuntu I receive the following: 00:08.0 VGA compatible controller [0300]: S3 Inc. 86c764/765 [Trio32/64/64V+] [333:8811]

I'm not familiar with linux commands or lingo so any "dumbed down" help is greatly appreciated. Thank you for taking the time to read this! :) Again, I apologize for a repeat thread. I know you all see this stuff over and over again.

July 21st, 2009, 12:48 AM
Look in System > Administration > Hardware Drivers

See what it suggests for a graphics driver and enable it.

July 21st, 2009, 01:25 AM
Ah, that's one of the things I tried and forgot about. There are no drivers listed, "No proprietary drivers are in use on this system."

July 22nd, 2009, 12:50 PM
A lot of what I have read deals with modifying the xorg.conf file. What I found is that mine is rather short compared to what I've seen. I've tried adding different modes and other things to different sections, but there was no change. This is what my xorg.conf file contains:

# xorg.conf (X.Org X Window System server configuration file)
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
# Edit this file with caution, and see the xorg.conf manual page.
# (Type "man xorg.conf" at the shell prompt.)
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
# Note that some configuration settings that could be done previously
# in this file, now are automatically configured by the server and settings
# here are ignored.
# If you have edited this file but would like it to be automatically updated
# again, run the following command:
# sudo dpkg-reconfigure -phigh xserver-xorg

Section "Device"
Identifier "Configured Video Device"
Driver "vesa"

Section "Monitor"
Identifier "Configured Monitor"

Section "Screen"
Identifier "Default Screen"
Monitor "Configured Monitor"
Device "Configured Video Device"

Literally, that's all it contains. I take it I should install the driver for the video card, but I don't know which: the S3 that it detected from the "lspci -nn | grep VGA" command or for the ATI X300 on my physical machine, and I have not been able to locate clear instructions for a straight driver install. I'm not asking anyone to hold my hand, I'd just like something to point me in the right direction.


Mark Phelps
July 22nd, 2009, 08:39 PM
First of all, there are no restricted video drivers for an X300 that work on Ubuntu 9.x. AMD/ATI dropped support and the only option now is the open source drivers -- which are installed by default. So, if you're getting video now, that's the best you're going to get.

Second, if you really want to learn about GNU/Linux, especially being a Sys Admin type (don't feel bad, I'm one myself), using a virtual machine is not the best approach. You'll suffer performance problems and, as you have already seen, you'll have to deal with an additional interface layer. You would do better to install dual-boot to separate Linux partitions.

July 26th, 2009, 07:23 PM
Thanks for the reply Mark.

I installed Sun's VirtualBox and got Ubuntu up and running. Max resolution is still 800x600. The command "lspci -nn | grep VGA" produced something different this time: "00.02.0 VGA compatible controller [0300]: InnoTek Systemberatung GmbH VirtualBox Graphics Adapter [80ee:beef]"


Forgot I had to install Guest Additions. Took me a little bit to figure out how; wasn't working how guides showed it would. The resolution is bigger now. The xorg.conf file still has the same contents. If I want a different resolution than what is provided, will it work if I add the resolutions to this file?