View Full Version : [gnome] After Updating a Woking 9.04 Upgrade, Black Screen Upon Login

July 18th, 2009, 09:09 AM
I started with an 8.10 install, and upgraded to 9.04. Everything worked as well as could be expected for a couple of weeks.

A few days ago, I noticed updates were available, so I ran the update tool, and rebooted.

Boots up fine, but on logging in, the screen goes black, with a normal white mouse pointer. The pointer moves, but otherwise seems to do nothing.

I can get a terminal with ctrl-alt-F1, shutdown -r 0, and at the login choose to change to a failsafe gnome session. That starts fine, and in fact I am accessing this site through FireFox in the failsafe session.

I'm prepared to re-install 9.04 from a CD if necessary, but I'd really rather learn how to track down what's wrong and fix it.

At the very least, I'd like to find the log that tells me what's happening as I boot up and login to gnome.

I'm running on an AMD cpu and an NVIDIA video board.

I'll appreciate any pointers I can get.

October 12th, 2009, 06:30 PM
I have exactly the same issue - any news on this?

November 1st, 2009, 05:10 PM
Im looking for a fix for this as well.

November 22nd, 2009, 03:44 PM
I have the same problem. I found one site that has an answer but I am afraid to use it. The only difference is that I can access Gnome by selecting a kernel from GRUB (doesn't matter which one i select) and Gnome will start up. I use the recovery mode "xfix" and that also starts up Gnome. The site that I mentioned is:


I haven't done this yet because I do not want to blindly remove something that I have no idea what problems it might cause. So if you are willing to do this go ahead and tell me what results you get.

November 22nd, 2009, 04:45 PM